DVD-RAM Drive not detecting CDs

vbimport

#1

Hi,

I have a HP Pavilion Dv6156EA Laptop. It has a Matshita DVD-RAM UJ-850S drive. Recently this problem started occurring.

Drive is able to read DVDs absolutely without problems. But when I put CDs (of any type), the Cd is shown as empty. No data on the cd is accessible. It shows that Cd is empty and 702 MB free space is available.

Could someone please help?!

Thanks!
Shush


#2

dvd drives have 2 seperate lasers , 1 for cds & another for dvds , sounds like the cd one went bad , but to be 100% sure its not any os issue , set the bios to boot from the drive & insert some bootable cd (the windows one will be a good choice)


#3

This may also be a firmware problem.

Easterbunny has posted some good advice there. Try booting up a bootable CD (such as a Windows installation CD-ROM) from dos. If it doesn’t boot up then try re-installing the firmware.

If that doesn’t have any effect either, then try cleaning the laser with a CD/DVD lens cleaner disc.


#4

:disagree: You should not use a cleaner disc for a computer DVDRW drive. Unless it is a slot-in drive, notebook drives are rather easy to clean using a soft brush as used for camera lens.

Michael


#5

What about half-height drives?
Do I need to open them? :eek:


#6

i’d just open the tray , turn off the psu or disconnect the cord and blast it with canned air


#7

I shall try to boot from cd. Meanwhile I am also trying to find the firmware. But not able to get anything. Any suggestions?


#8

Hi,

Good idea. My personal favourites are Knoppix or Ultimate Boot CD.

Meanwhile I am also trying to find the firmware. But not able to get anything.
This problem is not firmware related, but a hardware issue. If booting from CD fails, then the CD part of the drive is probably dead. In case your notebook is still under warranty, then have the drive replaced.

Michael


#9

Yup, try to boot from a CD or try to access CDs from SAFE MODE.

I doubt its an firmware isue here, because it has worked before…


#10

This is the reason why I suggested re-installing the firmware. Because I’ve experienced a sudden disc reading problem before with one of my drives which mysteriously fixed itself after re-installing the firmware. :eek:


#11

Hey, this is a Panasonic OEM drive. Getting firmware for these is nearly impossible :frowning:


#12

Re-installing the firmware can fix nothing.

ÄIf the firmware is broken, they drive would be dead already.


#13

Well, this is what I did. I reinstalled the drivers for IDE and now the drive detects a few CDs. But, not all of them. I tried the ones which did not work on mine on my friends Laptop and they worked fine. Any suggestions?


#14

Time to clean the drive and discs.


#15

New problem chef blank DVD-R’s not being detected! What do I do?


#16

Not detected where? In explorer??

Just open an tool like Nero or Imgburn and try to check the disc (info).


#17

Well, I wanted to burn a DVD-R using Nero 7. It said no disc, whereas I had placed an empty DVD-R. The disc info also said no disc detected.