DVD playback through USB 2.0

vbimport

#1

I have connected a DVD rom drive from Pioneer via a IDE-ATAPI/USB converter box to my PC. I can only play unencrypted DVD’s through the USB interface, but on another machine using the same software I can play encrypted DVD’s using the internal IDE DVD rom drive.
Any clues to solve the problem would be appreciated.
Also if it for some reason just is not possible I would like to know why.

Both machines run linux mandrake 9.1.

Thanks in advance for any help


#2

Now I have tried the same experiment using windvd on a w2k machine. The video gets decoded now.
This changes my question slightly:
Why can windvd play a DVD movie through USB 2.0, but the open source programs (I’ve tried ogle, vlc and mplayer) can’t.
The output from the open source DVD players indicates that they start reading the DVD disc ok, but the reading blocks or stalls indefinitely before actual playback starts. However as stated in my first post, the same programs can play the movies without problems using the internal DVD rom drive.

Please, can anyone explain this to me or provide good links that may provide an explanation.

Thanks