DVD Playback problems, PLEASE HELP!

Please forgive me if this has been posted, I have been scouring the net all day and have yet to find a solution to this problem

When I try and play a regular (non-burned) DVD video on my computer (it is a 6 month old Sony Viao Laptop with a pentium-M processor) the audio/video playback is extremely slow and choppy.

Please help!

So far I have –

  1. reduced my screen resolution
    2 reduced my color quality to 16 bit
  2. ran msconfig and disabled all start-up programs

I read a thread about a person having a similar problem after installing Nero… I have Sonic, but it came with the computer. I haven’t ever watched a dvd on this computer, so i don’t know if it would have been due to a program I installed.

Last thing, if I try and play any other video format, DiVX/AVI/etc, i have no problems at all.

Any help would be GREATLY appreciated

Your DVD-ROM is probably running in PIO mode, instead of the required UDMA.
You’ll find the setting in Device manager, under the IDE Controller entry (properties). There’s 2 indications, first the selected status and second, the actual status. If the first is set to PIO, change it to DMA and reboot. If the first is set to DMA, but the second shows PIO, then you need to uninstall the IDE controller and reboot. Windows will re-install the controller on start up and it should be in DMA.

After fixing DMA, use VLC tool for playing back DVDs and run dxdiag to check overlay and other settings.

You could try Nero’s CD-DVD Speed & try a burst rate test. You should get about 23mbs as the rate.

The other possibility is on the graphics side which seemed to be where you were heading. Are you using the correct video drivers. I had this problem some years ago where my graphics card couldn’t support the display rate required. This won’t be a problem these days but the drivers could be a problem.

I ran the test and only got a burst rate of 1mbps… This drive is seriously messed up. DMA is indeed selected, and I ran dxdiag, but it comes back as no problems (didn’t do anything other than type in dxdiag into the ‘run’ bar. It has to be a software conflict as I rolled back my system to months ago and it works fine. What am I missing?

DMA may be selected, but is it actually running in DMA?

Uninstall the IDE controller that the drive is on and reboot. After Windows re-installs the controller, try again.