Dvd Fab Subtitles

I`ve processed a disc Wolverine and the subtitles appear for all talking including english and japanese. it seems like for hearing impaired. As far as i know my settings in dvd fab are correct. Any clues?:wink:

It looks like you have “English forced” checked .
I’m not planing to use DVDFab 9 so I can’t say what “English normal caption” does.
Do you have just English as a choice ?

[QUOTE=cholla;2717721]It looks like you have “English forced” checked .
I’m not planing to use DVDFab 9 so I can’t say what “English normal caption” does.
Do you have just English as a choice ?[/QUOTE] Yes thats ticked, but i think i tried it that way with both before, but ill untick forced and try again. I`ll let you know. Thanks:bigsmile:

[QUOTE=deezalboy;2717724]Yes thats ticked, but i think i tried it that way with both before, but ill untick forced and try again. Ill let you know. Thanks:bigsmile:[/QUOTE]No, that didnt work, subtitles for all speaking. I don`t get it.:bigsmile:

I believe the problem is in the media player and not in the copy. Check the media player options to see if subtitles are being selected during playback. FYI the “forces subtitles” are subtitles that appear where foreign dialog is spoken with the tranlation shown as a subtitle.

[QUOTE=EEngineer;2717821]I believe the problem is in the media player and not in the copy. Check the media player options to see if subtitles are being selected during playback. FYI the “forces subtitles” are subtitles that appear where foreign dialog is spoken with the tranlation shown as a subtitle.[/QUOTE]Thanks, i see your point, but the subtitles appear on all players. The subtitles have text that says e.g. panting-engine noise-aircraft droning. Looks like hearing impaired subtitles to me.:wink:

I hear what you are saying,I have a couple of media player ie: powerdvd 9, which for some reason defaults on startup to display subtitles… check your media player and make sure subtitles are not selected.

[QUOTE=EEngineer;2717905]I hear what you are saying,I have a couple of media player ie: powerdvd 9, which for some reason defaults on startup to display subtitles… check your media player and make sure subtitles are not selected.[/QUOTE] Yes, i can put subtitles on and off. If i select off i get no subtitles at all. When i want subtitles, in Dvd Fab i select normal captions and get what looks like hearing impaired subtitles as you see in my photo. Both English and Japanese shows subtitles for what they are saying, and that shouldnt be, it should be for just Japanese because we can understand what Hugh Jackman is saying. Im trying to get subtitles on a copy where language other than english is spoken.:wink:


Try just English forced checked nothing else.

Is is possible that you ripped the version for the hearing impaired ?
That is the only reason I can think of that there would be sound descriptions .

[QUOTE=cholla;2717908]Try just English forced checked nothing else.

Is is possible that you ripped the version for the hearing impaired ?
That is the only reason I can think of that there would be sound descriptions .[/QUOTE]I think i tried forced, ill give it another go but not all have forced. I havent ever seen hearing impaired only visual impaired. Yes, sound description, thats the way to explain subtitles for all speaking, particularly when subtitles are there for e.g Hugh Jackman. ill get back to you. By the way i copied not ripped, probably that`s what you mean? :iagree:

The definition of "[B]ripped[/B] I’ve seen means;
Ripped(copied) from an optical drive to a harddrive.

I use “[B]dubbed[/B]” for this but I have seen "[B]ripped[/B] used:
Copy from one optical drive to a different optical drive . Also called “[B]on the fly[/B]” .

“[B]Copy”[/B] can be any type [B]copy[/B] such as from one harddrive to another harddrive .

I checked my copy of The Wolverine. If subtitles are enabled then the forced has only the Japanese to English .
The normal English has the sound descriptions . This appears to be the way this subtitle set is written.
So the only way to have it not do this would be to find a subtitle set that doesn’t have this on the internet . Then download & install it. I haven’t done this on a DVD movie & only to play around in other formats. Some member with a lot more experience at this would be better than me to help you with that. You might even have to extract the copy on this movie & edit it. Too much work IMO unless you really need it.

This may be a problem with DVDfab media player… sometimes on just some discs when actual audio is played, I may hear the French version even though the English is shown to be selected. I wonder if the same thing might be happening to the subtitles. If I try to correct the situation by selecting the French audio…then the DVDfab media player, plays back English ok… but the copy on other players will play back French. Maybe try with the 8.xx series DVDfab and see if that corrects the subtitle problem.

[QUOTE=cholla;2717972]The definition of "[B]ripped[/B] I’ve seen means;
Ripped(copied) from an optical drive to a harddrive.

I use “[B]dubbed[/B]” for this but I have seen "[B]ripped[/B] used:
Copy from one optical drive to a different optical drive . Also called “[B]on the fly[/B]” .

“[B]Copy”[/B] can be any type [B]copy[/B] such as from one harddrive to another harddrive .

I checked my copy of The Wolverine. If subtitles are enabled then the forced has only the Japanese to English .
The normal English has the sound descriptions . This appears to be the way this subtitle set is written.
So the only way to have it not do this would be to find a subtitle set that doesn’t have this on the internet . Then download & install it. I haven’t done this on a DVD movie & only to play around in other formats. Some member with a lot more experience at this would be better than me to help you with that. You might even have to extract the copy on this movie & edit it. Too much work IMO unless you really need it.[/QUOTE] Thanks, that`s explains very well. :bow:

This movie is 126 minutes (well the Canadian version) and the Main Movie you have chosen is only 121 minutes. Check the other titles to see if you have one 126 minutes in length as DVDFab may be selecting the wrong title for main movie.

If DVDFab selecting wrong title for your region DVD then DVDFab needs an update to handle the AU version

Also should be able to have both forced and regular subtitles on DVD and be able to select to only show forced but that is something DVDFab media player does not give for a choice.

To only have forced subtitles then that all you need select when you copy the DVD but DVDFab 9 seems to be having problems with subtitles right now and may be better to use DVDfab 8 till fixed

[QUOTE=AGJ;2718010]This movie is 126 minutes (well the Canadian version) and the Main Movie you have chosen is only 121 minutes. Check the other titles to see if you have one 126 minutes in length as DVDFab may be selecting the wrong title for main movie.

If DVDFab selecting wrong title for your region DVD then DVDFab needs an update to handle the AU version

Also should be able to have both forced and regular subtitles on DVD and be able to select to only show forced but that is something DVDFab media player does not give for a choice.

To only have forced subtitles then that all you need select when you copy the DVD but DVDFab 9 seems to be having problems with subtitles right now and may be better to use DVDfab 8 till fixed[/QUOTE]Thank You. I dont really understand what you mean re "selecting wrong title for your region". Ive tried another movie and it has subtitles on the original but Dvd Fab doesn`t give any option for forced captions. I tried Dvd Fab 8.2.3.0 but got the same result of sound description for all languages.:slight_smile:

Only some movies have “Forced” subtitles even when they have foreign language scenes . If the movie doesn’t have this type sub then the forced option won’t be available.

[QUOTE=cholla;2718074]Only some movies have “Forced” subtitles even when they have foreign language scenes . If the movie doesn’t have this type sub then the forced option won’t be available.[/QUOTE]Ok thanks, i`m learning.:bigsmile:

[QUOTE=cholla;2718074]Only some movies have “Forced” subtitles even when they have foreign language scenes . If the movie doesn’t have this type sub then the forced option won’t be available.[/QUOTE]I now have an activated paid Dvd Copy version never to expire and therefore only using Dvd Fab and Imgburn.
So, ive tried lots of things spending many hours to try and get captions/subtitles for just the language other than English in the movie. The following is what ive tried and results, selecting in the subtitles drop down in Dvd Copy.
(1) Selected Normal Captions together with English Forced captions-Result>Captions for both English and Japanese at the same time as they speak. Also, sound descriptions/captions such as plane or car revving. (2) Selected English normal captions-Result (same as (1)>Captions for both English and Japanese at the same time as they speak. Also, sound descriptions/captions such as plane or car revving. (3)Selected English Forced Captions by itself-Result>No captions at all.
Played them all on Dvd Fab Media Player and subtitles are set to English.
So, i understand that people get subtitles/captions in this movie for just the Japanese language and nothing else.
Therefore, i appreciate anyone who has success with this and to show me what settings they use.
All help is welcome.



@ deezalboy , The copy of Wolverine I’m working with is a full size DVD9 with menu removed . It also was ripped with only the English track but this has some Japanese on it. I kept all the language subtitles . This rip was done with AnyDVDHD & CloneDVD2 . The original DVD disc was region 1 USA.

Using the above opened in DVDFab 8.2.3.0 & compressing to DVD5 so I could write(burn) it with the ImgBurn in DVDFab . That is what is in the images I’m posting .Burned to a Verbatim DVD -RW single layer.

Using DVDFab Media Player :
The first image is on the first “English” selection DVDFab Media Player has . This is “English forced” . It show the English for the Japanese the man is speaking . It has no English subtitles.

This image shows DVDFab Media player set to the “English” second position. This has both the English subtitles with descriptions/captions & sometimes as the image shows it has “Speaking Japanese” right before a “forced” subtitle is used.

This is how I set the rip with DVDFab:

Everything seems to be working as it is supposed to so I don’t know where the problem you are having is coming from.

When I tried this in VLC the subtitle tracks were not correct but with what appeard to be the incorrect selection worked.




[QUOTE=cholla;2718552]@ deezalboy , The copy of Wolverine I’m working with is a full size DVD9 with menu removed . It also was ripped with only the English track but this has some Japanese on it. I kept all the language subtitles . This rip was done with AnyDVDHD & CloneDVD2 . The original DVD disc was region 1 USA.

Using the above opened in DVDFab 8.2.3.0 & compressing to DVD5 so I could write(burn) it with the ImgBurn in DVDFab . That is what is in the images I’m posting .Burned to a Verbatim DVD -RW single layer.

Using DVDFab Media Player :
The first image is on the first “English” selection DVDFab Media Player has . This is “English forced” . It show the English for the Japanese the man is speaking . It has no English subtitles.

This image shows DVDFab Media player set to the “English” second position. This has both the English subtitles with descriptions/captions & sometimes as the image shows it has “Speaking Japanese” right before a “forced” subtitle is used.

This is how I set the rip with DVDFab:

Everything seems to be working as it is supposed to so I don’t know where the problem you are having is coming from.

When I tried this in VLC the subtitle tracks were not correct but with what appeard to be the incorrect selection worked.[/QUOTE]Some say English forced and others say just English or other, some say turn on subtitles/captions in Dvd fab media player and others say no.
Ive tried everything and dont find a way to just only get subtitles/captions for the Japanese speaking, nothing else. I`ve tried English normal captions with English Forced and get captions for all speaking, tried English forced captions by itself and got no captions.:smiley: