DVD Drive will not work in DMA Mode

Windows XP SP3
DVD Drive: Pioneer DVR-115D, 80 way IDE cable.
Mobo: ECS P965T-A

I have tried everything. I had this working properly with an older XP installation (I am sure I added some sort of jmicron driver), then I moved to Vista and it did it all for me. No hassle at all. Now I am back with XP and it just will not work.

Things I have tried:
Modifing the registry for the secondary IDE
uninstalling the drive
uninstalling the secondary IDE
Jmicron drivers: jmb36x

All I have now is micron drivers I cannot uninstall at all. They just keep getting reinstalled at every windows startup. I have 3 secondary IDE, one of which my drive appears to be on, in PIO mode permanently and 3 primary IDE, one of which is my Sata 2 HD

So the questions are:

  1. How do I get rid of this micron driver permanently
  2. Does my motherboard even use micron?
  3. Why was it working before and why is there an issue now?

Any help appreciated. I have given up. On another note, I do wish manufacturers would use proper names for their motherboards instead of all this P965T rubbish. It just confuses everyone.


I just found this link and will give it a try…

well believe it or not…that link did the trick. So that should be noted. The P965T ECS motherboard is an annoying time waster that requires [B]those specific [/B]Jmicron drivers for the DVD drive to function in the correct way.
:slight_smile:

[QUOTE=seifer almasy;2408443]The P965T ECS motherboard is an annoying time waster[/QUOTE]
I’ve heard being an annoying time waster is a standard feature of ECS products.

Glad you fixed it yourself [I]seifer almasy[/I] by using google. :clap:

You get what you pay for and in general speaking any ECS mobo is a big bang for the buck.
Problem is, by introduction of ICH8 mobos manufacturers forgot that IDE cd/dvd drives still exist.
(Note though, ICH8-M supports atapi/ide drives.)

The first Jmicron 36x version the JMB361 (same type as on OP mobo) supported hdd raid arrays nicely, not an common ide drive though, although all knew Jmicron by design supported one ide channel with atapi drives.
In my opinion $ntel is to be blaimed not ECS. Abit, Asus, Gigabytes and all the other mobo makers that failed to realise ide burners still existed but they didn’t care.