DVD drive spins up and down, but end with not recognizing any DVD movies in the drive

vbimport

#21

I guess the next step would be to contact Sony tech support directly. Nobody knows their products better than them, after all.


#22

That is what I didn’t want to do :frowning:

This laptop is Hong Kong bought, and they don’t support it outside Hong Kong, unfortunately.

I wonder what would happen if I e-mailed them, though. I’m going to try that.


#23

Probably fake/reject garbage with no factory warranty, unless you’ve purchased from and authorized dealer in HK and could convince Sony that you’ve moved to another country.


#24

I bought the machine from a Sony showroom, so it’s definitely not a fake. Problem is that it is 1.25 years old now. And I think, if anything, it’s covered for only 1 year.


#25

Has your problem been solved?

I had a similar problem with my Toshiba laptop combo drive and after much frustration, I tried one last thing, I blew some air over the opticals and essentally ‘dusted’ out the drive. That seemed to do the trick. Just don’t blast the air too strong directly at the optics as you can knock them out of alignment.

I was advised not to use a drive cleaner so this dusting took care of the problem.

Your discription sounded so much like my own that I thought this simple cleaning exersice might help.


#26

I have just realised that my drive doesn’t recognise original software DVDs. I just bought Command and Conquer, and it doesn’t work.

I might have to try that dusting trick. What if I wipe the drive optic clean? Or do I have to use a duster?


#27

I wiped the drive optic clean, and my original Command and Conquer works.

But it still has some problems reading some DVDs (originals). I only have a couple of DVDs, but I will try and borrow some originals.


#28

I have the same problem with my pcg-k35 laptop. I can’t watch any dvd’s at all. I had the laser replaced and still don’t work. I wish someone would tell me what the problem is.


#29

I spent a few days on this problem. I even took apart my drive and adjusted the laser intensity…which did nothing but make it worse. So I set it back. Eventually I decided if the spin up was going to be annoying, perhaps what I could do is stop it from spinning up. So, I got a program to set the CD-ROM max speed. There are several free ones. Mine is called RimhillEx. Odd name, but it did the trick.

Now, since I set the limit down to 2x, it can’t make annoying spin up sounds and in fact the problem went away entirely. For anyone else running into this issue, my guess is that the motor is faulty, or the capacitor that regulates the current needed by the motor has drifted out of spec and therefore the voltage drops when it is spinning up. That latter part is just a guess though. Leaving it at the lower speed solves the issue though. I do wonder if putting an electrolytic capacitor on the power rail of the motor would eliminate the issue without reducing speed…?


#30

Okay so get this…aftger posting, I reset without that program running. The CDROM still works fine (BTW this is a DVD/CDROM model TS-L632 from Toshiba. Max speed is supposed to be 8X. It never dawned on me that the spin up was well in excess of 8X. In fact, it sounded like it was about to take off the runway. 8X should sound rather quiet. By comparison, this sounded like my old 52X CDROM from the 90s. Now it seems to be quiet even without the adjustment software running.

For even more accuracy, I tried putting in a similar drive before this btw. I think it is worth mentioning for completeness that it has to be a hardware/firmware issue/setting.on the drive itself. I replaced it with an identical drive from a laptop made the same year that I use for other stuff and that drive worked on the same computer flawlessly(even before I messed with speed setting software). So in short, the drive has somehow had it’s speed set to 50 trillion X. Set it back down with the correct software and it should work fine. I now have it set to 8x(which is the max speed for that model) and guess what? It runs at 8x flawlessly. No more spin headaches!