DVD Drive not refreshing disk info

Just found you guys after searching for an answer to a frustrating issue with my system. The dvd drive, Samsung 16e, will not refresh disk information when I change dvd or cd disk. I can press F5 in explorer til’ the cows come home, the only way to get it to see a new disk is to reboot the system.
Win XP Pro, service pack 2.
Athlon 3200
1.5gb ddr 400
4x 120gb Maxtor eide
Samsung 16e dvd
TDK 440n dvd/rw
Abit NF7 v2.0 Mobo
Antec 480 watt True Power Supply
Tried another drive, Aopen Combo, exactly the same. TDK dvd/rw does the same.

Any thoughts out there guys?

yeah, i know, you see the contents of the last accessed cd/dvd in explorer even though you have inserted a new cd/dvd. sux. my solution was to uninstall all my ripping/cloning/burning apps/virtual drives except for nero. no more refresh trouble. i suspect it was alcohol 120% or blindwrite suite [ both very crappy programs IMHO ]

Thanks Ghosters, gonna give it a go. Funnily enough, got both of those proggies, and yes, they are crap…

… another workaround … just have a look in your registry, if following entry is missed,
. . just write it in … works fine for me (XP Pro, SP1)

. . [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom]
–>“AutoRun”=dword:00000001

  1. Enable Auto Insert Notification for CD Drives
    Some programs will disable this default setting to play inserted CDs automatically! Roxio applications do this; for example! To re-enable this functionality >>>
    � Navigate to the following Registry key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
    � Double-click Autorun
    � Make sure the value is set to “1” under Value Data.
    � Navigate to the following registry key:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer.
    � Double-click "NoDriveTypeAutoRun"
    � Make sure the value was set to “91” under Value Data.
    � Close the registry editor
    � Restart your computer.
    You should now be able to pop in a CD, and WinXP should pop up the autoplay menu and attempt to autorun the CD.
  2. Disable AutoRun for the CD-ROM
    One of the easiest ways for a hacker with physical access to a company’s PC’s to distribute malicious code is via the CD-ROM. By creating a custom CD with a payload set to launch from the AutoRun feature in any machine, a hacker can affect any number of unlocked systems without ever leaving a fingerprint or touching a keyboard. Or he/she can simply leave a few of these lying around the office marked “MP3’s”, or “Payroll Data” and wait for an unsuspecting user to simply pick it up and insert it into their machine. You can disable this function in WinXP Professional by
    � Clicking Start > Run > and type GPEDIT.MSC
    � Go to Computer Configuration > Administrative Templates > System > Locate the entry for Turn AutoPlay off

Please let us know what finally cures your problem by posting back.
Good Luck and as you can see: we are all wishing you the best of success on this glitch! :rolleyes:

Km, welcome to the forum. I hope you can cotribute valuable information here to others. However…

This thread is nearly 4 years old. I doubt the OP will be letting us know if the problem is gone now…

Also, you start off describing auto insert notification but only give details on auto run. These are 2 completely different things. If you carefully read your #2 again, you will see that it has contradictions.

I noticed that you pasted this same exact answer on 2 other very old posts. It’s ok to reply to ancient posts if you have new info, but some of your info was already stated.

RM