DVD drive not recognising when disk inserted

vbimport

#1

I am having a problem installing a DVD drive (or two) under Windows XP Pro.

Situation is as follows:

Installed fresh version of XP Pro using CD-ROM and then later replaced this with a DVD R/RW drive (Cibox DVD Dual 16x double layer). This ran fine for about 2 weeks and then started refusing to play previously OK DVDs giving a format not recognised error.

I swapped drive into another machine and it refused to recognise any CD/DVD placed in drive even though Windows Device Manager didn’t report any problems. Window Explorer gave the following message when trying to explore drive ‘Please insert a disk into drive D:’. Same thing happened when I swapped drive back to original machine.

I returned drive to the shop and they ran a diagnostic which indicated a read problem - sorry don’t have any more information) and was given an Emprex DVD Dual 16x Double Layer as a replacement. I have now found this same problem of not recogniseing when disk inserted with the new drive.

Other symptoms I have noticed:

  • attempting to install XP with DVD drive instead of CD drive fails as drive is not located.
  • on original machine following error message on reboot before XP startup page appears: ‘Searching for Boot Record from CDROM…’
  • Green LED flashes when attempting to access drive through Explorer and when a CD/DVD is inserted.
  • Occasionally the CD icon appears on mouse pointer for 1/2 second indicating to me autorun is being attempted but again never completes action.

I have tried the following:

  1. Complete re-install of XP Pro from scratch including SP1 and SP2 (and also without SPs).
  2. Checking cable by replacing DVD drive with CD-RW (CD-RW works fine).
  3. Placing new drive in different machine (same result).
  4. Updating firmware (updated from www.drvupdate.com to A089 version of firmware from A082 but no joy).
  5. Searching forums and reading FAQs and checking Microsoft support pages but although there are similar problems nothing seems to quite fit.

Apologies if this is a question that has an obvious answer but I am running out of solutions (other than returning this drive as well). I have searched the forums and read the FAQs/ READ ME threads but still can’t pinpoint the problem.

Hope you can help.

Paul