DVD drive not beeing detected

Hi all,

I have a laptop with an internal DVD drive [LG DRN8080B]. Until now it was working perfectly, but for some reson, Win XP does not seam to recognise it any more. I don’t remember uninstalling anything from my system… :confused:

I was not able to find a driver for the drive on the net [only DOS drivers]. Does anyone know if there is a universal DVD driver that will work under Win XP?

Thanx in advance.

Cheers,
steff

Steff,

check if the ASPI layer is properly installed.

Thanx for your swift reply BoSkin,

I have checked the ASPI driver, and everything looks good.

Win XP is also showing my DVD driver as “Unknown hardware”… :confused:


Please read ForceASPI v1.7 in my sig and try it out.

Well,

Sorry, did not work… I have tried uninstalling the ASPI layer and installing it back again, without any succes. :rolleyes:

By the way, the download link on the pagina in your sign is dead.

Cheers,
Steff

Originally posted by steff

By the way, the download link in your sign is dead.

I’ve just revived it, check it out. :wink:

:slight_smile: The links works alright now… but I have tried the software without any succes. As I sad before, I have tried killing the ASPI layer and reinstalling it, but it didn’'t help. :a

Since it seems that it aint an ASPI issue I would try uninstalling the corresponding IDE controller from system devices and reboot - let the OS reinstall it and that may do the trick.

Thanx for your suggestion Hemispasm.
I am sad to say, that it did not work… :frowning:

Is the drive getting any current? Does the tray open? Is it recognised under BIOS?

The tray is opening all right and the BIOS is detecting it. I can even use it in DOS without a problem… it’s definitely a Win XP problem.
As I cannot find a driver for the drive, I was wondering if there was a universal DVD drive driver for XP. The only other thing I can think of is, taking the drive out, rebooting and then putting the drive back again. Hopefully XP is going to recognize the drive… who knows. :confused:

I could be a ide driver problem. try reinstalling them

Originally posted by steff

As I cannot find a driver for the drive, I was wondering if there was a universal DVD drive driver for XP.
Goto : C:\WINDOWS\system32\drivers

and make sure if the following drivers are available there :

cdrom.sys
imapi.sys
redbook.sys
.

Thanx again for your replies guys…

I have checked, the sys files you mentioned are all there :confused:

I have also tried reinstalling the IDE drivers without success…

Perhaps, the drivers are corrupt?

You can try to test this by deleting those drivers and see what happens.

Just make sure you do a couple of things first:

  1. make a bootdisk so you can undo what you’ve done (or get a NTFS supporting bootdisk from Bootdisk.com
  2. make a backup of the deleted files
  3. make a copy of your Windows CD on your harddisk, as you may need it to get the CD Drivers back again…

Good luck and please don’t blame me if your Windows dies because of this… it’s just that I can’t think of anything else causing this problem (call it a last desperate attempt)…

Try out this link (found through a greek forum):

CD-ROM Access Is Missing and Messages Cite Error Code 31, Code 32, Code 19, or Code 39 After You Remove Easy CD Creator in Windows XP

This has been a solution for several users whos problems wasnt related to ECDC anyways.


SYMPTOMS

After you remove either compact disc (CD) recording software or other software from your computer, your computer may exhibit the following behavior:
In My Computer, there is no access to your CD-ROMs.
In Device Manager, the following error message appears in connection with any CD-ROM device that is part of your computer system:

The device is not working properly because Windows cannot load the drivers required for this device (Code 31).
Device Manager displays the following error message:

A driver for this device was not required, and has been disabled (Code 32 or Code 31).
You may also receive an error Code 39 message that indicates that the driver is corrupted.

Device Manager displays the following error Code 19 message, which means that the registry returned some unknown result:

Your registry might be corrupted. (Code 19)
You may also receive the following error message:

Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41)


System Information :

Start > Run > In the Open box, type msinfo32.exe > System Summery >

go through/check statuses in Hardware Resourses ( DMA, I/O, IRQs )
& Components ( especially Problem Devices )

Thanx guys,

Well I have tried the solution that Hemispasm suggested, but it killed my PC for a while. I had to use the last know good config to get it back to life. But it was worth a try…

I have not tried the thing Dee-ehn suggested YET, but I think I will… :a

Here is the sys info. It seams to be a Vxd problem, but which one? :rolleyes:


Originally posted by steff

It seams to be a Vxd problem, but which one?

VxD Loader returned an unknown result. For example, there could
a version mismatch between the device driver and the operating system .
Try removing the device from Device Manager and then running the Add New Hardware wizard in Control Panel.
Update Driver !

With this I’ve just walked into the new, 3th, “millennium”. :smiley:

I have tried that… no luck!