DVD Drive locked to region 1!

vbimport

#1

Hi,

I’ve been backing up my region 2 dvd’s for a while now as I’ve been getting them, and bought some region 1 dvd’s. . When I opened them with DVD Shrink it asked me to change the region for my dvd player (Pioneer 110). Like a fool, I did. Now it will only play/backup R1 movies! When I put a region 2 one in, I can’t play it at all and DVD shrink asks me to change the region code again. It said “Your dvd recorder only allows you to change the region one more time.” I try to change it to R2 again, but it say’s Region change failed! What should I do?

P.S I have tried re-installing dvd shrink, and have downloaded this program-
http://www.remoteselector.com/driveinfo.htm

When I run it, it says the drive is locked to region 1, the user has 1 change left and manufacturer has 4


#2

Ok, I just updated my firmware from 1.17 to 1.37. Now, when I try to play the R2 dvd with power dvd player it comes up with error message-
ESDI driver or ASPI manager is not compatible"

and when I try to open the disc with DVD Shrink, the analysing box comes up and then say’s -
DVD Shrink encountered an error and cannot continue, Failed to read D:/, overlapped I/O operation in progress.

Please somebody help quick! Thanks.


#3

But the aspi is installed on your system? You can find the wnasp32.dll in the windows system folders. Also for your region problem you can try a rpc1 firmware, but keep in mind it’s on your own risk.
http://tdb.rpc1.org/index.htm
Also to have region free discs you can try AnyDVD.


#4

I’ll try the firmware now, What do you mean about the Wnasp file. I’ve managed to find the file in windows/system but what do I do with it?


#5

Ok, The firmware from the link worked, Thanks a lot, my drive is now region free :smiley:

However, I’ve still got the problem with power dvd with the ASPI thing. Can you sort that out for me? Thanks


#6

Does this only happen with powerdvd?
Have you tried some other player software like Vlc or media player classic both are free?
It could be that a reinstall maybe solve that with powerdvd. Also you can download for sure a newer aspi file. Just google for it you’ll find it.


#7

Hey,

I’ve tryed downloading another ASPI file, but when I click on install it say’s a ASPI drivers are already fully installed and fully working. Would prefer to use Power dvd player,but will give VLC a try. Have also tried re-installing power dvd


#8

Just tryed and VLC Media player works fine, But I’d prefer to use Power DVD as it is better for DVD Movies.


#9

Cause i don’t know what version you’re using i’d recommend you to have a look at the FAQ’s for PowerDVD. Here


#10

Thanks rapid fire, managed to get everything sorted out :D:D


#11

Nice to hear that. :wink: