Dvd drive has disappeared

vbimport

#1

hi everyone. i don’t know if this is the right forum to be posting in, but here goes. recently, my dvd drive and my cdrw drive have disappeared from my computer. for some reason, the computer just won’t detect them. they’re not in windows explorer, media player won’t find them, nothing can find them. they still open and close and spin discs so i don’t think they’re broken.

here are things i have tried -

1)update the drivers. this i found to be an impossible task because nothing on my computer can detect the drives and liteon seems to have all of their tech support pages in chinese.

2)going to device manager and uninstalling the drives and rebooting. the problem with this was that even device manager can’t find the drives.

3)opening regedit and deleting the upperfilters and lowerfilters of the cd/dvd keys and then rebooting. i didn’t have upperfilters so i just deleted the lowerfilters. i rebooted but still nothing.

4)opening setup before windows loads and setting all drive detections to automatic. they were already all on automatic. so this resulted in nothing.

i’m running windows xp w/service pack 2. i have an athlon2500xp with 512mb ram. the dvd and cdrw drives that are missing are manufactured by liteon.

i’m at the end of my options here. does anyone here please have any other ideas on how i could fix this frustrating problem before i just reinstall windows? thanks in advance.


#2

Have you tried reseating the cabling?


#3

yeah, i’ve tried that. no dice. the drives are recognized in the bios, just not xp for some reason.


#4

Have you tried booting into safe mode as Administrator as per alan1476’s advice?


#5

yep. booted into safe mode and went into the administrator account, and the same thing. the drives aren’t found under windows explorer or the device manager :confused:


#6

Another quick try solution would be a system restore back to a time before the problem first appeared. Did you install any programs around this time?

To exclude a dying drive, try shutting down, remove cables from the slave drive and startup again. If still nothing shows up, try the other drive by shutting down moving the connected cable and molex power connector to the other drive making sure the drive is set as a master. Although they’d probably not get recognised in bios if this were the cause.
If none of these fixes work you’d probably be quicker in the long run backing up any irreplaceable data to an external hard drive (providing XP picks it up!!) and doing a repair install.


#7

Sounds like yet another “upper filter” and “lower filter” registry fix. I think it’s about time for a sticky thread for this issue.


#8

thanks for the help. unfortunately i think my computer is completely beyond repair at this point. i’ll just have to format and do a clean install. system restore has never worked properly for me - there’s never any restore points to go back to. i tried to do a repair install when i booted from the disc, but my computer then informed me that it can’t do that because apparently i don’t have a hard drive. this thing is messed up. thanks for you help anyway.


#9

Do you have a SATA hard-disk? You may need to install drivers to get windows to recognise the hard drive.


#10

i do have a sata hard disk. i have the drivers for it on a floppy. i tried putting that in during the boot and nothing happened. i think i might be doing something wrong though. it’s been a while since i’ve had to use this floppy diski with the sata drivers on it for anything.