DVD Decryptor working at .6x speed?

vbimport

#1

I am currently using DVD decryptor to rip my dvds. It is taking an obsurd amount of time. The actual read time averages about .6x. Im pretty sure I should atleast be breaking 2x. I have read about others having great success with their usb cases so Im not sure that is the problem. All of the dvd’s I have tried have taken a good 2-3 hours which is longer than the movie itself. I am using a NEC 3500 drive in an external case with a usb connection. What am I doing wrong? I also tried dvd shrink which took about 2 hours per dvd which also seems long. A friend of mine rips in about 30 mins with a POS computer and an older NEC drive. I have read the guides with no luck. Anything would help. If more info is needed just let me know.

Thanks


#2

Open Device Manager
Expand the IDE ATA/ATAPI Controllers branch
Uninstall the IDE / ATA Controller entry
Reboot your pc.


#3

Gave it a try. Didnt fix it. It did all the reinstall and then i rebooted and still got transfer rates of .6-.7x


#4

Are you using USB 1.0 or something?!

Sorry, I didnt see the bit about USB in your first post, DMA doesnt apply to those drives!


#5

btw, you’d be much better off putting the drive inside your pc on a proper IDE channel if at all possible!

You’ll never max the drive out in a usb case, for some reason they just cant cope with the transfer rates they’re supposed to be able to!


#6

Given its a laptop I dont think I have any other way. newegg wont let me return the case because 30 days has passed which means no firewire case for me.

As far as I know I am using usb 2. The computer is an alienware laptop purchased in 2002.

any other ideas?


#7

You never said it was a laptop - hence the reason I covered my ass by saying ‘if possible’ :wink:

well I’d go looking for updated chipset / usb drivers. Does the board use an Intel chipset? Their drivers are easy to find!

If you look at the usb branch in device manager, does it actually say ‘usb 2’ anywhere? It probably will do if it’s usb 2. Mine shows up as ‘Intel® 82801EB USB2 Enhanced Host Controller - 24DD’. Microsoft actually do a little tool to show you how your device is connected. It’s called ‘USB View’. I’m sure you can find it if you search google.

Then again, windows XP (if that’s what you’re running) should pop up a message if you connect a usb 2 device to a usb 1 port.

When you’re ripping, I assume the buffer is always at 0%? If it’s not, that would indicate the problem was actually with something to do with the hdd.

Can you copy stuff off the dvd using explorer any quicker, or does it always take ages to do anything with the drive?


#8

May have found the root of the problem. Under the “Universal serial bus controllers” pulldown I have ‘Intel® 82801 CA/CaM USB Enhanced Host Controller - 2482’. It says nothing about USB 2 on there. How can i fix this? Sorry if I am sounding completly computer illiterate. This is just not part of a computer I ever mess with. USB that is…


#9

Well now we know it’s Intel, goto the Intel website and download the ‘chipset’ drivers. It’s called infinst_enu.exe

http://downloadfinder.intel.com/scripts-df/Detail_Desc.asp?agr=N&ProductID=816&DwnldID=7948

Install those and reboot your machine when prompted.

Then go check device manager again and see if anything changed.

If it didnt, uninstall everything from the USB section - ensure nothing is plugged in that’s using USB - especially the drive!

Then reboot your pc again. You might find it then uses a different driver - hopefully that’ll say USB2 somewhere!


#10

Well, for the past 3 years now I have assumed I had USB 2. I guess I am wrong. Looks like I have to invest in one of those pci cards to gain usb 2.

Thanks for all of your help. Even though my problem has yet to be solved, you have saved me about 10 days worth of sitting here straining my eyes trying to figure out why the usb 2 that i really dont have isnt working.


#11

I am assuming this is what I need to have usb 2?


#12

it might still be usb 2.0, because my usb controller under device manager doesn’t mention anything about usb 2.0, but i know it’s 2.0. you should probably call up alienware if you don’t know how to verify if it’s 2.0.


#13

Yeah, yours does say ‘Enhanced Host Controller’. That ‘Enhanced’ bit normally means it IS USB 2.0.

I mentioned a utility called ‘USBView’ earlier, you can get it from the link below.

http://www.k0lee.com/dc3000/usbts.htm

Run that when your drive is plugged in and see where it ends up. Maybe you could post a screenshot or something when the burner is the selected item.


#14

Here is a screenshot of it. Just to toss it in… when I turn on my drive i get a message saying if I plug it into a highspeed usb 2 i would get better performance. Either way here it is…

Given I only have a mouse and the drive currently in usb ports I am assuming the last one “device connected: usb mass storage device” is my burner.


#15

Right yeah, that’s the message I mentioned earlier!

The ‘Enhanced’ bit seems to have gone from your USB controller string too.

So I guess that means you’re only USB 1.

Time to get looking for that USB 2.0 card then I guess :wink:


#16

Well… looks like I am wrong. I do not have usb 2.0 on my laptop. I was running my drive on usb 1. I purchased a pcmcia card today to give me usb 2 and when used i got 4.4x writing out of my 4x disks. Overall I am very pleased the problem has been fixed. Thanks for all the help finding out what the problem was. As of right now, DVD Decryptor is running flawless. I am ripping/burning dvds withing 30 mins. I am ripping between 2x and 4x and burning at a speed over what the disks I am using are rated at. Thanks again Lightning, sorry to put your software on the hotseat.


#17

Glad to see you’re up and running properly now :slight_smile: