DVD/CD Drive Major Malfunction

vbimport

#1

I don’t have a NEC drive, but I have major problem I think you guys can help me with… I can’t fix the DVD/CD-ROM drive for my Sony Vaio laptop.
Here’s a list of things that are wrong with it:
1. It wont respond to the manual eject button.
2. It only ejects if I click the eject command from the CD-ROM drive icon in My COmputer.
3. It does not recognise any type of disk (CD, DVD, Blank media, etc.)
4. The LED never lights up, even during restart.
The laptop is only a month old, it’s brand new. I tried burning data to a blank DVD-RW with Nero 5.5, however Nero would only give me the option to burn CDs but not DVDs (the options were all greyed out.) After giving up, I finally used the crappy burning software that came with the Sony (Sonic Record Now!) with no problem. Everything went smoothly and after 20 minutes, I had a shiny new data disc. The next day, the problems began, and now I’m here.
Here’s a list of things I tried:
1. Uninstalled the drive in device manager, rebooted.
2. Uninstalled the Secondary IDE channelin device manager, rebooted. In both cases Windows XP reinstalled it, but the DVD/CD-ROM drive still has the same issues.
3. Deleted the Lowerfilters (no Upperfilters were present) at

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318} and also at ControlSet001 and ControlSet002, rebooted. Still nothing.

Under the DVD/CD-ROM properties, it says the device is working properly. I dont get any error messages when I click the Explore or Open commands from the DVD/CD-ROM Drive Icon in My Computer, and it just opens the drive like a blank folder, whether it has a disc or no disc in the drive. Everything in the Hardware device manager seems to work; there are no little yellow attention symbols or the like. DMA is enabled.

Any Ideas?? :confused:


#2

If it’s new, then reformat the HD and retest. If problem persists, then get a new replacement.

Multiple installation of CD/DVD burning software can create such a problem. Use windows system restore to revert back to a previous configuration. Continue to go back until you fix the problem.


#3

If it’s brand new then you are still covered under the warrantee! Call sony and get it replaced with a brand new one. This is obviously a hardware issue if the drive doesn’t give any activity information at post and anything occuring from within windows is just a result of this. :iagree:


#4

Thanks for your help guys