Dvd burning speed slower than it used to be

Hi there,
My dvd burner is SONY DVD ±RW DW-D56A.
I used to burn dvds at 6x max speed. But now I can burn them at only 0.45x to 1x max. It takes hours to burn a dvd now. Its so frustrating. Please help me.
Is it because I used Safedisc Hider 4? I used this to play NFSU.
Thanks in advance!

Hi and welcome to the forum :slight_smile:

Check if DMA is enabled. Sometimes windows revert to PIO mode without any advice to the user

i went to other forums and checked, it is enabled. thanks for your help.
i also tried resetting the epprom … it also doesn’t work…any idea?

Try to get rid of this and see if it solve

Have you checked your hard disk for fragmentation recently, always helps to keep things running sweetly.

thank you for your help guys!
yes geno888 i did got rid of that thing. still same problem.
and chriso, what does it has to do with fragmentation of my hard drive. i dont understand…is there any relation with cdrom?
and anyone please let me know that if there is any other way to check dvd burning speed without wasting my new empty dvds.

Use Nero’s CD-DVD Speed & do a burst rate test with a bought DVD-ROM inserted. You should get 23mbs or so if all is OK.

If not then you’ve not got DMA enabled - it’s not just DMA if available , it’s current transfer mode being UDMA2.
Or replace the IDE cable with a good quality 80wire (Ultra DMA 66/100/133) cable.

Also I assume that the DVD writer is master on it’s own IDE channel & not slave on the HD’s IDE channel.

thanks timc,
i checked it, i DMA is enabled and it still has low burning speed.
how do i know that it is master on its own IDE channel?
btw i am using laptop, dell inspiron 6000.

use nero infotool: it say many informations on your system configuration.

You can find here

http://www.cdspeed2000.com/go.php3?link=download.html

If the files you are burning are on the hard disk, and scattered all over the place, then there would be a slowdown as the HDD would be unable to pass information to the buffer fast enough.

However, I doubt it would make the amount of slowdown you have described. It might be worth watching the CPU Usage % whilst burning, to see if that is where the problem is (i.e. at or near 100%).

As the others have said though, it could just as easily be a dodgy IDE cable (in which case try a new, 80 wire one) or incorrect DMA setting (in which case simply change it, also make sure the BIOS DMA setting is correct).

Ciao
Chriso

ok i think i found the problem…please see the attached images…there is a conflict.
see the infotool, it says DMA is off but when i check the secondary ide properties there is use DMA if available, but its PIO only. how do i change it to UMDA2?
I appreciate your help guys, thank you so much!



check if you need to enable DMA also in BIOS

i didn’t see any options in BIOS to enable DMA, so i uninstalled the secondary IDE channel restarted, changed the ‘PIO only’ to ‘DMA if available’, restarted again and now i have UDMA2. YAY!!
thank you guys, the shitty problem was DMA afterall.

Good to hear it’s all going again.