DVD burning awfully slow

Hello All

I am facing an awfully slow experience in burning DVDs, its taking almost 3 hours to burn a 4.7GB DVD. My desktop is a Presario SR1620NX with an HL-DT-ST DVDRRW GWA-4164B DVD drive. The driver provider is Microsoft and the version is 5.1.2535.0 (dated 7/1/2001).

I had to re-image this machine recently, before that I had the same slow experience but the machine was in warranty and HP support had given me a driver update (which I lost) that resulted in tremendous performance improvement. For the same support now they are asking $99. Really appreciate if somebody can provide expert opinion.

thanks in advance
Alok.

Really burning only??

Then enable DMA mode, check my sig.

Welcome to the Forum a_lok , do as chef has advised and I am almost sure your problem will disappear. This is a fairly common thing, if your drive slips into PIO Mode your burning capabilities will slow to a crawl.:iagree:

thanks chef and alan1476.

I followed the link in your signature. Heres the info from device manager on IDE ATA/ATAPI Controllers

Primary IDE channel
Device 0
transfer mode - DMA if available
current transfer mode - not applicable
Device 1
transfer mode - DMA if available
current transfer mode - not applicable

Primary IDE channel
Device 0
transfer mode - DMA if available
current transfer mode - Ultra DMA Mode 5
Device 1
transfer mode - DMA if available
current transfer mode - not applicable

Secondary IDE channel
Device 0
transfer mode - DMA if available
current transfer mode - not applicable
Device 1
transfer mode - DMA if available
current transfer mode - not applicable

Secondary IDE channel
Device 0
transfer mode - DMA if available
current transfer mode - PIO mode
Device 1
transfer mode - DMA if available
current transfer mode - not applicable

Based on the info from the link, I guess the first secondary channel is for the DVD burner drive?
The second secondary channel seems to be for the removable drive which is PIO mode.

any ideas?

thanks
Alok.

Secondary IDE channel
Device 0
transfer mode - DMA if available
current transfer mode - [B]PIO mode[/B]

Do you have SATA harddisk(s)?

I have IDE harddrive

Then the hdd should be there:

Primary IDE channel
Device 0
transfer mode - DMA if available
current transfer mode - Ultra DMA Mode 5

that motherboard has sata support, look in device manager for your hard drive id

ide emulation?

Hi,

Your HDD, possibly SATA

Device 1
transfer mode - DMA if available
current transfer mode - not applicable

Secondary IDE channel
Device 0
transfer mode - DMA if available
current transfer mode - not applicable
Device 1
transfer mode - DMA if available
current transfer mode - not applicable

Secondary IDE channel
[B]Device 0
transfer mode - DMA if available
current transfer mode - PIO mode[/B]

And this is your DVD writer.

Device 1
transfer mode - DMA if available
current transfer mode - not applicable

Michael

so looks like my DVD writer is indeed in PIO mode, any idea how can I change it to DMA mode. The transfer mode is selected to ‘DMA if available’. May be it requires a driver update? I searched web for hours for HL-DT-STDVDRRW GWA-4164B driver to no avail

thanks
Alok.

Set Pio to DMa in the drive properties.

can you please let know how to do that, I looked up in the links in your signature too, couldnt find it, appreciate your help

one more note that, I already tried changing the transfer mode to PIO and back to DMA and rebooted the computer, but the current transfer mode still shows PIO.

Read this: http://club.cdfreaks.com/showthread.php?t=101616

Michael

the problem is fixed now!

thanks chef, alam1476, DaChew, mciahel for taking time to respond to my problem, really appreciate it.

Heres is the summary:

  • DVD drive was burning very slow (3hrs)
  • as suggested in the thread, downloaded the vbs script on the link above (Resetting DMA using VBS script)
  • executed the script, and rebooted the computer
  • channel now shows as DMA and speed is down from 3 hrs to 25 minutes for 4.7GB DVD

go club cdfreaks!

Hi,

:clap: Fine you got it sorted :slight_smile:

  • channel now shows as DMA and speed is down from 3 hrs to 25 minutes for 4.7GB DVD
    25 min is still very slow. What speed are you setting for burning? With modern media, 8x should be fine, so the plain burn process would take about 8 minutes.

Michael

hmm… actually it is at 16X. The DVD playtime is 2 hrs 53 mts. The DVD is from Sony (16x)

Alok

Is this plain burning time, or is ripping also included in the 25 minutes you need for processing now? If ripping is included, then you’re fine. Plain burning should be about 6 minutes @16x (max).

Michael

ok it included the rip time.

thanks for the input.
Alok.