DVD Burner IRQ conflicts/ bsod

Hi guys,

I recently built a new HTPC, and everything seemed to be running sweetly.

I have started ripping mt DVDs to hard drive using DVDFab 5 and again, no problems. I was using the single DVD writer the LG 20x and progressing well.

I then purchased 3 more units (LG 22x this time - the 20x’s were out).

I managed to do 1 complete simultaneous burn - which I now suspect might have been lucky.

I’ve tried subsequent simultaneous burns, and I get BSOD’s… at various stages - in some cases just setting up the job, and not ac tually burning.

The bsod message I received is;

DRIVER_IRQL_NOT_LESS_OR_EQUAL

STOP: 0x000000D1 (0x0000000C, 0x00000005, 0x00000001, 0xB9F135F7)

atapi.sys

In terms of setup, the 20x and one of the 22x drives are plugged into the 2 GSATA ports on the mb, and the others are plugged into the other SATA ports of which there are 6. (2 of these are occupied by the WD1TB HD and the other is the 4 port SATA adaptor - currently not being used).

I have disabled my parallel and serial ports and tried disabling the 4 port sata adaptor and the wireless Nic (Belkin) that I added to the original build - still no joy.

In the Bios, it appears that RAID is disabled and the interface for the SATA is set to IDE/SATA.

My original build is posted below. If anyone can offewr any insight, suggestions or answers, I’d be extremely appreciative. My hardware knowledge is limited - not quite a novice - and this is my first build, so please bear with me. I checked in Windows device manager looking for obvious conflicts but don’t see any…

Thanks,
gajit

1 Koutech IO-PSA420 32-bit PCI SATA II Controller Card

1 AVerMedia AVerTV Combo PCIe ATSC/NTSC/QAM TV Tuner Card (White Box)w/L-P Bracket 7 95522 96058 0 PCI-Express x1 Interface

1 ICY DOCK MB455SPF-B Multi-Bay Backplane Module - Retail

1 Western Digital Caviar Green WD10EADS 1TB SATA 3.0Gb/s Hard Drive -

1 SeaSonic S12 Energy Plus SS-550HT 550W ATX12V V2.3 / EPS12V V2.91 SLI Certified CrossFire Ready 80 PLUS Certified Active PFC Power Supply - Retail

1 LG 20X DVD±R DVD Burner w/ SecurDisc Tech Black SATA Model GH20NS15
1 COOLER MASTER Stacker 830 Evolution RC-830-KKN3-GP Black Aluminum ATX Full Tower Computer Case - Retail

1 GIGABYTE GA-EP45-UD3R LGA 775 Intel P45 ATX Intel Motherboard
1 CORSAIR 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 1066 (PC2 8500) Dual Channel Kit Desktop Memory Model TWIN2X4096-8500C5 - Retail

1 Intel Core 2 Duo E7400 Wolfdale 2.8GHz LGA 775 65W Dual-Core

1 HIS Hightech H465FS512P Radeon HD 4650 512MB 128-bit DDR2 PCI Express 2.0 x16 HDCP Ready Video Card - Retail

added:

3 x LG 22X DVD±R DVD Burner w/ SecurDisc Tech Black SATA
1 x Belkin Wireless NIC 802.11g

Have you set voltage correctly for your memory?
Try running mumtest86+ for a few hours to eliminate hardware (motherboard) and RAM issues as well as software.
You might want to try running in AHCI mode instead…
//Danne

Thanks Diizzy - you certainly get around these forums…

Hmmm… correct voltage? … I haven’t done anything specific for that, I just assumed it was the matched memory for the mb, so it would just work out of the box.

I’m not familiar with mumtest, but have downloaded it and am now running…

I’l let you know how i get on…

incidentally, I moved the sata connections around on the mb, i read that i should be connecting the opticals to the non-ich10cr ports, so they are now connected as 0-3 with the hard drive in one of the two GSATA connections…

I tried a reburn - and successfully managed 4 discs all in one go. I then loaded another 4 … and crash… bsod… so, again - I think the successful run is pure luck …

According to Corsair’s datasheet you memory will need 2.1V running at 1066Mhz (PC8500) which I’m not sure if your motherboard will provide by default. However it should also work with 1.8V if it runs at PC6400.
http://www.corsair.com/_datasheets/TWIN2X4096-8500C5.pdf

Have a look in BIOS and check what mode the southbridge uses, AHCI/Legacy/IDE etc
//Danne

Thanks again dizzy.

I ran the mumtest86+ for sometime and it hadn’t failed… i might leave it running overnight tonight to see what else comes up.

I’ll check the bios for the current memory settings (and the southbridge), but wouldn’t the mumtest fail if there was an issue there?

The interface is SATA/IDE i believe - you mentioned AHCI - isn’t that a problem is I change it now under Windows XP?

Yes, you would need to reinstall XP
//Danne

  1. What program are you using to burn?

  2. Is Service Pack 3 installed?