DVD booting problem with TSST (Samsung) SH-S222A and SH-S222L

vbimport

#1

I am having a strange problem with four new IDE DVD drives. They are the TSST Corp. SH-S222A and SH-S222L. All of them work wonderfully when installed in a working operating system. However on two machines, when I have tried to use them to boot from a DVD, they hang, and fail to go much farther than displaying the Windows “Hit any key to boot from CD…” message (if I am trying to boot any version of Windows). These two machines both have nVidia nForce 500 chipsets (Asus M2NE-SLI and M2N4-SLI). The drives WILL boot from a CD on these two machines. On SEVEN OTHER machines, a selection of Intel boxes, an SIS and a VIA AMD box, and so forth, the drives boot fine. I have reflashed the firmware to an older version, and back, to no avail, and tried every type of cable, and so forth. And, yes I have tried a wide assortment of DVD’s (DVD+R, -R, RW, and factory made disks). I wonder if anyone else has seen anything like this, and if there might be a newer version of firmware (newer than SB02), or some other fix. Or perhaps I missed something? Sadly the two machines having the problem are my own, the others are customer machines that happen to be hanging around. :sad: And, yes, the two problem boxes boot fine on any other DVD drive I may try.


#2

Hi and Welcome!

seems as if there are issues with that Nvidia chipset. Have you already flashed the latest motherboard bios? Also, what flavour of Windows do you want to install? In case of Windows 7, this is a controller/motherboard related problem which is only fixable by a motherboard Bios update.

Have you also tried a live Linux CD or DVD?

Firmware updates are available from here: (click), but I doubt this will help.

Also make sure you are using a standard compliant 80 wired flat ribbon cable (18"/45 cm, not longer) and have the jumpers set properly. You may try Cable Select (on both drives) instead of Master/Slave combinations.

Michael


#3

Yes, both motherboards have the latest BIOS. And, NO, this is NOT a Windows 7 issue. This problem happens before any specific operating system is installed. In fact, it happens if I try to boot memtest86, BartPE, Winternals ERD Commander, or Ubuntu from a DVD! Anything, if it will fit on a CD, boots perfectly from this drive. I thought this might be a DMA/PIO type of issue, but the drives work properly, although very slowly without DMA, on these two boards. Note that optical drives have to work initially in PIO mode when booting until protected mode drivers are loaded by an operating system. I also flashed older versions of the BIOS to one of these two boards without resolving the problem. So if it is a motherboard BIOS problem, it was always there and has not been resolved. I am still suspicious of the DVD drives because no other drive, at least the ones I have borrowed from other machines or found lying around, have this problem. Nor are there any references to this problem on Asus’ support forum. Samsung does not seem to respond to my support requests. As far as the cable goes, DVD drives don’t work faster or better with an 80 conductor cable. And, yes, I have tried a selection of cables, both the cable select variety and the old fashioned manually-set-the-jumper variety, both 40 and 80 conductor. It is definitely NOT a cable issue.


#4

Hey acemoab - I am having exactly the same problem with the SH-S222A drive. I have built several upto date xp Pro x64 Edition install discs and burned them to CD and to DVD. The CD’s will boot without a problem but not the DVD’s. They begin setup, although very slowly, and then BSOD with an error. Usually “File \xxxxx\xxxxxxxx.xxx could not be loaded. The error code is n”. Occasionally setup will get further and then BSOD and report that a file is corrupted. The annoying thing is that the DVD’s will boot under a VM running under xp Pro x64 Edition without any problem.

I am running an Asus A8N-Sli Premium board with the last available BIOS (1303) and have tried setting the BIOS to defaults, swapping DVD-Drives to secondary IDE channel and have run Memtest 86+ but without any success. Have emailed ASUS support about this problem but haven’t heard back from them yet. Having wrestled with this for a few days now I am thinking it is more likely to be a problem with the drive.

I am going to email Samsung about this though I doubt I will get a reply as I am sure they won’t be arsed with supporting a £15.00 drive.

Will let you know if I manage to solve this problem. Good luck!


#5

Hi and Welcome!

in case your motherboard supports booting from USB devices, you can transfer your Win7 setup stuff on a 4GB USB flash drive and install from there. See
http://technet.microsoft.com/en-us/magazine/dd535816.aspx and http://go.microsoft.com/fwlink/?linkid=166277 plus http://go.microsoft.com/fwlink/?LinkId=203056

This would at least rule out problems with the drive and the storage controller.
Installing Win7 on such older computers is often a pain - I myself have given up since the install disc wasn’t even recognized as bootable.

Additional idea: run Windows 7 Upgrade Advisor: http://windows.microsoft.com/en-US/windows/downloads/upgrade-advisor
and also check if your hardware is on the Win7 compatibility list: http://www.microsoft.com/windows/compatibility/windows-7/en-us/default.aspx

Michael


#6

To Michael:

I want to use the optical drive for installing on systems I build for customers and not force them into booting with a flash drive. This drive works on other boards, so it is a problem with the drive and/or the motherboard BIOS. I am leaning toward a drive problem because the drive is newer and the board works with the vast majority of drives. I want to solve this problem, not find a workaround, since I like this drive for other reasons.


#7

OldNewb:

Yes, you seem to be seeing the same problem I am seeing. Which is, the drive will work for booting and installing a virtual guest operating system since it is really using the host’s drivers and services even in “pass through” mode. The problem, as both of us see it, is only happening with the drive operating in real mode (textmode) trying to boot the real physical machine from a DVD. CD’s boot just fine. The symptom of the drive working, sort of, and reading some files, is exactly what I am seeing. This would be really strange if it weren’t repeating on two machines. I am thinking it is Samsung’s glitch.


#8

Very likely a controller Bios problem (which is a motherboard controller problem then).
I myself own a MSI K8T Neo2-FIR, with Via 8237 and an onboard Promise controller plus an add-on card with Silicon Image 3512A chipset.
A Windows 7 install disc is only detected as bootable in the drive that is connected to the SiI controller. Go figure.

Michael


#9

acemoab - I have solved my problem by installing an old LG drive. It works flawlessly which suggests that either the mobo BIOS cannot control the Samsung drive or there is a problem with the drive itself. It will be a shame if it turns out to be the drive as it produces good quality burns, rips well and very importantly to me is quiet. Still I can use it for all these things just not for booting.

Hope you find a solution to your problem and if I hear back from either Asus or Samsung will post the details.

Good luck


#10

Pretty old by now, but just in case it proves useful for someone … I encountered similar problems with a SH-S222L drive on a somewhat older Asus board. On that system I used S-ATA for HDD drive and IDE for two DVD drives, both on same secondary 40 pin black IDE port (with the first blue IDE port left unconnected).

For me it worked by setting the BIOS “Onboard IDE Operate Mode” to “Enchanced Mode” only for S-ATA, thus leaving the P-ATA in “Compatible mode” (there were three options for enchanced, P-ATA+S-ATA, P-ATA only and S-ATA only – I used the last one).

SH-S222L was with SB03 fw (the latest for it).

Cristi


#11

Probably due to a firmware glitch the firmware coders have not thought about such possibilities (ide mode etc)…