DVD/BD drive unable to read media

vbimport

#1

Hello, I’m struggling with a Laptop Drive, it’s a DVD writer+BD reader. Since some time ago it can’t burn DVD+DL anymore and it can barely read them, meaning that sometimes it reads sometimes not. I once tried to clean the lens and that did the job but not always.

Now I’m trying to play some BD movies and the drive changes to “CD drive” and stay there making noises trying to recognise the media. Cleaning the lenses did nothing.

I can’t think of anything else, I once changed the drive firmware so I could browse the BD’s and copy files from disc (UDF), after that everything has been a bit weird. Maybe also when plugging an external DVD writer…

Model is HL-DT-ST CT10N


#2

I do hope you used firmware from the manufacturer of your laptop. OEMs like Dell, HP and Acer often times use proprietary firmware revisions for the the optical drives in their laptops.

There haven’t been many laptop drives that have impressed us over the years. They are flimsy, and break often.

A full size external optical drive is usually a better option, though inconvenient and not very portable.


#3

well, after installing the UDF and seeing strange behaviour I reverted back to original firmware. So in principle it is the same as always but actually isn’t, something went strange on the flashing stage (had to shutdown, disable, enable, several times…)

I don’t know of any good drive debug tool, flasher, etc to start checking everything is fine.

I’m waiting to buy a BD drive to be released in Europe, but yes, I want to fix this, there’s also a funny thing, the external DVD writer can’t write SL DVD’s only DL. So whenever I need to burn a DL I need the external, and when SL the internal, it’s really weird, the external drive is also always spinning when I put a disc inside…
I’m clueless on everything related to optical drives issues so any help is welcome.


#4

Tell us the make and model laptop that you have and we should be able to find out if there is another, newer firmware revision for that drive. This may not exist, as the model number of the drive itself tells us that it is made by LG, and they aren’t exactly the most forthcoming with new firmware.

You say you added UDF…are you saying you added UDF reader to Windows XP operating system? http://www.videohelp.com/tools/UDF-Reader

Later versions of Windows have this capability built-in.

Have you run the Fix-it tool from Microsoft for optical drives? http://support.microsoft.com/mats/cd_dvd_drive_problems/en-us

Have you tried burning with ImgBurn? www.imgburn.com (be careful not to select any add on tool bar). This is the best burning program available.
It also has a tool within it to clear upper and lower filters. Start the program, click on Tools–>Filter Driver Load Order and remove the filters found there (don’t remove AnyDVD if you happen to have that program).


#5

Yes, Acer Aspire 6935G Laptop.
Yes I added that UDF from videohelp to XP.
The only reason I don’t use ImgBurn is because it lacks on file handling. It’s a pain to add, remove, edit files. But I can test on it and check if it makes any difference (on burning)


#6

Fix it didn’t fix anything.
I had this noted down on a txt:

The latest firmware for this drive is the A104 from Dell (dated 28.08.2009).

Your firmware is in fact the oldest one available for this drive (dated 11.08.2008) and Acer never released an update, so if you want to benefit form the latest firmware, you’ll have to crossflash to the DELL OEM firmware.

You can do that by flashing the main firmware (from here: CT10N_A104_dump.rar) using DevilsClaw’s Flasher (flasher_Win32_10252010_1142PM.zip). You don’t need to flash the core.
My problems are really beyond firmwares I think, because now I have the original stock firmware (supposedly) applied. The only issue could be that I flashed it back wrongly or something like that.
But since I don’t know how to check these kind of things… (check UDF, check firmware, etc) it can be whatever…

edit: I’m discarding lens issues since BD’s and DVD’s use different lenses, and I have problems with both. The other thing is AHCI configuration…


#7

I wasn’t able to find an update from Acer. Apparently they never released one. I did find this thread at The Firmware Page: http://forum.rpc1.org/viewtopic.php?f=32&t=47351#p230148

cvs posts here at MyCE and is far more knowledgeable about burners than I am.

Edit: I see you found the same thread.


#8

yes, sorry. I always note down relevant info on txt’s.