Dumping Firmware of Optiarc AD-7580S

vbimport

#1

Hello guys :),

that’s my first post here (although I’m a regularly reader) and I hope to get some help from you.Sorry, but this post will get a bit longer just to be as precise as I can.That’s my situation:

I’ve an older DVDRW burner “Optiarc AD-7580S” which is a OEM QSI Drive (Chipset MTK MT1859L).I’ve tried nearly all flash utilities out there to make a firmware dump.The bad part is, there is no flasher that supports this drive except the Windows flash utilities from Optiarc and the QSIFlash utility for DOS.After I examined the QSI utility,it seems that it has an option to make a dump.But this option doesn’t work.I think there is an internal VID/PID check for specific drive models and depending on the drive it decides which options to allow.Maybe I’m wrong,but that’s my first thought.

If you type e.g. “qsiflash.exe /h” or “qsiflash.exe /?” or something similar as usual, it doesn’t output much information about it’s supported command line options.After examination I discovered that it supports the following options to display some help/usage info: “qsiflash.exe /detail” and “qsiflash.exe /usage” (see QSIFLASH.TXT for output).On my drive only the options from the /detail output are supported and the other options do nothing,although they are shown.Now,my questions are:

  1. How to check if the unsupported options are just disabled or if they are just some left strings that they forgot to remove at compile time?
  2. What information about the drive would be needed to add support for this drive to binflash? Maybe I can help to get this drive working with binflash (if possible at all).
  3. Does somebody now a source where to purchase the MTK MT1859L?
    I contacted Mediatek but they say that they dont sell this chipset. OK,that’s enough for now. I would have two or three more questions,but this would be beyond the scope of this post.

Thanks in advance…


#2

I wonder … since this drive is based on a Mediatek chipset, maybe DosFlash might be able to produce a dump?

See the 1st post here: http://club.myce.com/f44/liteon-ihas124c-crossflashing-firmware-333397/ for some DosFlash details and links.


#3

Yes, I already know DosFlash and tried it in different ways. It recognizes my drive and seems to be ok,but when I hit “read flash” button it gives>>
“Dosflash error: No known flash chip on this port!”

It’s a bit strange because the drive uses a Winbond flash which should be known (I think). I also read on some Xbox forums that they figured out to get a dump, although they first got the same error. It was just a matter of timing e.g. switching the drive off and on at the right moment and so on. But with my drive things seam to be harder, because there is nearly no information on the net. I tried to find a doc/information about the Chipset, but nothing.

I must hope that perhaps someone gives me some hints and in the meantime I will try to figure out how the QSI Utility works.Maybe I get some useful imformation how the flash is accessed.


#4

Hey everyone,

I’m back with a possible solution, but I really need some help.
I got the sources from an MTKFlash based utility wich was written from a guy at MTK (as I could see from the sources).
It seems to be the original flash utility for my drive because the chip is mentioned in the sources.

I tried the utility on two different machines (Notebook with Intel SATA ICH9 Controller & Desktop with Intel IDE ICH4 Controller) and the results are the same,
the utility can’t enter MTK-flashmode.
The problem is that my C/C++ knowledge is very limited and therefor it’s difficult determine the cause.

It would be great if someone who has the knowledge (e.g. Liggy) would take a look at the code.
Maybe you can also take some useful information for binflash.


#5

I guess it’s not a matter of modifying the source code, but rather the drive that does not understand the command for entering the flash mode.

I wouldn’t mind having a look at the source code though :wink:


#6

I’ve sent you a PM for the sources. I hope that’s ok for you.

Maybe that the drive can’t understand the command on my Desktop PC but on the Notebook I assume that it can’t find the drive because it’s a newer controller and not listed by the flash utility.

If you have any suggestions how to proceed after you’ve looked at the code I would be happy.

Thanks in advance :slight_smile:


#7

Since the program is DOS based, I guess it won’t be able to access a drive when it’s in AHCI mode, so the SATA controller must be configured to Legacy, IDE oder whatever it’s called in BIOS/UEFI setup. However it should work fine with ICH4 as this one probably did not support AHCI.

I had a look at the BENQ flasher and it contained PCI-IDs from several IDE controllers - including the ICH4. Maybe the controller could be searched for in the other tool as well, but ICH4 and ICH9 are missing


#8

Generally it should be possible to flash in AHCI mode also in DOS , if the Utility supports it. The QSIFlash Utility is such a tool, it’s called “AHCI Firmware Update Utility” and it detects the drive in both modes, AHCI and IDE. But there is no dump option.

You are right, the MTK Utility is just for IDE mode. If you make a string dump you will notice that there is an entry for the ICH4 controller (it’s called “ICH4 3RD”).
I guess it’s meant ICH4 third generation, but I’m not sure.

I don’t know if it matters, but for my Desktop PC (ICH4) I must use an IDE to SATA adapter to connect the drive. It has a JMicron Chipset JM20330.


#9

Hello everyone,

after some weeks of investigation I analyzed the QSIFlash utility and some parts of the firmware which came with the utility.
I managed to dump some parts of my drives firmware (e.g. User Data, Boot Code…) and query some other information.
But there are some difficulties that I don’t get to work/don’t understand, since this is a new topic for me.
The most knowledge I will teach me on my own, but at some parts I need some support (e.g. my solution doesn’t dump all parts of the firmware…).
However, If someone has some spare time and likes to support me maybe we have very soon a nice Windows & Linux flasher for this OEM drives.

@ Liggy:

Ich gehe mal davon aus, dass du nichts brauchbares mit dem DOS - Flasher anfangen konntest?!
Wie dem auch sei, ich habe meine Aufmerksamkeit auch dem oben genannten Thema zugewendet und bin schon sehr weit gekommen.
Für den Fall, dass ich mich auch an dich wenden kann für gewisse Fragen bzw. Informationsaustausche lass es mich bitte wissen.
Falls nicht, werde ich dir dies natürlich auch nicht übel nehmen :wink: Bist ja sicherlich selber auch mit anderem beschäftigt.
Ich hab da jedenfalls die ein oder andere offene Frage welche ich nur per PM klären mag, da ich Infos teilen müsste, welche ich nicht
jedem preis gebe. Denke, du weißt wovon ich rede.


#10

I didn’t get very far with the DOS Flasher and also didn’t want to spend too much time on it. In case of questions feel free to ask, but I cannot promise any (valuable) answers. :wink: