Dsabling Autoplay - Nasty Side-effect

A couple of weeks ago I started a thread about how to turn off autoplay compeltely on DVD drives, in order to prevent DVd software from self-installing- & posted isntruction s for doein this which I had then found via Google.

I’ve just found a horrible side effect of this today- when I began copying DVDs to a new USB drive . All of my DL copies were giving read errors , even though they had previously worked OK. Further testing showed that the failure was always with the VOB file which spanned the layer break. Windos gave a read error with that file, and DVD player software froze when tested on that exact VOB.

Now the only change to my PC that I’d made recently was this disable autoplay thing - (and a side effect of turning autoplay off completely is that Windows no longer really knows what’s in the DVD drive e.g. it does not display a title and does not update explorer when you swap out DVDs.)
So I wondered if, because of this, windows was not properly aware that it was working with a +R DL copy.

So I’ve now reversed the Gpedit & related resistry settings so that autoplay is back to nomal & My DL copies are now usable again!!!

I don’t profess to fully understand it, but it’s a big relief to find that my DL backups are not corrupt after all ! ( It only affects copies I think, because I’ve played DL original movies on my PC OK since truning off autoplay & they were not affected )

Cybmole, thanks for posting this. I am having terrible problems burning DLs (they don’t finalize correctly). I turned off autoplay using a different method at about the same time this trouble started for me, but I can’t understand how autoplay could be involved in the problem I’m having. But I will turn it back on and see.

[QUOTE=signals;but I can’t understand how autoplay could be involved in the problem I’m having. But I will turn it back on and see.[/QUOTE]

it could be that windows becomes confused about what sort of media is in the drive.
just before I diagnosed my problem, I was about to Bin one DVD copy which seemed hopelessly corrupt &I now thank that was because essential title ifo data was on the 2nd layer & was not been read. In my standalone player it was fine, and it’s fine now in the PC.

maybe in your case windows is only finalising one of the 2 DVD layers - if that makes any technical sense ?

PS I had trouble turning autoplay back on - I ended up using a mircrosoft knowledge base instruction page that I found by putting “restore autoplay” into windows help.

This is darn peculiar.
For what it’s worth, I have autoplay disabled, but via TweakUI.exe…one of microsoft’s PowerToys.
TweakUI.exe
My DLs are flawless. I’m running XP Pro sp2.
Just to throw a monkey in the wrench, I have used GPedit in the past and had no problems with DLs then, but it’s been quite awhile.
I don’t see “how” autoplay is disabled, would make any difference, but I can’t see the connection with autoplay disabled and read errors either.

I’m not saying there’s not a cause and effect relationship here, just that my brain can’t connect the dots…:confused:
More voodoo at work?

Please keep the feedback coming.

@signals,
You must be loving this, I know how you love a good mystery!

Hahah yeah, but I prefer when it is somebody else’s mystery.:bigsmile:

Ok _ so it’s not actually cured all of my read errors ( I blame the usual combination of chaep media+ layer break problems ) so I have some DVds that played OK on a standalone player but don’t want to copy back onto the PC that made them.
BUt with one DVd, that was only about 5Gb, re-enabing autoplay now means that PowerrDvd & DVDfab both see it properly whereas before they were both failing to find the title screen ( which I guess was on the 2nd layer).

I think you have to look beyond the obvious function of autoplay & spot that when it’s disabled, and you then put in a different DVD, the windows OS receives no notification that the drive content has changed, so it could be working with a cache of part of the drives’ previous data content . The clue is that in MY computer you just see a drive letter and total file size - no volume name appears. and I think you’ll also observe that if you change DVDs, the file size displayed in My computer does not update.

that’s my current theory anyway.

as a related question I recell in a different thread a post saying that some DVDs will play ( in standlone’s) even though they wont copy due to CRC errors.
Is this true and could this explain why i “thought” that my customised DL backups were oK - because they played OK. ( NB they were made before Fab added the validation function )

and final question - there customied DL copies were made using fab to write from a hard drive copy ( made using full disc copy modeto C:/dvdfab) , so fab would have had to decide where to put the layer break. Would FAb have written a vob file so that it spans the layer break ?
All my copy problems occur with the 4th file in the set of 1GB file & I’m pretty sure that’s because the file starts on layer 1 & continues onto layer 2. I get the CRC error at the exact point in the copy where the drive tries to switch layers.

[QUOTE=cybmole;1923585]Now the only change to my PC that I’d made recently was this disable autoplay thing - (and a side effect of turning autoplay off completely is that Windows no longer really knows what’s in the DVD drive e.g. it does not display a title and does not update explorer when you swap out DVDs.)
So I wondered if, because of this, windows was not properly aware that it was working with a +R DL copy.
[/QUOTE]

That’s a different issue.

Disabling autoplay should not affect the detection of media changes so the cause is some sort of configurational problem elsewhere.

Did you disable autoplay manually or use TweakUI?

TweakUI is in my view the easiest and most effective way to disable autoplay.

It circumvents certain problems associated with doing it manually.

[B]Wombler[/B]

[QUOTE=Wombler;1923706]That’s a different issue.

Disabling autoplay should not affect the detection of media changes so the cause is some sort of configurational problem elsewhere.

Did you disable autoplay manually or use TweakUI?

TweakUI is in my view the easiest and most effective way to disable autoplay.

It circumvents certain problems associated with doing it manually.

[B]Wombler[/B][/QUOTE]
i thought I’d only used GPedit to disable autoplay, but to get autoplay back I had to also change a value via regedit (following microsoft knowledge base instructions) as well as reversing the Gpedit changes. Simply reversing the gpedit changes & rebooting did not work . I didn’t use tweak UI - with hindsight maybe I should have ! ).
There was another program recommended by amiga freak here:http://club.cdfreaks.com/f116/preventing-unwanted-autoplay-executables-230708/
, then un-recomended by others
I downloaded & opened it but I thought I’d exited without it making any changes Maybe that had made a registry change.

disabling autoplay your way - with tweak UI - do you still get the DVd title displayed in MY computer when you insert a disc ?

I am also checking this;)

I have submitted my DL problems to VSO via their support link. No reply yet.

If you do not want software installing when you insert a DVD have you guys ever thought about turning off [U][U]auto[B]run[/B][/U][/U] and not autoplay there is a difference you know

I am mixed up autorun and autoplay are two different things.:confused:

And can’t you just hold the Shift key down to prevent all forms of ‘Auto-XXX’?

[QUOTE=alan1476;1923769]I am mixed up autorun and autoplay are two different things.:confused:[/QUOTE]

What’s the difference between AutoPlay and autorun?

AutoPlay

AutoPlay is a Windows feature that lets you choose which program to use to start different kinds of media, such as music CDs, or CDs or DVDs containing photos. For example, the first time you try to play a music CD, AutoPlay asks which media player you want to use, if you have more than one installed on your computer. You can change AutoPlay settings for each media type.

Autorun

Autorun is a technology used to start some programs or enhanced content (such as video content on a music CD) automatically when you insert a CD or another media type into your computer. This is different from AutoPlay, but the result is often the same: when inserted, the CD starts automatically, using a particular program. Autorun is incorporated into the media types that use it, and you can’t modify it.

When you try to play a CD or another media type that uses autorun, AutoPlay asks you to choose an action to perform (for example, to play the autorun content or to skip it).
:cool:

Have a nice day:flower:

so how do you disable autorun only , as that’s the one which can install malware - is that possible ?

[QUOTE=StormJumper;1923762]If you do not want software installing when you insert a DVD have you guys ever thought about turning off [U][U]auto[B]run[/B][/U][/U] and not autoplay there is a difference you know[/QUOTE]

thanks for pointing that out. A lot of web site’s advice confuses the two, e.g. they recommend tweakui for autorun when it apparently only turns off autoPLAY .

I had not fully grasped the difference but I think I’m getting there now.
It seems that autoRUN has to be turned off via regedit ?

It also seems that it’s autoPLAY which affects the recognition of new media in the drive e.g. as per this posting which I just found

“As I’ve pointed out, TweakUI doesn’t keep the AutoRun feature from activating when you double-click on a drive in the Explorer to open it for file access. Using TweakUI to disable AutoPlay on a drive only keeps the automatic file scan from occuring.”

so the ideal set up for safe dvdcopying would seem to be

  1. autoPLAY enabled & set to launch DVDfab.
  2. autoRUN disabled

any feedback or anything else I should be aware of before I go for this configuration ?

PS I just tested the "hold down shift while inserting the DVD " trick.
using an original DVD which has an autorun file.
This method does work, but only if you continue hold shift for about 10 secs - let go too soon & the autorun still triggers.
So it will be safer to protect against rootkits & othe malware via a registry edit ?

[QUOTE=cybmole;1923722]disabling autoplay your way - with tweak UI - do you still get the DVd title displayed in MY computer when you insert a disc ?[/QUOTE]

Yes disc refresh still works perfectly.

It’s very simple to use too.

[B]Wombler[/B]

[QUOTE=cybmole;1924073]“As I’ve pointed out, TweakUI doesn’t keep the AutoRun feature from activating when you double-click on a drive in the Explorer to open it for file access. Using TweakUI to disable AutoPlay on a drive only keeps the automatic file scan from occuring.”
[/QUOTE]

Sorry for possibly pointing out the obvious but in Windows Explorer you only need to single click to view the contents.

Alternatively if you’re launching Windows Explorer from somewhere else then right click, explore.

It’s useful to have autoRun available for when you need it so I wouldn’t bother disabling the double click method. Just don’t use it unless you want to run the disc.

HTH

[B]Wombler[/B]

so tweakUI disables both autoRUN & autoPLAy simultaneously ?

the program only displays an option to disable autoPLAY but you reckon it actually does both ?