DRW1004 in non-Windows environment: post experiences here!

Though BTC has no support infrastructure in place for non-Windows environments, I would like to let people know about succesful experiences of endusers in Mac, Linux, etc. environments.

From a Mac User:
“…DRW1004im Definitely works on OSX computers with ‘Roxio Toast 5+’ running as the disk burning utility…”

From a Linux User:
“…I use Slackware Linux 9.1 with Linux kernel 2.4.22 on an Athlon XP 2000+ system…”

If you have similar experiences, please add them to this thread.

Thanks in advance for sharing your experiences.

Marco
BTC Europe Support

Hi all!

Would like to tell you that I have working
the BTC DRW1004 in Debian woody GNU/Linux with Kernel 2.4.22 (Custom).

System:
XP2000+
epox 8RDA+ (nforce2)
512MB RAM

with:
(of course: hdc=ide-scsi)

K3b 0.10.2cvs
http://www.k3b.org

cdrtools 2.0.0.3
http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/cdrecord.html

cdrdao 1.1.7
http://cdrdao.sourceforge.net/

dvd+rw-tools 5.13.
http://fy.chalmers.se/~appro/linux/DVD+RW/tools/


My burning tool is k3b 0.10.2cvs. This uses the several tools to write to media.

Cdrdao is used to burn CD-Rs and is working with “–driver generic-mmc”.
Burned two CD-Rs successfully.

The dvd+rw-tools are used to format and write DVD+RW media,
works great for the packaged DVD+RW from RIDATA.

Unfortunately I chose “Intenso DVD-Rs” to buy with the burner,
which are not compatible.
For that I couldn’t burn a single DVD-R yet. In fact I destroyed two of them :wink:
But I would not blame the burner, I am to blame because I didn’t read the compatibility-list before!
I will add a comment as soon as I burned DVD+R and DVD-R successfully.

michael

With dvd+rw-tools 5.13, I could burn (and read) dvd+ (only “skymedia” tested).

Burning dvd- (“princo”), however, always resulted in a burn without any error messages and a unmountable disk (I once could even burn a burned dvd- another time, which resulted in an interesting ring texture :().

After updating the dvd+rw-tools 5.14, I could burn a mountable dvd- for the first time, but only the first ~1.7GB were readable, the rest gave I/O-errors.

This burner starts to get expensive :frowning:

Hi I am an owner of a DRW1004, I’m running Slackware Linux current with the 2.6.0 kernel without ide-scsi emulation

I have burned several ISO files to CDR (with k3b using cdrecord) without problems.

First I had some trouble burning mp3 files on the fly to CDR. This was because the latest stable cdrdao doesn’t support atapi, it requires ide-scsi emulation. I found a beta version of cdrdao (1.1.8pre2) that did support atapi, after installing this k3b burned the mp3’s without a problem.

Program versions used:

K3B 0.10.3
cdrecord 2.0.3
cdrdao 1.1.8pre2

I did not try to burn dvds yet, I’ll report that as soon as I have some results.

Mandrake linux 9.2, kernel 2.4.22 and K3b 0.10.1 works wery well.
I burn data and video dvd, erased dvd-rw with no problem

:smiley: :smiley:

Debian Testing w/ Kernel 2.6.1-rc1 works
with:

DVD: dvd+rw-tools 5.13.4.7.4-1
CD: cdrecord 2.0+a19-6

Using the IDE driver, or using an USB->IDE converter and the SCSI driver.

My Mustek standalone player can read the DVD-RW (Primeon 1x) and DVD-R (MMore - OPTODISK001). The DVD+RW is detected as CDDA - maybe the booktype problem.

Eric

BTW, will firmware 0048 support setting the booktype?

Debian testing w/ kernel 2.6.1

DVD: dvd+rw-tools 5.16.4.8.5-1

BTC 1004 (FW 0047) is not working with this version of the dvd+rw-tools. Downgrading to 5.13 helps in this case. I heard rumors that a firmware update could help as well. Can anybody confirm this?

Eric

Athlon64 3200+
Gentoo Linux in x86_64 mode using 2.6.1-gentoo-r1
MSI Neo K8T Mobo
DRW 1004IM f/w 48 (upgraded from 43)

Using hdparm/dvd+rw-format/growisofs I wrote a DVD+RW once.

Using cdrecord (for ISO/CDRs) constant failures.

DMA errors
Also DMA isn’t set by default by the Neo K8T :frowning:

Having strange problems with DVD playing, as I need to first mount the DVD before I can reliably play DVDs with xine/ogle

hevisko,

Which version of the dvd+rw-tools are you using?

Eric

Originally posted by elussa
[B]hevisko,

Which version of the dvd+rw-tools are you using?

Eric [/B]

dvd+rw-tools-5.16.4.8.5.ebuild
just tried dvd+rw-tools-5.13.4.7.4.ebuild
and at present I get things like:

swartes root # dvd+rw-booktype -inq /dev/hda
Unable to ioctl: Input/output error

hda: DMA timeout retry
hda: timeout waiting for DMA
hda: status timeout: status=0xd0 { Busy }
hda: status timeout: error=0x00
hda: drive not ready for command
hda: ATAPI reset complete
hda: CHECK for good STATUS
hda: DMA timeout retry
hda: timeout waiting for DMA
hda: status timeout: status=0xd0 { Busy }
hda: status timeout: error=0x00
hda: drive not ready for command
hda: ATAPI reset complete

With growisofs from dvd+rw-tools 5.16.4.8.5 I get the following error:

:-! “COMMAND SEQUENCE ERROR”@LBA=0h. Is media being read?
:-! the LUN appears to be stuck at 0h, retrying in 5 secs…

Version 5.13.4.7.4 is working ok on my side, but I’m using an USB->IDE box (which creates additional headaches).

Did you try to disable DMA and run the drive in PIO mode? If this helps maybe try another cable (80pin?) and try again with DMA enabled.

Eric

Originally posted by elussa
Did you try to disable DMA and run the drive in PIO mode? If this helps maybe try another cable (80pin?) and try again with DMA enabled.

Eric [/B]

As I said, both 5.13 & 5.16 were giving the errors above.

Also, I’ve chaned the cables and location a couple of times beofre too :frowning:

However, retrying things with 2.4 & 32bit
works fine with the drive/setup, it just appears that 64bit doesn’t work with this drive (Though cdrecord in 64bit works fine on the Sony at the same time in the same machine…)

Okay, I missed the “turning off DMA part” :frowning:

Yes, the drive appears to be stable with
dvd+rw-tools 5.17 & 5.13 when I use
hdparm -d 0 -X pio4 /dev/hda

However: DVD playback suffers :frowning:

At present I’m looking at these interesting two lines that cdrecord spews out when using the BTC 1004IM (F/w 48) that’s not in the output of cdrecord for the Sony DVD-rom/cdrw (same machine secondary vs primary bus, both Masters)

[B]

cdrecord: Warning: controller does not support CD write parameter page.
cdrecord: Cannot set up 2nd set of driver options.

[/B]

This appears to be the root cause for some buffer under run errors I see on this drive in 2.6.1:

Total of 30 possible drive buffer underruns predicted.

I use Mandrake 10.0, K3b 0.11.12, KDE 3.2 and GROWISOFS 5.20 (for DVD-burning) and my DVDRW IDE1004 works very well.

I had some problem with firmware upgrade, solved with the help of Marco and BTC support (thank you guys)!!

Only a question… There’s a plan to port the firmware-upgrade-software to linux? It would be great!

I have both the 1004 and 1008 in a Mac g4 OS X but do not have a way to update the firmware. has anyone found a way to convert the firmware ugrade or make it work in a Mac?

Reads CDs and DVDs.

Works to burn CD-Rs, but will not burn CD-RWs. I’ve checked the media at the www.drvupdate.com and these CD-RWs should work OK. It burned CD-RWs OK (at least once, I never erased one) with 2.4 kernel, so I’m still not sure I have a drive/media or a kernel problem.

I have not tried burning a DVD+/-RW of any sort.

I’ve switched back to ide-scsi since there seem to be ide-cd issues still in the 2.6 kernel (especially 2.6.8.1). (I need to use the 2.6 kernels for the SATA.)

AMD 2500, 256 M
Via KT-600 motherboard
Emprex 8x (BTC DVDRW IDE1008)
Cdrecord-ProDVD-Clone 2.01b31 (i686-pc-linux-gnu)

hi marco, i am trying to update the BTC 1004 drive with the newest firmware but WINDOWS version would not let me. i was wonder if it is possible using a DOS version if available and if so, can you send me instructions on how to do so. i would appreciate it very much. thanks