DRW 3S165 firmware-updates, patches? help!

vbimport

#1

hi,
i bought a LiteOn DRW 3S165 (used) and have problems burning DVD+R media (Nero info-tool confirms that - it says i can´t DVD+R, even if it works, sometimes…). I already set the dma in bios, the drive is recognised by the system.
Another prob is, that i wanted to install the new firmware (e.g. CJST - now it´s CSG1). i could´t find a new firmware on the liteon-site (if i dl the 1653S-firmware, i can´t install it, it says that i have the wrong drive).
i saved the eeprom, i tried to flash with LEDFix_ CJST that i found on this site, but it doesn´t work,the system says that´s impossible and i should contact the vendor. i even tried the dvd-bitsetter. here it says that i have a sony-drive that can´t be manipulated. so what else can i do? i wrote to liteon, but they still didn´t answer. i want to keep on using DVD+R media. anyone´s got an idea?
thanks in advance
Oliver


#2

get this firmware: http://codeguys.rpc1.org/firmwares/Sony.710A.BYX3.patched-cf-rs-ledfix.rar


#3

hi, thank you, there´s only one problem left. when i try to do it, again i receive the message that my drive cannot be flashed and i should refer to my vendor. do i need another prog to apply the firmware?
thanks in advance
Oliver


#4

what windows version do you use and what’s the current firmware on the drive?
are there installed any IDE drivers other than the standard microsoft ones?

also try this: http://d26.yousendit.com/E/1BXMOW7TVONVP0VIKLD57BAX0Z/Update.rar


#5

hi,
my OS is XP sp1. yes, apart from the MS-primary/secondary controller there is another IDE-Controller, a Via-Bus-Master-IDE-Controller (Driver 5.1.2600.1106) and right now (burning Audio-CD´s) i had to use my external DVD-Burner, because it was impossible to burn a single CD without mistakes. is it possible that there is a hardware-conflict?
the dvd-burner is installed as secondary/master and the DVD-Rom as secondary/slave. the firmware on my LiteOn-drive is CSG1.
the link u gave me seems to be invalid, i can´t open it (?).
thank u very much, i´m very glad somebody´s trying to help me.
oliver


#6

could be a hardware conflict… i can’t help if it is.
but you can try this (link corrected): http://s5.yousendit.com/d.aspx?id=2WSGQIM0KEPPC0TYQ3U5KVOS8N


#7

@ obeycar

The drive you have is a 4KUS DRW-3S165 (a rebadged LiteOn) so you will not find firmwares on the LiteOn site. The site for 4KUS drives is http://www.4kus.com.tw

Unfortunately there are no ‘official’ updated firmwares on their site, I had a look.

The drive is the same as a LiteOn SOHW-1653S but you cannot use the firmwares from the LiteOn website as it is a 4KUS drive.

BUT you can use firmwares from the codeguys site http://codeguys.rpc1.org/firmwares.html for the 1653S that say ‘crossflashing’.

There is much conjecture to which is the best firmware just read through the forums here and make up your own mind. You can also use the Sony DRU-710A BYX3 which I am currently using on my 1653S.

Hope this helps.


#8

i could update with omnipatcher & the 1653S crossflashing file.
After all i have to think that there´s still a hardware conflict with IDE-controllers or drivers to resolve. thank u very much, you helped me a lot. i´ll stay in this forum!
have a good time.
Oliver


#9

hi,
using the unscrambled versions, the firmware flashing tool & the omnipatcher i am not able to flash the drive. writing the firmware he stops and gives me writing errors or says that it can´t write to the drive and i should refer to the vendor. do you have an idea what could be the prob? thanks in advance.
one thing: if i use the firmware flashing tool, i can get the checksum. what if they´re different?
oliver


#10

u want to try the ledfix codeking gave out, i forget the address but u can do a search in the liteon forum for it :slight_smile:

then unrar and then flash using the 1653 pacthed unscrambled :slight_smile:


#11

hi, sorry, maybe my english is not good enaugh :-), what do u mean?
i have the ledfix 1653S.CSTJ.patched-cf-ledfix.exe
i have the 1653S.CSTJ.stock.exe (unscrambled)

what do u mean with flashing it using the 1653 patched unscrambled? as i can see, these two files are both different types of firmware but not a flash-prog???
i have both on the desktop. what am i going to do now? would be very nice if u could help me one more time…
best
oliver


#12

@ obeycar
use the 1653S.CSTJ.patched-cf-ledfix.exe


#13

hi,
it says:update vom CSG1 to CSTJ, i press start.
then error: unable to flash firmware. please contact with your vendor.
i can´t understand this. is there a trick? what´s my prob?
thanks
oliver


#14

can you post a screenshot?


#15

@ obeycar
I am not quite clear on your configuration. Do you have your burner connected to the VIA IDE controller? That may be blocking the flash. It may even be conflicting if your burner is connected to the MS-driven IDE channels. I would suggest you connect your burner to the Intel controller and/or replace the VIA drivers with Microsoft drivers. If nothing is on the VIA controller/channels you could try to disable it in your BIOS and that may allow you to flash.
You could also try to put your burner in the external case and flash it there.