DRU-810a - CD won't burn

vbimport

#1

Howdy! I’ve had the computer listed down in my sig for about 3 months, and finally got around to needing to burn a CD. I’ve been able to burn DVDs since I put the computer together with no problems at all, but I can’t burn a CD to save my life.

I’ve tried using Nero Ultra 6.3.0.3 as well as the Windows burning function. Unfortunately, neither gives me a useful error message on the failure. Nero just hangs, and Windows just says it can’t finish.

I have also not been able to find much in the way of info on the net. I did upgrade the firmware of the drive from 1.0a to 1.0e. The only thing that I think may be relevent that I’ve come across is the ASPI checker program from adaptec.com. It says that ASPI is not currently/properly installed. And I haven’t been able find anything regarding how to go about fixing that. The ASPI package from Adaptec did not work, I guess because I’m using Win64.

Any help would of course be much appreciated.


#2

Most modern burning software uses either its own custom interface (IE VSO software’s BlindWrite and Copy2DVD’s Patin-Couffin Engine) or a custom ASPI layer (IE Nero Burning ROM, Roxio (I think?), etc.) so this really shouldn’t be that big an issue. Since you’re using Nero, it shouldn’t be an issue.

I’m not entirely sure, but I don’t think that’s the latest version of Nero in the 6 series. Grab the update and install it, then check and see if anything’s different. Also, some people have reported that NVIDIA’s IDE drivers cause burning problems (though if you can burn DVDs fine I doubt it’s that) so you might consider a rollback of the drivers to the ones from Microsoft.

Just as a side note… that’s a [I]nice[/I] rig.

Anyway, check that, as well as making sure the drive is in UDMA mode, not PIO (but again, if you can burn DVDs fine…) and we’ll see what else I can think of here. I’m sure others will throw their two cents in as well.

-[I]silence[/I]


#3

Thanks for quick response. I have confirmed that it’s in DMA mode (at least, it says DMA if available rather than PIO only…) I hadn’t thought to look at the IDE drivers, and god I hope it hasn’t got anything to do with them. At this point I don’t remember exactly what my problems were, but let me tell ya, it took about 2 days to get the motherboard and hard drives talking to each other with Win64.

And if you think the rig is nice, you should see the impetus behind why I need to burn some MP3 disks. This one isn’t mine, but it’s awful close: http://www.stangbangers.com/05_MustangGT_Pic01.jpg


#4

Driving a silver 1998 Audi A4 2.8 Quattro… with a PES-Tuning supercharger setup. I understand. :wink:

Win64 is the devil, really, especially on a gaming rig. I seriously doubt this is a “64 bit” related issue, but I’ve seen crazier things blamed on it/caused by it.

Is the firmware you flashed still current? Unfortunately (I’m more familiar with Lite-ON’s) this is a rebadged BenQ DW1640. Good drive, but I don’t work with BenQ’s enough (got a DW1650 about 3 days ago) to tell you what to do firmware wise, short of looking for a more up to date Sony firmware. It seems like 1.0E is current, though. I don’t actually see it on Sony’s site, only 1.0D, so it may be a beta or something.

You may want to consider getting a combo drive or a dedicated CD-RW drive, though, as I’ve noticed that my DVD-RW drives burn relatively poor quality CDs, even on good media. Never really figured out why, though. Music CDs in particular have a tendency to skip, but data is usually alright.

Anyway… update your IDE drivers if anything’s available – but NVIDIA, like Creative, is terrible about releasing updates… or even bothering to write them. Update Nero to the latest in the 6 series. Hope that sorts it out. If not, consider grabbing the 1.0D flasher from Sony or elsewhere and making sure it’s not the 1.0E firmware causing the problem.

-[I]silence[/I]


#5

I flashed my Sony DRU 810A 1.0d to BenQ DW1640 and happy ever since :stuck_out_tongue:


#6

Can you read CDs ? That would proof that the CD laser is not completely dead.
Disable the Windows burn engine, the IMAPI service. In case this does not help, post the text output of Nero Infotool as text file attachment using the Manage Attatchments button so we can have a look at your config.


#7

Charlie T: It’s good that you’re happy with your drive after having flashed it. Was it having problems before you did?

Ala42: It does read CDs just fine. Whenever I try to burn one though it does what I described in my first post. One thing I forgot to mention is that after a couple seconds of it trying to write, it starts to make some very faint clicking noises. I checked the Imapi service and it was off and in Manual mode. I disabled it entirely and tried again, but no dice.

Attached is the text output of Nero Infotool.

I just uninstalled my old version of Nero (6.3.0.3) and installed v6.6.0.14 Sony Edition that came with the drive. Again no luck though. Also attached is the failure report.

Burn Failure Report.txt (6.75 KB)


#8

Welp, just did a little testing. I took the DRU810a out of my current computer (in my sig) and put it in my old one. That rig is an Asus P4C-800E, P4 3.2E. A fresh install of Windows XP Pro (non-64 bit of course, and pre- service pack 1), a fresh install of the OEM Nero 6.6.0.14 that came with the drive aaaaaand… still won’t burn CD.

To take it a step further, I put an old Plextor Plexwriter Premium into the Athlon rig and it burned a CD just fine.

Methinks I’ve got a bum laser in the Sony. In perusing the Burn Failure Log attached above, it does reference a “Calibration full” error, which Nero indicates could have to do with power source of the drive (is currently the only drive on that cable) and some other stuff which doesn’t apply. It then indicates the drive is probably bad. So… damn.


#9

Yes Methink you are correct :iagree: !!! Me-also-thinks Sony drives are rubbish. Had nothing but problems with them every time.


#10

:doh:


#11

Harrier B, sorry to hear about your problems. But before making any final judgement I suggest you as folow;

  • Try with other media. CMC’s are pure crap :Z
  • Use CD-DVD Speed DiscInfo to determine avilable burn speeds. Not sure burner likes your current media to be burned at 40x (bad compatibility).
  • Finalize burn. Posted log is from a multisession compilation.

[I]@coathi,[/I] Sony 810A is a BenQ 1640 rebadged. One of the best burners ever made… :smiley:
(We are in Litey forum section I know, but my opinion about 1640 still stands.)


#12

Thank you for the info Pinto2, I have to say I think highly of your opinion and yes I have to :iagree: the 1640 are a very good drive, it’s just anything Sony puts there name on seems to turn into rubbish or a Lemmon.


#13

When I first tried burning a CD a few days ago it was Memorex 40x cds. I’d had that spindle for about 3 years, so I thought perhaps they had just gotten old or messed up by heat (I moved about two years ago and they were in the back of a 24 foot rental truck… don’t think I’ve burnt a single CD since…) There were only about 3 blank memorex discs left, and none of them worked, so I went and picked up the TDKs.

I just followed your suggestion, burning a single-session disc at 12x. Still no go. Attached is the log from this attempt.

12x Burn Log.txt (6.69 KB)


#14

Well, if the drive is still under warrenty you can try to RMA it or similar. Contact Sony directly, maybe… but good luck there. If not, crossflash (go to the BenQ forum section for that, I have no idea how to go about this) to the BenQ 1640 firmware and see if that helps. If not, your CD laser is screwy. Grab a cheap combo drive and don’t lose sleep over it. :wink:

-[I]silence[/I]


#15

[QUOTE=Harrier B]Charlie T: It’s good that you’re happy with your drive after having flashed it. Was it having problems before you did?

Actually I did not have any problem with Sony DRU 810A. But after reading forums I found out that BenQ has more features like Q-Site for DW1640. It’s an extra benifit Sony does not offer.


#16

Welp, as it turns out, Sony did accept an RMA on it and they sent me a DRU-820A as a replacement. Just thought I’d close out the thread as reference in case any one else runs across the same kind of problem with an 810.