Drivers for (Lite-On iHAS324)

[qanda]This thread is about the Lite-On iHAS324. Click here to see full specs[/qanda]I just bought a Liteon iHAS 324-09 A a few days ago and been trying to get it to work properly. the drivers for it show 2002… and I cant find drivers for it anywhere and the nero 8 cd that came with it says it has drivers but when I search it the system says the system has newer drivers than whats on the cd. I am currently using windows xp 64 bit. Anyhow, when I put a cd in…it locks up my whole system, forcing me to reboot and take the disc out.

Any ideas or how to fix this?:confused:

Welcome to CD Freaks. :slight_smile:

Can you post more system specifications, like motherboard, or system make & model?

yeah sure
Gigabyte mobo GA-K8N-SLI
2GB Memory
1TB HDD
Windows XP 64
AMD PROCESSOR 64 bit 3000+ 1.8ghz

Hope that helps or do you need more?

guessing you need more information… lol

correction: Xp Professional 64 bit and service pack 2. Hope that helps?

Check your BIOS for options to disable the RAID capability of the SATA controller and place it into Legacy/IDE mode. Also, if possible, switch from nVidia’s drivers to stock Windows drivers [in Device Manager] if possible.

looking bios now, ide/sata-II raid function is disabled, but seral-ata II 1 and 2 are enabled. the only legacy i am seeing to enable is usb,mouse and keyboard.

can somoene tell me which one is the raid controller?
ide/sata-II raid
serial-ata II 1
serial-ata II 2

Im using award modular bios v6.00PG

Ok, take a look at the picture. Where is the iHAS324 connected to, the nForce4 or SiI3114 chipset? In the BIOS, there are two sets of SATA functions, make sure you select the correct non-RAID/ATA settings on whichever chipset that the iHAS324 is connected to.


is that how its supposed to be setup?

Yes, that is correct for the nForce4 chipset. But it seems like you don’t have the extra SATA controller, namely, Silicon Image 3114, which is probably reserved for the Ultra or Pro motherboard.

Try plugging the iHAS324 on either SATA1_SB or SATA3_SB on the motherboard, while the hard drive on SATA0_SB.

my cables are plugged into the 1st two ports near the green ide cable port

But which one is connected to what? From the picture you’ve shown, I’m suggesting plugging the iHAS324 into the rightmost plug (SATA1_SB) and the hard drive to the next one over (SATA0_SB).

ok, HDD is plugged into the 1st one on the right and ihas324 is plugged into the one next to it

i just tried to move dvd to SATA3_SB no luck…but going to try something…just dawned on me that the hdd is in sata1_sb not sata0_sb…brb gonna shut down and try this.

Didnt fix the problem.

any other ideas??

If you have installed nVidia’s IDE driver, you can try uninstall that. Reboot the computer and let Windows use the default drivers. Try removing the upper and lower filters as well.

upper and lower filters arent in the regedit. I will try to remove the ide drivers.