Drive will not burn CD-RW

Hello everyone,
I have problems with my LG GSA-4163B (yeah I know it’s old). This issue has started about 1 month ago.
The drive simply won’t write to CD-RW media. Every time I try writing to or erasing a CD-RW disc I get the message ‘no seek complete’ and nothing on the CD is modified. CD-R and DVD+R media can be written with no problems though.
I’ve tried updating to the latest firmware available (A106) and cleaning the CD drive lens. This hasn’t helped at all.
I have no idea what else might be causing this problem. Any suggestions?

Maybe your CD-RW media is getting a little worn out. I’d try some new media and maybe a different brand.

Yes, and FULL FORMAT that CD-RWs.

we both share the same problem,
and after searching and experiment found the answer
The problem is speed of writing of the LG drive
It has a speed of 10x,while the media we are using is having the speed of 12 x or more.
What all we are already burning has a speed of less than 10x (RW media)
and less than 40x for one time write.
I tried the same media on another writer whose read and write speed is 24x and it is working fine
I hope i answered your problem.