Drive reportedly flashed successfully but still indicates region switch limit

vbimport

#1

Hello,

I just downloaded the binflash v. 1.56 application (“necflash”) for Mac OS X (running 10.6.7) and the patch file “3ahb_rpc1.bin” for the OPTIARC DVD RW AD-5680H in my iMac (10,1), put both files in the Applications folder, launched Terminal and issued the following command (after having set the file patch):

./necflash {-queryrpc} {A:} -> after having ascertained the device id

This resulted in the following output (default header skipped):

Region control is RPC2
4 user changes left
4 vendor changes left
Drive is set to region 2

Immediately following this report, I issued the following command:

./necflash -flash 3ahb_rpc1.bin {A:}

I acknowledged the disclaimer with a “y”, and then with another “y” to the follow-up question:

You are about to flash your drive with the following firmware:
Vendor: OPTIARC
Identification: DVD RW AD-5680H
Version: 3AHB

This resulted in the following output (default header skipped):

Region control is RPC1

…which I assumed indicates a succesful flashing of the drive? After a reboot (no shutdown) I inserted a region 1 DVD which immediately started playing (remember the drive was initially set to region 2), and felt really pleased with myself (for having managed to flash my drive with such low technical skills :-).

However, just for testing, I inserted a region 2 DVD – and then received the old dialog box asking if I wanted to switch region, and that I was limited to 4 more changes! I cancelled, shutdown the computer, waited 5 seconds and then tried again, but with the same result. At this point I relaunched Terminal and issued the query command again, and it still said “Region control is RPC1”.

But doesn’t RPC1 mean that I should be able to play any region DVD without being asked for a switch (and informed about a 4 times switch limit)? Was the flash unsuccessful and I now need to do something else/more in order to succeed (if so please advice what), or have I misunderstood how this works (I remember having read somewhere that I still have to switch region code whenever I play a different region DVD than last time, but that the limit value always resets to the initial value 4 after I shut down the computer)?

Please advice how to resolve this matter so that I may play any region DVD without the current hassle, I would really appreciate it (I did something similar to my MacBook (which has a different drive named LG HL-DT-ST DVDRW GS23N SB11) with another application named just “flasher”, and there it works fine – any region DVD that I pop in automatically starts playing, no questions asked :-).

Thanks,

Mark


#2

Hello again,

Ok, I’ve now read some more about this and realize that while the DVD player (hardware) may now be region-free (RPC1), the “DVD Player” (i.e. the Apple software application) will still not be region-free, which means that I will have to use another application such as Region X in order to manually handle the region switching (which may now be done an infinite number of times, as opposed to the pre-flashing limit of five times). But one question remains: On my MacBook I don’t get the change dialog when I play DVDs from different regions – why does it seem to work transparently there (i.e. no need for Region X)? I should note that I have only tried region 2 and 4 DVDs on my MacBook, while I have only tried region 1 and 2 DVDs on my iMac – could it be that there is a complete distinction between region 1 and other regions, while there is in some cases no distinction between region 2 and 4? What would speak against this theory though is that the region 4 DVD that I tried to play before having flashed the drive wouldn’t play without a region switch (as the drive was set for region 2), but after the flashing this disc played transparently (no change dialog)…

Thanks in advance for hopefully shedding some further light on the matter! :slight_smile:

Mark