Drive doesn't recognise blank CDR - Toshiba DVD-ROM SD-R2002

Drive doesn’t recognise blank CDR - Toshiba DVD-ROM SD-R2002

Main questions: What would cause a drive to be able to write to a CDR containing data and not to a blank one and also be able to read all discs perfectly? Also why did it work before I re-formatted my hard drive and re-installed Windows XP, but not now?

Detail: Recently done a fresh format and re-install of Windows XP Pro + SP1 and now I can not burn a CD as the drive does not recognise that a blank CDR has been inserted. I have tried 5 CDs from the same pack, and none work on this computer although they are recognised fine on my friend¡¦s computer, also I used 100 of these disks before on this drive without any problems. I have tried flashing the firmware on my Toshiba DVD-ROM SD-R2002 combo drive. My drive has the 1F26 firmware and have tried flashing it with the original firmware (RPC2) available at http://forum.rpc1.org .

Curiously, it does burn to an un-finalised CDR with data on it via Multisessioning; this works on Windows XP built in burning and with Nero. It reads all discs fine.

I also noticed that the drive does not make the sounds I was familiar sounds, with when a empty CDR is inserted and Windows XP does not bring up the option dialog as to what to do with the blank disk. Windows XP built in burning reports “Insert a writable disc to continue. There is no disc in the drive. Please insert a writable CD into drive D:” and Nero doesn’t allow any selection of Write speed when a blank CDR is in the drive although it does allow selections as soon as the disc is ejected. Creating a compilation without a disc in the drive and then selecting the burn option reports “Waiting for drive to become ready”. If the disc is ejected again and the final burn button pushed Nero switches to the burn screen and reports “DVD-ROM SD-R2002: Waiting for Disc. Please insert an empty disc to write to¡K Disc required for the compilation: CD-R/RW. Disc type in the recorder: (Empty).” When a CDR is inserted the light on the drive flashes for a long time but nothing else happens.

Bizarrely in 20+ hours of fiddling I have managed to burn two CDRs, both originally blank (adding to already written discs - un-finalised discs - works fine). However when I tried straight away to do it again, I encounted the same old problems.

I have tried using the latest SIS PCI IDE UDMA controller driver, but I got the same results I got from the one that one Windows XP chooses to install.

I have tried enabling/disabling DMA both from the BIOS or from Device Manager for both the Hard Drive and/or CDRW/DVD-ROM.

Even though I use Windows XP I have tried installing an ASPI layer from www.adaptec.com 4.71a2 (install program only wants to add wnaspi32.dll and aspi32.sys and not install winaspi.dll or wowpost.dll. No help at all. I then tried installing forceaspi to add all four files, which it did, but my problems remain. (http://cd-rw.org/articles/archive/aspisetup.cfm )

In desperation and I used a CD drive cleaner, the type with the brushes underneath, luckily it did not damage the drive, but it didn¡¦t help either.

I have tried using version 6.0.0.19 or 5.5.10.35 (Enterprise Edition) of Nero Burning ROM, and have tried using the built in windows XP burning functions. I have tried combinations of turning off the CD burning facilities of XP and setting the IMAPI CD-Burning COM service through Automatic/Manual/Disabled rebooting each time. I have tried many combinations of disabling/Enabling Services via the Administrative tools menu. I have Microsoft Office 2003 installed, but can¡¦t see why this would make a difference.

I have a Rock Sigma SI Laptop from www.rock-direct.com find additional (and probably irrelevant) information on it from www.mobile-support.net . Info on Toshiba Slim 4x Combination CD-RW/DVD-ROM drive SD-R2002 from http://www.toshiba-europe.com/storage/Index.asp?page=PCI&nav=ISH_PRS&model=SDR2002 .

Question: In Nero disc info what does the information for the drive in the brackets mean: (ID: 0 HA:1)

If you require any other information I am sure I can supply it. I’ve never been this stuck with a IT problem before, and hope u can help! I’ve spent many hours on google researching this problem to no avail. Hope this post will get the answer I need. Thank you for your help.

Also if anyone else has the same problem, even if you have no solutions please post and we can compare configurations to rule some things out; plus it will be nice to know I am not alone! (This person seems to have the same problem with a Toshiba http://pub44.ezboard.com/fultimateboardofcoolstufffrm31.showNextMessage?topicID=792.topic )

Thanks
Graham

Question: In Nero disc info what does the information for the drive in the brackets mean: (ID: 0 HA:1)

This gives the location (adapter and target id) of the unit. I suggest you try a different brand of cdrs just to check.

Thanks for the Info.

I’ll go out tommorow and spend some money on some new CDRs just to check, but I’m not holding out much hope. Worked before I reinstalled, and my friend has managed to brun using the exact same CDR I tried first.

Tried a different brand… still no good, i’m afraid. Any ideas on where to go now?

I am having this problem as well.

I originally had Nero installed and it would give carious errors when I tried to launch it, so I uninstalled and then re-installed it and it would never launch. There were errors about the .exe has changed and to reinstall even right after it was installed.

So I scrapped Nero and wanted to use the built in Windows XP burning. I turned on the IMAPI service, and made sure that CD Burning was enabled for the drive on the recording tab of the properties.

Now, I copy the files to the disk, and then click “Write these files” and it keeps saying “Please insert a writable disk” even though there is a disk in the drive.

I have tried Staples brand, Sony, and TDK and all do the same. The Drive is a Lite-On 12101b and can read all disks fine and has never been a problem before.

I really need to get this working and have uninstalled the drive and reinstalled it with no luck.

ANY IDEAS?

having the exact same problem. I too recently reinstalled XP. Has anyone contacted Microsoft yet? Odd thing is that I can still burn a music CD, just can’t burn a data CD.

I just downloaded the trial version of Nero and used the data burning feature to burn a photo onto a CD. At least now I can get my Christmas Card pictures printed. If anyone else is in a hurry, this works.

Have any of you tried reinstalling the drivers for your CD-RW drives. I know that I’ve had a problem like this with my LiteOn and that fixed it. It could also be that the drive just died, although that wouldn’t explain why it can burn onto multisession CDs and read. Have you tried updating your chipset and/or BIOS? It may be that it’s having compatibility problems for one reason or another. Other than this I can’t really think of anything that could be wrong, unless you’ve just had bad media the whole time.

I seem to have the same problem with XP.

I don’t use my CD writer much, but today tried to burn a couple of disks… CloneCD didn’t work so I installed Nero6, then tried MS own utility. And a couple of others, but nothing doing, it won’t recognise the disk. Just keeps saying ‘no disk in drive’ or ‘insert a writable disk’… spent half the day on this :frowning:

I’ve added a lot of software, Windows updates, Media Player 9 etc since the last time I burnt a disk so there’s no easy way of tracking the source of the problem down… but I wonder if it’s some incompatibility between my Lite-On and some XP update or media player.

I couldn’t find anything about it elsewhere so hopefully someone here will get farther than me…:wink:

I pulled the drive and put it into a different system and it works fine, has something to do with the XP install on the first system.

As for what was installed, Nikon View, was the only thing installed after the system was verified to work.

http://support.microsoft.com/default.aspx?scid=kb;en-us;q324129
PJ

I had found that and done as advised and it didn’t work on mine, usually MS fixes are OK but there must be something else going on that the article doesn’t address.

Sorry to hear the link didnt help…

its a strange one, im surprised no-one on these forums has been able to answer this yet.

I have 2 machines with the same problem, and am about to try the fixes suggested on the link.

One is an upgraded windows 98 box, to windows XP with Service PACK 1 slipstreamed during install

The other is a toshiba Satelite Pro laptop, thats doing the same thing, but this is a brand new laptop from toshiba with a vanilla XP install

Its stumped me at the moment…

The only other useful info i’ve found is this

The behavior may be that Windows XP could not recognize the CD-RW drive
automatically. Let’s perform the following steps to modify the registry to
let Windows XP treats the device as the CD-RW.

  1. Run Regedit to open the Registry Editor
  2. Switch to the following key

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD
Burning\Drives

  • All CD drives show up in same key

  • “Drive Type” value determines whether drive is capable of writing and
    rewriting

01=CD-R Drive

02=CD-RW Drive

03=Write Disabled

  1. Note: if you have more than 1 CD-ROM / CD-RW devices installed, you
    will
    see the related items under the Drivers. Please change the keys one by
    one,

PJ

@ Toshibakid

Hi,

could you give a little information on your hardware? What chipset does your mainboard use? Intel, Via, Sis, Nvidia? And what drivers do you have installed? Version?

Your problem could be that you dont have the right IDE Drivers installed. At least not the ones that were working for you before. Without knowing what type of system you are running, its just a rough guess though.

Example…Nvidia Nforce2 chipset seems to work best with the Standard IDE driver, although you can use the 1.16 drivers. If you use the 3.13 drivers and intall the SW IDE drivers, it screws everything up.

There could be issues with Intel drivers or Via drivers as well. Do you even know which drivers were installed before?

Your problem stinks alot like an IDE Driver problem.

Well let’s see…

Tyan Trinity KT-A 2390B Motherboard (Via chipset)
Athlon T-Bird 1.3 200mhz FSB
Visiontech gForce 2 GTS 32mb
Drivers are the Via Hyperion 4-1 drivers, newest version.

That should cover the relevant bits.

I had this exact same problem and it plauged me for some time until I finally realized that the source of the problem was the IDE drivers. If any of you are still experiencing this problem I would recommend d/ling the latest drivers from your motherboard company. If that fails to work, try the default windows drivers as that’s what’s working for me now.

Same problem. Link provided sorted it out but now I can only record-enable one of my writers at a time! At least I got my new one to work though. Thanks for that!

same thing here too after reinstalling xp pro
but it’s only with cd-rw
tried both Memorex and Verbatim
JUst Says:Please insert disc
or
Function not available
nero cddvd gives media info like it is .66gb storage…
but i can’t explore it in my computer
it lets me erase cdrw but can’t burn or explore
dvd burning works fine.
I tried to restore my system to few weeks ago but it says “Your Computer Cannot be restored to the specified date” even though there are bold dates to go back.
any suggestions

Same problem here. Only that I have toshiba dvd/cd-rw sd-r2212. I had xp home which came bundled with my laptop (toshiba satellite 1110) and the xp inbuilt cd writing was working fine. I recently formatted my hard disk and installed xp pro this time. curiously, I also installed office 2003. now the cd writing wizard refuses to recognizes the blank disk. i contacted microsoft but they are still to find a solution :confused: . incidentally, i have successfully used ‘burnatonce’ to write a cd,despite this problem with the win xp inbuilt cd burining program. i wonder if there could be any solution.

Just thiought I would add my name to the problem you are experiencing. I am running an Advent 6416 with XP Professional.

Also I can no longer play DVD’s it just doesn’t recognise that there is a disk in. (region status is OK).

I have searched for an updated driver but no luck.
Any help would be appreciated.