Dreaded "There is no disc in the drive. Please insert a writable CD into drive."

(Moderators, if there is a better place to post this issue please move. I will find it)

HP Pavilion DV6700Z laptop
Downgraded to Windows XP SP3

Everything seems to work on this laptop except CD writing (have not tried any DVD functions yet). (DVD burning did work under VISTA so I’m pretty certain the hardware is functional.)

Immediately after booting, My Computer shows the device as a DVD-RAM. The standard driver is load (and has been reloaded several times). IMAPI (via the CD Writing Wizard) fails with “There is no disc in the drive. Please insert a writable CD into drive.”, even though there is a fresh Imation 52X CD-R in the drive. At this point My Computer says the device is a CD-ROM.

Nero 7 was loaded, but has been successfully removed (with no change in behavior)

Here is what I have done

[li]All ATA channel are set to automatic DMA and are running some DMA mode
[/li][li] Microsoft Fix 314060
[/li][li] Microsoft Fix 316529
[/li][li] Microsoft Fix 310751

Well, it’s working now (mostly), but I don’t know exactly what cured the problem.

I did a Windows XP repair installation. This is not a full “scrape the disk” installation as it preserves all users data and 3rd part software. The bad news was, this effectively down graded me from SP3 to SP2 (because that was the only XP load disks I had) and broke a couple of drives.

After several hours of downloading and installing patches via Microsoft Update and searching and install the latest video and audio drivers I finally got back to where I started ! Yes, that is correct. The Microsoft standard CD Writer Wizard still gave me “There is no disc in the drive. Please insert a writable CD into drive.”


So something in the back of my brain said, “Let’s try something different !” I downloaded FinalBurner FREE and SHAZAM it worked !

So I got brave and reinstall Nero 7. Joy, it works also. Plays movies, and burns data DVDs (that is all I have verified).

So maybe the XP repair did fix the problem, but the MS CD burn wizard is broken as far as I am concerned.

Win XP SP3. No 3rd party burning software on this work laptop.

Had same problem. It worked with some media but not others. I got “There is no disc in the drive” “Insert a writable CD into drive”

This fixed the problem:

Open ‘My Computer’. Right click on DVD/CD-R/W drive. Select Properties. Select Recording tab. Make sure ‘Enable CD recording on this drive’ is checked. Change write speed from ‘fastest’ to 4X (or as fast as you dare). Click Ok.


Buz- thank you! I was having this problem and changing the write speed to 4x fixed it.