Downgrading Firmware for Liteon IHAS324 B

vbimport

#1

I’ve created a firmware bin file using the read flash function within the Flash Utility 6.0.1, the version is AL12 which I believe is the initial firmware release for the 324 B series but I’m not having much success at all trying to downgrade to this firmware using either versions of Flash Utility 6.0.1 or 7.2.0.

The firmware dump AL12.bin file was created using Flash Utility 6.0.1.

I’ve noticed in a recent thread that someone had successfully downgraded back to AL14 from AL1B but that method for me has also been unsuccessful.

Could someone please offer some assistance as to what I’m doing wrong

Thanks


#2

How exactly is the process failing?


#3

Hi Albert,

When I try to downgrade using the AL12.bin file, a dialog box comes up stating “error writing FLASH to drive” and also within the Liteon flash utility version 7.20 at the bottom it says “writing of FLASH failed!”


#4

Is there an alternative method for flashing .bin files instead of using the flash utility?

I heard something about it being possible to downgrade using LiteOn’s firmware EXE flashers would that be correct?


#5

Yes. You can try to use one of the unlocked flashers. A link to one stored here: http://downloads.ultrafastcdn.com/BDRE_OEM_FW/LiteOn/exe/iHAS324B_AL18_UL-FWHQ.exe

Would you mind uploading your AL12.bin file to a site like Zippyshare so I can double check that the firmware backup was successful?


#6

Thanks for that, I think I uploaded it successfully to Zippyshare here is the link http://www19.zippyshare.com/v/f2XWDh7n/file.html

It was created using Flash Utility 6.0.1 if that makes any difference in terms of a successful or unsuccessful “Read Flash” firmware dump .bin file.

Is it best to use the latest version of Flash Utility 7.2.0 even for the old LiteOn IHAS324 B series of drives released way back in 2010?


#7

Oh I should’ve mentioned that I disappointingly forgot to backup the EEPROM of my IHAS324 B drive, isn’t that meant to be a crucial and necessary procedure if one wants to successfully downgrade the firmware .bin files for these IHAS324 B series drives?


#8

No, you don’t HAVE to backup the EEPROM to upgrade/downgrade firmware for the same drive series, but it is recommended just in case you accidentally overwrite the EEPROM data while trying to flash new firmware. (Under normal circumstances, this shouldn’t be a problem).

The last release of the Flash Utility should work the same way as 6.0.1 does with the B series drives, so there’s no preference in this situation.

EDIT: your dump of AL12 looks fine. :slight_smile:


#9

I think I successfully downgraded to version AL12 on my IHAS324 B drive with the unlocked AL18 firmware flasher you linked but the thing is I found this from another thread where it was said that you can copy the earlier .bin file and paste it onto the AL18 firmware flasher file then it opens up and states it will flash from the most up to date firmware version AL1B to AL18 NOT the AL12.bin file so I was stumped for bit but then I went ahead and tried it anyway assuming it would downgrade to AL18 but upon restart I checked the firmware version and it read AL12 a great success, thanks again for your help Albert!


#10

One more thing I was wandering why the unlocked firmware flasher didn’t show that it would downgrade from AL1B to AL12 it listed AL18?

Is it because that the underlying firmware file embedded within the .EXE flasher is actually AL18 but this copy & paste process sorta tricks the application?


#11

[QUOTE=oniiz86;2786502]One more thing I was wandering why the unlocked firmware flasher didn’t show that it would downgrade from AL1B to AL12 it listed AL18?

Is it because that the underlying firmware file embedded within the .EXE flasher is actually AL18 but this copy & paste process sorta tricks the application?[/QUOTE]

That’s correct.


#12

Quote:

Originally Posted by Albert View Post

Let me explain a little differently.

For this particular drive, you take this Flash Utility http://club.myce.com/f44/flash-utili…-2-0-a-190420/

(notice the capitalization I use; when capitalized, I’m referring to that specific utility)

And the AL14.bin file (download the .rar file, and the .bin file is inside).

Flash the AL14.bin file to the drive using Flash Utility.

From there, you can flash anything from AL15 to AL1B (or anything later, should something magically pop up years later).

Repeat the process if you need to downgrade again. (Say, you realize that AL16 was best, and you’re on AL18 again. Flash back down to AL14, then upgrade to AL16.)


For other drives, you would do something similar. If you had the unique unlocked .bin files, that would be easier, as you could just flash to that firmware, but at the LEAST, you get the oldest .bin file you can find, which will allow you to use the official locked firmware flashers to get whichever firmware you want.

I apologize for the confusion.

Hi Albert,

You helped me out earlier, I was the one that created a new thread regarding downgrading my IHAS324 B drive.

I’d noticed this thread before posting about my issue and didn’t achieve any success with this method yet in this instance it was a success for this member.

I know its a bit redundant bringing this up now that I’ve successfully downgraded through an alternative method but I was just curious all the same, I could NOT flash the AL14.bin file you provided using the LiteOn Flash Utility either 6.0.1 or 7.2.0.

My IHAS324 B had the latest firmware AL1B

Thanks again for all your assistance!


#13

Hi Albert,

There was a bit of confusion regarding my previous posts on this thread and the other thread you replied to me on (Downgrading LiteOn IHAS324), I know I sound like a broken record but could you possibly offer me a reason as to why your suggestion to simply flash the AL14.bin file you supplied him using the LiteOn Flash Utility worked for that user “meeshu” in downgrading his IHAS324 B from AL1B to AL14 but for some reason it was an entirely futile process for me with my IHAS324 B drive.

I know its totally redundant in me bringing this up because as you noted I found a workaround solution but I’m curious as to your response either way.


#14

SATA controller compatibility issues: maybe an incompatible SATA mode that doesn’t like optical drives, or a version of a given driver that doesn’t pass the correct commands. Interference from other software on the system (not necessarily nefarious). Maybe the Flash Utility didn’t know the right way to access the flash chip on your drive (unlikely, but possible)

Note that the Flash Utility attempts to use the same commands that the official flashers use, but it’s possible that LiteOn’s flasher has workarounds built into it that the Flash Utility doesn’t have.