Downgrade firmware

vbimport

#1

i asked it before , but never get a answer , or i missed it , so : is it possible to downgrade a firmware version ( plextor 24:10/40a or plextor 12/4/32s ) , in other words : is possible to go back from 1.04 to 1.03 ( for example ) if you want it ?? , never get a answer from plextor too ,

thanks


#2

Of course you can downgrade firmware, it is software stored in E2prom. Now the only trouble you may have is if the flash program checked the current version first!!


#3

of course, since you can use mtkflash for flashing its bios (mtkflash uses brute force for writing and even works if a drive is not recognised by the BIOS)


#4

mtkflash does not work with the plex, however, plex’s own fw program will flash regardless of what version is on the drive at present. It will flash up or down.


#5

http://club.cdfreaks.com/showthread.php?s=&threadid=42865

> Note that this may only work for drives with mediatek

Another thread says that plextor 24x uses a mediatek chipset.

==> ? I’ll try it on my own (only to extract the firmware)


#6

go to plextor europe and download their program for firmware update, i was able to downgrade with no problem with that


#7

thanks you all for the replys ,

i will try it the way ssjkakaroto says


#8

Does anybody know if mtkflash works on samsung devices??


#9

the mtk stands for mediatek, so it is designed for mediatek chipsets. I don’t think that the samsung has a mediatek chipset, but someone else may know for sure.


#10

Samsung uses its own chips; they are also found in the low-end Ricoh.


#11

The thing is that i have a ruined Samsung 612S DVD … my younger brother tried to update its firmware with the wrong f/w version so now it acts as if it were dead. :mad:

I have tried reflashing with the correct f/w with no luck … everytime i try all i get is some strange noise for the device while in the process with no result. I was looking for a program that would force the wrong f/w out so that i can update it…

Any suggestions? It would be a shame to throw away a working piece of machinery :frowning:


#12

Ask the God of Media & Liteon about this. He PM’d me today about some outrageous way of bring a dead 32123S back to life & the damn method worked; he’s a Freak


#13

Originally posted by FutureProof
Ask the God of Media & Liteon about this. He PM’d me today about some outrageous way of bring a dead 32123S back to life & the damn method worked; he’s a Freak

:smiley: :smiley: :smiley:

I didn’t know that OC-Freak has such a reputation ! Should i post a new message at the media forum then? I’ll wait a while, maybe he’ll drop by in the next few hours … don’t wanna repost the same problem again and again … Tax may get irritated :wink:


#14

Hemispasm: check your yahoo mail :wink:


#15

Originally posted by OC-Freak
Hemispasm: check your yahoo mail :wink:

THANX !!!

I will try it tonight and see …

I think i have tried in the past with mtkflash with no luck, but i didn’t have the drive on the main ide nor did i use this particular firmware…

I will post when i get it done … Hope it works

I love it when CD Freaks make my day !! :smiley:


#16

I finally did flash the drive and guess what ??.. It became alive again, thanx to OC :smiley:
There’s nothing like bringing adead piece of machinery back to life - not to mention the 100$ i saved !!

There’s still a little problem though…

The drive is recognized under bios and windows, it plays dvds and autoruns games… the problem is that i can’t open any cd!!! When i go to my computer and press open cd or choose explore or search the cd it does nothing!! System don’t crash or anything, it just doesn’t respond!

Under dos when i use “dir” etc it opens the cd right away and reads all contents of the cd!

Any ideas? I thought of using the firmware provided by samsung but then again it doesn’t seem to me that it is a firmware thing. More like an xp bug or something!:confused:


#17

False alarm …

I just changed ide cables (put it on ide 2) and works just fine !! :confused:

Anyways, thanx a lot guys (special thanx to “God of Media&Liteon” !!! :wink: )


#18

That “can’t see files on cd” bug is a very common windows XP bug. I’ve not found a real working solution. :frowning:

You have grabbed all updates from windows update? If you have: I guess we just have to wait and hope that service pack 1 will fix the problem.


#19

Originally posted by OC-Freak
[B]That “can’t see files on cd” bug is a very common windows XP bug. I’ve not found a real working solution. :frowning:

You have grabbed all updates from windows update? If you have: I guess we just have to wait and hope that service pack 1 will fix the problem. [/B]

Well yes i have installed all windows updates up to now. If my memory serves me right, this has also occured with my plexie 40x a few weeks ago but was “fixed” by itself after a day or two.

Besides i have changed the drive from ide1 to 2 and it now works properly. A few minutes ago i put it back to ide1 as slave and works fine !!???

You never know with windows i guess !! … it’s like they have a mind of their own sometimes - and a very twisted one i might add :wink:

Anyways thanx a lot for your help OC-Freak !!! :smiley: