DosFlash V2.0 patched to support BH16NS40/BH16NS55 drives


#141

Is anything known about the LG BU30N?


#142

@tjn007 Good to hear it worked out for ya.

Let’s all keep the thread going by helping others!


#143

Has anyone gotten this to work for WH16NS60?

I have two of these drives and need to downgrade them.

I spent last weekend creating a bootable 32-but windows 10 Drive and trying to run DOS flash to see if it could read the WH16NS60, but couldn’t ever DOSFlash to actually install it’s drivers and see the drives.

From reading the forum it looks like no one has actually answered the original posters problem which is the same as mine. Downgrading the WH16NS60 drive.

I’m


#144

Theoretically, our modernized version supports this drive.
But these LG WH \ BH16NS60 models are only available for now in the US and Korea.
We have a clean firmware of 1.00 but we do not have access to these devices to test the operation.
If the upgraded DosFlash will create a valid copy of the firmware, it should also easily install the firmware 1.00.


#145

Using the FreeDos option with the excellent tutorial from @TheBelcherMan, is using DosFlash 1.7 vs DosFlash 2.0 that is up at the top of this thread imperative for this to work. And if 1.7 is needed for this to work 100%, where can I find the 1.7 version - I have read that it should be at the bottom of this thread but I cannot find it…

Thanks,
Bob


#146

here you go, dosflash 1.7 patched for free dos, link, and the thread that explains how to use it as well
https://drive.google.com/file/d/10IUtW4xE9e36yAyS5Zcb0hUWGBmhRBo0/view


#147

Thanks @er557 :+1:


#148

@czary2mary I would love to help you guys get this, but I’m having a hell of a time trying to do so.

I created a Windows 10 32-bit USB boot drive, but the app wouldn’t load the drivers and see the devices.

I’ve also tried to use @TheBelcherMan 's tutorial and do this through FlashDOS, but my bios doesn’t have a SATA as IDE option. It only has ATAPI and RAID as options. And it can’t see the drives like that either.

If someone can walk me through what to do and how to do it, I can get this done for your guys. I have two of these drives in my machine right now that are virtually useless. :frowning:


#149

Is there anyone based in the US that has a system setup that can handle this? I’d be willing to compensate someone for help fixing this at this point.


#150

Well in a last ditch effort I went through every one of my servers and found one I built that had the SATA to IDE Mode and an hour later I have the 1.01 firmware off my WH16NNS60 read and on it’s way to @czary2mary.

Hopefully this verifies that the 1.0 firmware for this drive will work as well.


#151

It looks like a copy of the firmware has been properly made.
Be sure to leave this copy as a backup copy without any changes.

Then transfer the calibration data to the clean LG WH16NS60 1.00 firmware (sent on PM) and upload it to the drive on the same computer where the correct reading of the LG WH16NS60 fw.1.01 firmware was made.


#152

Woohoo!!! WH16NS60 successfully downgraded to 1.0 firmware!

Thanks a ton, @czary2mary for all your help!


#153

@character82
Thank you for the test and confirmation of the operation.

We add clean firmware for LG WH16NS60 fw.1.00 and LG BU40N fw.1.00 models

LG WH16NS60 fw.1.00 Clean
LG WH16NS60 fw. 1.00 Clean.zip (1,3 MB)

LG BU40N fw.1.00 Clean
LG BU40N fw.1.00 Clean.zip (1,3 MB)


#154

Hi, I have the BU40N with firmware 1.02… I am going to try to downgrade to 1.00. If I try using the attached “LG BU40N fw.10.00 Clean” file, do I just start at step #4?


#155

Hi. I came across this guide and I would like to downgrade firmware
I managed to get Dos Flash working in Xp, but I get an error when trying to read

Production date 2018 04 11 on sticker


#156

You must start from the first point, have a copy of the fw.1.02 software and the calibration data to transfer to “clean firmware”

Is this a modernized version of DosFlashV2.0?


#157

I was successful in downgrading the BU40N to firmware 1.00. I tested and it is able to play the UHD (Black Panther), however, I am still unable to rip it using makemkv.

I was able to successfully rip the same UHD using an Asus BW-16D1HT. Do I assume that the BU40N is just not “friendly”?


#158

I have a WH16NS40 Svc Code NS50. I dumped the 1.03 firmware using “DosFlash32_BH16NS40”. I also downloaded the 1.02 firmware from this thread (filename “wh16ns40svc50firm102untouched.bin”). I’m stuck with the EEPROM_Data_Mover. It lets me select the firmware I dumped. When I try to select the 102 firmware “Select a clean BH16NS40 firmware file”, it returns the error “Incorrect Firmware file”.

Any help would be appreciated. I can upload my 1.03 firmware if that would help.

Thank you.


#159

Download ‘Clean_NS50_compatible_firmwares.7z’… link available in 1st post of this thread & extract/use ‘flash_HL-DT-ST_BD-RE_WH16NS40_1.02_NS50.bin’. Worked for me.


#160

Dear mods

I currently have the following drives
BH16NS40_1.01 and BW16D1ht_1.01

should i still use the dosflash to upgrade to the appropriate firmware for UHD ripping?
which firmware should i be using?
thanks much in adv!

t