DosFlash V2.0 patched to support BH16NS40/BH16NS55 drives


#121

Help needed, Please.

I am trying to downgrade the firmware on an ASUS BW-16D1HT and have tried following the instructions in this post, but keep failing. Is there someone who would be kind enough to help walk me through it? I have a couple of days left before the deadline to return the unit to where I bought it, but I would like to get the downgrade to work and keep the drive if possible.

Alternatively, I would be willing to ship the drive to someone and pay them to downgrade the firmware for me. Just let me know.

Thanks to all for this great community discussion.


#122

you probably got stuck in 3.03 which is no good, you want 3.02, this in ns50 drive so build yourself a winpe windows 7 flash drive x86, put dosflash32 from the archive in there, and in bios ide mode the flasher will load from winpe, find the drive on one of the sata ports, and from there you need to flash clean firmware. That’s what I figure, but I am not an expert yet.


#123

I guess where I am stuck is the part about putting the bios in ide mode. The drive is set up as an SCSI device. I don’t see anything in the computer bios about ide mode. what am I missing?

Thanks!


#124

Also, what is “winpe” does that mean portable? If so, that is what I have done. Then when I run Dosflash 32, there are no devices to chose from to flash.


#125

When I run DosFlash and select the port drop down box, there is nothing to choose from. Do I have to cause the BW-16D1HT to take up the SCSI - 1 port (which is currently the HDD), or something like that for it to recognize the ASUS drive?


#126

When you run DOSFLASH, does anything come up as a connected device? If so, try disconnecting everything and put the drive on the 0 port. If nothing shows up, then you need to change a setting in the BIOS. Keep in mind there is no guarantee DOSFLASH is going to work with your motherboard. I had to try two different computers.

Also, you may have to run DOSFLASH multiple times for it to work. First time I run it, nothing shows up. Second time, it finds the drive, but can’t read or write. Third time is the charm.


#127

All ASUS BW-16D1HT with manufacturing date January 2018 onwards, you cannot re-flash that firmware from higher to lower version. I returned mind to amazon and replaced with WH16NS40 with firmware v1.02. This is sure for UHD friendly drive (v1.03 is bad).


#128

Also, you find the BIOS setting in storage settings, or sata settings, or ahci settings, use ide in compatible mode, not ahci or raid, note that your OS may fail to boot in this state, so make sure to change it back once you are done with winPE. The drive should be ideally on the first or second sata port of the motherboard. BTW, ordered this same ASUS drive and it’s on the way, I for one don’t care about UHD so if it comes with 3.03 I don’t mind.

Another thing to keep in mind is to transfer the eeprom data from your firmware dump before flashing, as per the guide in the OP, with eeprom data mover.


#129

I have to change my firmware also; is it advisable to change bios/ufi to non-secure-boot before attempting this change?


#130

I would think so, yes, but it is related to booting your OS, which is not what you are doing, as the flasher does not work in windows x64. If you boot to a winpe win7 32 bit flash drive, portable, do this change and also change storage configuration to ide, compatible mode. Ideally dosflash32 will find your drive if on one of the first sata ports.


#131

I get an reading partition table drive error when I try to boot from the Flash Drive using FreeDos Boot. Any thoughts on how to fix? I’m using a 32 gig fd that I used Rufus to create the USB boot following the instructions above from TheBelcherMan. Trying to change LG WH16NS40 firmware to 1.02. Thanks for the help.


#132

Get some screenshots for me. We can figure it out :slight_smile:


#133

From the flash drive boot.


#134

On the Flash Drive


#135

Been I while since I posted this, but you’re at the step where you’re just trying to boot from the newly created USB Drive and it bombs?


#136

Are you able to do a “dir” and see all the files your copied over? My first guess is the usb drive is jacked up. You got another one?


#137

What’s connected to your SATA ports? Did you disconnect your internal hard drives?


#138

Here are the settings I used to format and create the bootable USB. I also used 2 separate flash drives. I can try another.


#139

Yes I did disconnect the internal drives.


#140

TheBelcherMan-

I went through the process again and saw the same error code. It’s been years since I ran anything in DOS so I was expecting to see the files come right up when I did the USB boot. When they didn’t I thought something was wrong. What I did different this time is I typed in DIR to see the files I did not see the first time and sure enough, they came up. Duh. Ran DosFlash and you were right, it’s a little tricky picking the SATA port and my was 2. Everything worked like a charm after that so I really appreciate your detailed steps to get it done. (especially when you said repeat, since it didn’t work the first time)

I paid over $100 to get 2 LG Drives from Amazon and when I realized I didn’t have the right firmware, I thought I was screwed. Finding this forum was a lifesaver.

Here’s my proof :slight_smile:

image