DosFlash V2.0 patched to support BH16NS40/BH16NS55 drives


#101

Of course yes.


#102

And so stupid question:

I updated it to 1.01 (I think; it’s been months). it shipped with 1.00. How would I revert back to 1.00? Assume I need a clean 1.00 from ?

And would I need to splice together a new firmware via hex editor the downgrade?


#103

You have to import specific data (laser calibration and so on) from the 1.01 dumped firmware to the new one (even if older).


#104

I didn’t keep track of everything that was done but I started with using DOSFlash (booting from USB FreeDOS) to put an image on the drive, looked like it was successful drive showing v1.02, but wouldn’t read, so I tried LG Crossflash (BH14NS40_N1.00-A4_patched.exe) and firmware file ‘flash_HL-DT-ST_BD-RE_WH14NS40_1.02_NS50.bin’. Same results, drive won’t read, but reports v1.02.


#105

yup. figured as much. had to do same with an Asus drive.

just need to know where to grab the 1.00 firmware and then what to copy via a hex editor to make a clean 1.00 for my drive


#106

Did you remember to use the “move” program on the dumped 1.00 and clean 1.02 firmware before you flashed the 1.02?


#107

Have you made copies of the factory firmware with the modified version of DosFlash?
Do you have it?

Make a modernized version of DosFlash dump firmware 1.01 and make a screen of this operation. Send me the firmware 1.01
We have a clean LG WH16NS60 firmware 1.00 but we have not tested this model BH \ WH16NS60 because they are available only in the USA and Korea so far and we have no access to it.


#108

I think I’m in trouble - overwrote the backup on USB.


#109

Not good, you’ll have to upload a copy of the software from another drive to the test.

Let someone send you a full copy of DosFlash. I am traveling and I do not have access to such software at this time.


#110

I saved a copy of my DOSFLASH dumps (non-clean) I can share. Will that help him?


#111

Can you try recovering the file using a tool like Recuva? https://filehippo.com/download_recuva/


#112

Thanks SizzleachestXXX, but no good, recovery didn’t work probably wrote too much information on the stick.

I do have a copy of DOSFLASH.


#113

How do you restore a copy made by DosFlash?
Post a screen with all the operations you perform.


#114

I have a copy of the application, not the ROM image.

I’ve decided to order another drive from NewEgg and start again, this time making backups of bakups.


#115

Hi guys, I seem to have killed my wh14ns40 service code ns50, it is recognized and opens tray but cant read anything. At first, I crossflashed to wh16ns58, successfully, and the issue appeared. I tried to revert to wh14ns40- issue persisted, upgraded firmware to 1.03, same issue, but now also cant flash anything due to error message(protection). Is there anything left to try or clean OPC data?


#116

Do you still have the ORIGINAL dump of the firmware you made?


#117

No, unfortunately I haven’t, I thought crossflash is “supported”


#118

There ought to be a warning at the beginning of these guides: BACKUP YOUR DUMPS!

If you screw up or have problems, you can restore back to stock/original. I keep the original dump of my drive in a folder with the drive’s serial number backed-up on my server. This should be obvious, but…


#119

already snagged a pioneer bdr-s09XLB off ebay for 70 bucks, learned my lesson…, probably will get another unit


#120

Thank you so much for this! I’d missed the DataMover step, and was really confused why my flashed drive couldn’t read any discs.