DosFlash V2.0 patched to support BH16NS40/BH16NS55 drives


#81

This is why I said it had the ‘potential’ for doing great things. :slight_smile:

I don’t know what can and can’t be done through patching, nor the exact limitations of JF

If someone, somewhere happens to actually know someone that helped write it…maybe now they’d be inclined to resurrect the tool.

Another option would be if someone knows the interface behind the X360USB PRO, whereby new software could be written to take advantage of it.

DosFlash with X360USB PRO support would be ideal :wink: Where’s Kai Schtrom these days?


#82

The USB Slim Portable LG WP50NB40 SVCNB50 Firmware 1.01 cannot read UHD disk… And i couldnt dump the firmware. ,fyi.


#83

I thought I should mention that the version of Dosflash being used in this guide is 1.7. I was trying with version 2 with the link at the top of this page and it just wouldn’t open in dos. If you scroll up to the bottom of this pages post then you can see a box with some ‘popular downloads’ or something and there you can download dosflash which is 1.7 which does work. I just used this method and my BH16NS40 drive can now see 4K blu rays however the two that I tried, Makemkv could not decrypt the video as the ‘volume key is unknown for this disc’. I believe this is just a problem on Makemkv’s side and not the drive itself as I can now see the discs and it’s name etc.


#84

Hi, I have an LG WH14NS40 OEM I just updated the firmware to 1.02 from 1.01 but I still can’t read UHD discs. It doesn’t even look like this drive has a service code at all, so I’m not sure what I can do if anything. Can anyone lead me to any useful information on this or if it just isn’t at all possible?

Thanks in advance.


#85

Any chance of getting the tweaked DosFlash for 64bit versions of windows?.
If not maybe, i could run this from winPE on a bootable usb. I don’t look forward to reinstalling windows to get my drive fixed. lol I wish I had read these forms before I flashed my drive.

update-
i created a winpe flash drive. now I just need to


#86

2013 unit is not UHD friendly. It should have SVC code NS40, thus it won’t read any UHD at all. :frowning:

You have to buy a unit built from 2015 to be able to read UHD discs.


#87

Booting on WinPE worked great. I watched this youtube video for the How to Create Windows 7 WinPE Boot Disk. I did add dosflash’s driver to the boot.wim. By mounting the image to a folder and coping the driver to system32\drivers. I’m unsure if that was necessary. Just didn’t want dosflash to complain that it couldn’t install the driver. Then I copied all the files I needed to reflash onto the same usb thumb drive. Then I just followed your directions. Though I was a bit confused on which clean image I was supposed to use. I just assumed i should make my bh16ns40 1.2 and not 1.3. Thank you for the help.


#88

Used these instructions today to downgrade my drive that I stupidly upgraded to 3.03 not knowing it would stop me from ripping UHD discs. Worked flawlessly and also did my friends brand new drive as well which he ordered on my recommendation, but came with 3.02. Both downgraded to 3.00 and ripping perfectly!

Good work!


#89

Just finished downgrading my WH16SN40 (svc code NS50, January 2018) that came with 1.03 drive to 1.02.

My PC with Asus Z170-Deluxe board could not get its SATA ports set to IDE, so I had to use my son’s PC that is using an old Intel DG33TL board and could. Then I used a Win 7 “Live CD” (basically a win PE disc) with the files from the initial post of this thread copied to it, and it worked fine.

The drive is now working with UHD discs on DVDFab Passkey.


#90

Hi,

It seems that I’ve exactly the same config as you sotvalley (Asus Z170 pro gaming + BH16NS55)
Did DosFlash work for you finally ?

Moreover I have an issue (out of the box, I didn’t try anything about flashing firmware yet).
I use windows 10 64bit and sometimes the drive just become unusable.
Suddently it is not longer detected by any burning/ripping/reading software and I have this “Device not migrated issue” like here https://answers.microsoft.com/en-us/windows/forum/windows_10-hardware/not-migrated-due-to-partial-or-ambiguous-match/9e18a99a-0131-422e-8527-fa20b2793e9e (exemple with a network card here). Seems related to drivers / window updates
After googling I checked windows files, upgrade chipset, install/uninstall/rollback drivers, still have the same issue…

Do you have the same problem ? Could it be related to riplock or not ? Or a failed drive ?

Thanks


#91

Hi all,

I finally successfully revert to 1.02 (from another pc).

About the second issue I had (Drive which suddenly disappeared). It was due to the cases I use RDP to remotely access to the computer. A default GPO is blocking direct access to removal storage via remote sessions. So nothing related to firmware.
Here’s the solution if it can help someone else : https://social.technet.microsoft.com/Forums/windows/en-US/1b486631-324e-48fd-8b40-efff1d17a892/controlling-cddvd-over-remote-desktop-connection?forum=w7itpromedia


#92

I have several questions, they are as follows:
When using the clean firmware and the dumped firmware to create the new firmware, does the new firmware to be flash retain the new media edit codecs with the writing scheme from the dumped firmware for faster writing?


#93

Only OPU calibration data are used.
We restore the recording strategies and other settings such as those stored in the firmware that we install in the drive.


#94

Thats great to know, you guys doing awesome work.


#95

Hello all. Just received an LG WS14NS40 from Newegg that came with 1.03. Been trying everything to get it down to 1.02, but no luck. I now have it in such bad shape that it won’t read a disc when loaded - doesn’t spin up. Came across this trail, and I’m hoping someone here can help me same this thing.


#96

What is this LG WS14NS40 model?
Can you put a photo of the drive and label it?


#97

Ah, sorry. That should have been WH14NS40 SVC code is NS50.


#98

Now, describe exactly what software change operations were performed.
On what Windows system and how connected computer drive.


#99

I got DOSFLASH.EXE to see the drive, but it says “MTK Vendor Intro failed on port 0xFF00.” It tries to resend the command, but the status never changes from 0x51. I tried the other sata port, but it doesn’t even detect it on that port. It’s definitely on the primary master. When I switch physical ports, it shows up on the secondary master, but still doesn’t respond.

If I go past the detection, it either doesn’t find the drive, or I get to the prompt to read, but then it can’t find the drive on the read attempt.

EDIT: I got a hold of another old computer and it worked! I was able to crossflash!


#100

Is it possible to downgrade the firmware on the LG BH16NS60 yet?

Now that I have a setup where I can dump firmware and flash, I’d like to fix that drive…