DosFlash V2.0 patched to support BH16NS40/BH16NS55 drives


#61

A suggestion: Can this post be given its own thread to increase visibility? I know many people, including myself, who use 64-bit Windows 10 and, because of this, we cannot use the 32-bit method described in this thread’s original post. However, your method immediately above works perfectly. Thanks!


#62

Hello, I set up a PC with windows 7 32 bit set in ide mode and seems to have managed to read the firmware that I will attach.
I do not know if everything went well because I had to repeat the operation several times.
Hello Roberto.
P.S. I hope I have made it useful.flash_HL-DT-ST_BD-RE_BH16NS40_50 Flash chip_1.01.zip (1,2 MB)


#63

Hi Roberto

Everything is well done! We thank you very much with @ Blackened2687!


#64

Thank you for your help


#65

I followed this guide from beginning to end but the drive will not read any discs after downgrade to 1.02. I was able to restore my initial “read” of 1.03 to the drive and discs can be read again. I have the exact same model as you (BH16NS40) and followed all steps. Any ideas?


#66

Please send me your 1.03 dump and I’ll be able to create a full working 1.02 firmware for you.

You will also need to follow other instructions I will give you. :wink:


#67

Sounds like you missed the Data mover step? No reading after the firmware downgrade upgrade usually indicates this?


#68

I did follow the data mover step…selecting the good 1.03 output, the firmware from the zip, giving the file a new name then writing back to drive via dosbox…


#69

I’m sending you again the invite of sending files, if you read messages it would be better. :smiley:


#70

103.BIN (2 MB)
Attached.Sorry, missed this the first time. I also just tried to use a hexeditor, pasting in the relevant pieces according to the guide on makemkv, still no luck.


#71

I’ve found the reason for which you will not be able to read UHD discs. Looking inside your 1.0.3 dump, your drive is a BH16NS40 but with NS40 SVC and not NS50 (which is needed for be a UHD friendly drive). So, my question is : Is your drive the same as in the image linked by TheBelcherMan ???

In other words, has your drive the same label stick reporting SVC Code : NS50 ?


#72

Ah, I did not take the computer apart to check it. Off to Amazon to buy an Asus…thanks for your help.


#73

Are the Asus drives known to be more “friendly” than the LGs? I don’t have the hardware that allows the use of DosFlash to work so looking for next best option. If not, anyone want a quick $20 to flash my LG WH16NS40?

UPDATE: I ended up ordering an Asus BW-16D1HT from Amazon this week and the unit appears to be built in Feb 2017 with FW 3.00, which is great as this drive is able to read UHDs fresh out of the box a year later. The LG I purchased was build date of Dec 2017 and came with v1.03. Granted the Asus was about $25 more, but I think it will be worth it.


#74

Hi, my LG BH16NS40 is dated 2013 so I assume it’s a svc 40, as it does not detect uhd bluray could you tell me if I have any chance to make it operational?
Thanks, Roberto.


#75

You haven’t, the drive is too old


#76

Man, you are a LIFESAVER. Beautiful walkthrough and saved me from having to mess with a bunch of old computer parts to Frankenstein together another machine. Got my WH16NS40 back to 1.02 and am now reading 4K just fine!


#77

This is a great software, but will one after another support for other LG drive it?


#78

Only the modernized version of DosFlash will work properly with LG models equipped with MediaTek MT chipsets.

LG BluRay:
LG BH \ WH \ 14 \ 16NS40 \ 48 and technical clones \ OEM Asus \ HP - hardware SVC CODE: NS40

LG BH \ WH \ 14 \ 16NS40 \ 50 \ 55 \ 58 and technical clones \ OEM Asus \ HP - hardware SVC CODE: NS50 \ 51 \ 55 \ 58

LG BH \ WH16NS60 - hardware SVC CODE: NS60

LG DVDRW

LG GH22NS90
LG GH24NS90
LG GH22NS96
LG GH24NS95
LG GH24NSB0
LG GH24NSC0
LG GH24NSD0 \ D1
and their clones \ OEM ASUS \ HP \ Pioneer


#79

This might be a little bit ‘out there’, but once upon a time there was an xbox 360 tool called JungleFlasher and hardware known as the X360USB PRO (and later an X360USB PRO 2).

Combined, they had great potential for doing everything DosFlash could do, but without the need to disable driver signing stuff or revert to IDE mode etc. All you had to do was plug it in via USB and off you go.

JungleFlasher supported the X360USB and could do all sorts of things with the XBOX 360 drives and I’m sure it would be able to do the same with most mediatek stuff, if only it didn’t seem to be locked down to xbox variations.

If anyone with knowledge in this area happens to have the hardware and software to hand, perhaps they could have a go at ‘patching’ that too?

I did try asking at the time if they’d make it more generic so I could use it for reading firmware from the more recent LiteOn burners, but I didn’t have the right ‘contacts’ and it fell on deaf ears. :frowning:


#80

I’ve already tried JungleFlasher and it only shows manufacter/device ID for MediaTek devices like ASUS/LG drives, but it will never allow to dump/write any firmware, as it is a software written for X360 drives which have 256 kb size lenght as firmware, so how could you tell to JungleFlasher to dump a 16 Mbit eeprom (2 Mbyte file) instead of a 2 Mbit eeprom (256 kb file) ???