DosFlash V2.0 patched to support BH16NS40/BH16NS55 drives


#223

it’s impossible to download from zippyshare. can anyone post a clean version of LG WH16NS60 FW 1.00 Appreciate any help. Thanks!


#224

Here you are…

flash_HL-DT-ST_BD-RE_WH16NS60_1.00.zip (1.3 MB)

One way to avoid all the crap on Zippyshare is to use Firefox with uBlock Origin AddOn.


#225

Many Thanks!!


#226

Hi Guys,
I tried to downgrade my LG BH16 NS40 (manufactured in June 2014) from Firmware 1.03 to 1.02. using the TheBelcherMan’s Method under FreeDos.
Sadly, it doesn’t read any Disc now that I throw at it. I guess I made a fatal error when creating the dump. I did not name it with the appropriate type ending .bin, but just named it 103. Could this be the reason for the drive not working?
Is there a possibility to revive the drive with another dump or do I have to get a new one anyway because mine is too old to read UHD Discs?

Many thanks in advance!!

EDIT
I just went back to Firmware 1.03 with the original dump that I created and the drive is working again. Maybe it is simply too old to work with the BH16NS40_EEPROM_DATA_Mover?
Any suggestions on which new drive I should be buying?


#227

The drive has to have SVC CODE: NS50 in the lower right of the manufacturers label.
This is shown in an image posted by TheBelcherMan Feb. 1,2018.
Best I can tell post#59.
If your LG BH16NS40 is too old to have the SVC CODE: NS50 then the firmware flash won’t work.
So that is what you need to check for.


#228

I just took a look - seems like my drvie doesn’t even have a SVC Code. So I’m gessing that it is definitely too old.
Many thanks though for the fast reply though!


#229

WH16NS40 SVC Code NS50 - 1.00

CLEAN_HL-DT-ST_BD-RE_WH16NS40_1.00_NS50.zip (1.3 MB)


#230

I gave this guide a try again and I have now downgraded to Firmware 1.02
Maybe I forgot to set IDE mode in bios last time I tried
X79 deluxe motherboard, Windows Xp 32bit.
Thanks :slight_smile:


#231

excuse me, maybe i’m so stupid… I understan to put out my LG BE16NU50 from is box and link it with an old pc in ide, But, I’ve not understood th name of the exact clean firmware I mus download (actually I’ve 1.02 and andestend to dump to 1.01, but which ?.. is that ?
DosFlash32_BH16NS40_patched.zip (104,2 KB)


#232

I found this thread with a google search. Just wanted to say that I was successful with the flashing tutorial provided and had no errors in dosflash.

What I used

  1. Dell Optiplex 380 with a copy of Windows 7 32-bit Dell OEM CD installed.
  2. Dosflash 2.0 provided here
  3. My drive is an LG WH16NS40 SVC NS50

My drive came with version 1.02 Originally. I flashed 1.03 thinking it would resolve some errors I was getting when reading burned discs (mostly BD50) but it made things worse and windows reported “bad blocks” in event viewer. I know the burns were okay because they all completed but did give me I/O errors in imgburn.

I tried a few discs in my drive after flashing.
Some CD-R’s & DVD’s and they all read. I don’t have any bluray’s to try but can I assume that since my drive is reading media that I did this correctly? I know on the PS2 you can have the drive read CD games but DVD based games may not work and vise-versa. I had to do this at work so when I get home tonight I will test some Bluray’s

Thanks again for posting this method because from the manufactors point of view (LG) your stuck on firmware v1.03 and cannot do anything.


#233

Mostly because of the PUH has 2 lenses, 1 for cd and one for dvd. :wink:

Did you follow the guide exactly? If yes, all should be fine.
Did you try an UltraHD BD disc with makemkv??


#234

For my needs NoScript is all I need. :wink:


#235

I don’t have any UltraHD BD discs on hand.

I did try the following media formats
CD-R
DVD-R
DVD+R
DVD+R DL
BD-R
BD-R DL
BDXL

All of these were able to read without issue.
I also burned a few BD50’s and they worked as well.

So at this point I think I’m good to go.
Thanks for the tip.


#236

Yes, all seems to be fine!


#237

hello !
downflashed perfectly, now I can read my original 4k uhd disks …all ok !!! many many thanks !!!
best regards


#238

DosFlash does not work on Windows 10, I get the digital driver signature issue, even when disabling every requirements. I then ran a Windows 7 Virtual Machine, disabled signature enforcement at boot, same issue! How do you all manage to run this software?!


#239

Start by reading post #1 AGAIN.


#240

:slight_smile: You’re funny.

Anyway, running a virtual machine with Windows XP seems to do the trick for now.


#241

Ok, Windows XP on a Virtual Machine allowed me to go past the signature issue, but it is giving me trouble recognizing the drive. Has anyone been successful running DosFlash 32 on a Windows 10 x64 platform?


#242

The truth is, you are ignorant seeing the truth and what’s obvious and explained since at least post # 1 in this very thread.
Screw your frickin WiX and follow the how to explained many times…