DosFlash V2.0 patched to support BH16NS40/BH16NS55 drives


#203

‘A’ the first one


#204

WH16NS60 successfully downgraded to 1.0 firmware!

Thank you all !!


#205

I get past the point of creating the .bin file, and attempt to run EEPROM data mover. I get an error message “Incorrect firmware file” when I try to load my .bin. Granted I have a WH16NS40 instead of a BH16NS40 but I’ve seen others with this model successfully complete this process. Any advice would be greatly appreciated!


#206

Either a defective firmware or badly marked.
Submit for checking.


#207

The first item necessary is a motherboard that is not UEFI only.
You need to set your “BIOS” to Legacy or IDE boot.
You will need to create a bootable USB flash drive as in the instructions below.
Then boot to a USB drive into a DOS environment.
If you can’t do this the DosFlash32.exe won’t work.

These instructions are taken from
http://www.makemkv.com/forum2/viewtopic.php?f=16&t=17058
By TeddyRaspin.
I’ve used them successfully on 2 LG drives.
One WH16NS40(mine &
one BH16NS55 (for a friend).
Both were NS50 & version 1.03.

Steps for dumping firmware : (DOS Method)

  1. Prepare an USB FreeDOS bootable stick, using Rufus (which can be
    downloaded here).
  2. Unzip on USB root the DOSFLASH.zip attached file.
  3. Enter into motherboard BIOS settings and set SATA Controller as IDE
    (or Legacy). If you can handle only AHCI, DOSFLASH will not properly
    work, or it could not work at all.
    Be sure to connect your ASUS/LG drive alone, as SATA Primary
    Master (USE SATA1 or SATA2 controller ports).
  4. Disable CSM (Compatibility Support Mode) and boot from the USB
    stick.
  5. At the command Prompt, type “DOSFLASH” and press Enter. If it does
    not detect anything, retype again. It could be needed to type
    DOSFLASH 3-4 times before ASUS/LG device be properly detected. It
    should show the Manufacter ID of your device, namely “MediaTek
    MT1959”.
  6. Press the relative number of the detected device (1 in my case) and
    press “R” (without quotes) to dump eeprom firmware.
  7. Save firmware with the name you like and keep it safe.
  8. At this point you can zip it and send this file to me and I will create
    a 100% working firmware in order to turn back the UHD capabilities
    as well as to fix the “Drive Signature DV value” or “Bus Encryption”
    error shown in AnyDVD HD !!!
    (For # 8 I don’t know if TeddyRaspin still does this. You won’t need to do this if you can use the Hex editor instructions below.)

Steps for importing data from backup firmwares : (Hex Editing)

  1. Install WinHEX (or any other similar Hex Editor).
  2. Open the dumped DOSFLASH firmware and the new one you want to
    flash on your device. (*)
  3. On the backup firmware (the dumped one) select hex range starting
    from 0x1E8000 offset to 0x1E84FF and copy it in the same range of
    the new firmware. (**)
  4. Do the same as point 3. but starting now from 0x1E9000 to the end
    of the file. (***)
  5. Save the new firmware (for example as TEST.BIN).
  6. You are now ready for flashing (or crossflashing) the new firmware
    (or a downgrade version).

Steps for flashing firmware : (DOSFLASH modified method)

  1. Follow the same steps written for the dumping method, until you
    arrive at the DOSFLASH command prompt.
  2. Be sure to have copied the new prepared (TEST.BIN) firmware onto
    root of your USB stick.
  3. Press the relative number of your detected device under DOSFLASH
    (1 in my case).
  4. Type “E” (without quotes) to fully erase your drive eeprom and wait
    for the end of the task.
  5. Now type again DOSFLASH, press the relative number and the “W”
    letter (without quotes) for writing firmware.
  6. Type the firmware name (TEST.BIN in this example) and wait 1 min
    or less to the end of the process. (It has to write 32 rom banks
    starting from 0 to 31).
  7. Eventually you will see the blue light of your device blinking. This is
    the proof your drive has been initialized again and ready to work.
  8. Reconnect your devices as before, do the same with bios settings for
    UEFI support and boot your Windows OS.
  9. Now you’re ready to see if your work has been properly done and
    your device working again with UHD discs !!!
    ** - This point is the most important of all, as it contains the Drive
    Signature (DV Value) needed for the bus encryption and it is specific for
    each drive !!!

You should have a working version 1.02 with this method.

This is a link to the Dosflash_Windows7.zip on the makemkv web site.
It is the one I used because I used Windows 7 to flash the firmware.
https://www.makemkv.com/forum/download/file.php?id=1316
The ones here may work fine but they are not what I used.

You won’t need the following.
Clean_NS50_compatible_firmwares.7z
EEPROM_Data_Mover
BH16NS40_Firmware_Dump_Cleaner.zip


#208

Is there a way to downgrade with some kind of virtualbox ? I’ve recently got an BH16NS55 (SCV Code: NS55) but it’s in 1.03

I’ve tried on two computers with different motherboard (B360M-DS3H, MSI B250 Bazooka), but both of them have AHCI for SATA mode only and DosFlash don’t see the drive, even with an old 32 bit Window 7 Live USB

I’ve also access to a macbook pro, but I think there is any hope here.

This is so sad.


#209

I checked the manual for both MBs.
The B360M-DS3H no setting for legacy.
The MSI B250 Bazooka manual showed this
:arrow_forward::arrow_forward:Boot Mode Select [LEGACY+UEFI]
Sets the system boot mode from legacy or UEFI architecture depending on OS
installation requirement. This item will become un-selectable and will be configured
automatically by BIOS when Windows 8.1/ 10 WHQL Support is enabled.
[UEFI] Enables UEFI BIOS boot mode support only.
[LEGACY+UEFI] Enables both Legacy BIOS boot mode and UEFI BIOS boot
mode.

So it may be capable if you disable WHQL if you are using Windows 8.1/ 10.
Then the [LEGACY+UEFI] will be selectable.
I don’t have this MB so I can’t say for sure.
It wouldn’t hurt to try it.to see of it will boot from a DosFlash bootable USB flash drive.
Then detect the BH16NS55 optical drive.
Remember you may have to try several times with DosFlash to get it to detect.

I don’t have a Mac so I don’t know about it.


#210

I keep getting the error. “Unknown flash chip!” when running dosflash from FreeDOS. I get a similar error when I run it in Windows 7x86 using dosflash32. Is there anything I can do to get past this?


#211

Which drive exactly do you have ?


#212

I’ve only done this to 2 drives & I didn’t have the message you are getting.
The suggestion I’ve read for this is to keep trying until it works.
If you are getting past the “dosflash” command .
Make sure your selecting the correct drive number.
If the message is after you enter “R” the keep trying to read the drive.


#213

For all the folks that don’t have access to a motherboard with IDE support, there is hope, if you’re willing to spend another $30 or so. This also works if, like me, you’re too lazy to dual boot to something other than Windows 10.

I picked up:

  1. one PCIE IDE adapter card
  2. one IDE/SATA converter

This monstrous little daisy chain allowed me to read and write the firmware of an LG WH16NS40 bought on 9/22/2018 to downgrade from 1.03 to 1.02 on my ASUS Prime X299 Deluxe motherboard. UHD BluRays once again reading as I type.

The linked cards are clearly marked and easy to setup. Without all the gory details, the tools/process I used were: Rufus, DosFlash, Data_Mover w/ Clean Firmwares. Kudos to everyone else that figured that out.

Just wanted to point out these little toys as a thanks for all the great information that got me my old drives back and a couple of spares to boot.

Cheers!


#214

Thanks for sharing this info, but why not buy a StarTech PCIE SATA adapter card ? Did anyone try that ?

I think that the trick is in the controller built on the pcie card, otherwise a PCIE SATA card would do the trick anyway.


#215

I have a PCIE/SATA adapter that says VanTech on it to fit some extra drives in my box. Seem to recall the box the adapter came in said StarTech?

Regardless DosFlash of any ilk didn’t seem to like it. Drives weren’t recognized at all and BIOS recognized them as SATA drives. My guess is that you need to force the IDE interface which is different from PCIE? Maybe?

Though maybe a different brand or feature set would do the job better.

EDIT: My bad, VanTech and StarTech are different companies. I mean, the names say so, no? Must have been looking at them on the web same day and got the one because it was available that day at Fry’s


#216

Well, according to the StarTech specs it seems that the PEX2IDE card has the JMicron - JMB368 chipset.

You can read specs here

Thus, maybe a pcie2sata controller with the same chipset ID will do the trick.


#217

Unless you linked to the wrong card, that’s the same as the first card that I linked to on Amazon. Looks like we’re suggesting the same thing, just want to make sure.

If that is the correct link, the problem is that card doesn’t have SATA ports on it so you can’t hook a SATA drive up to it. But the second link I posted is a SATA to IDE adapter that plugs right into the IDE port on the card you linked to.


#218

What I’m saying is that the most important trick is the chipset id. In our case, the pcie -> ide card you linked (like the specs link I attached above), uses the JMicron JMB368 chipset which is properly detected by DOSFLASH, while the PCIE -> SATA card (without the ide -> sata addon) uses the Marvell controller which is not DOSFLASH compatible, that’s all.


#219

Gotcha!

Wan’t fully groking the ‘PCIE2SATA controller with the same chipset’ line from the first post.

Well, if anyone can find such a beast it’s going to be less flimsy than the two card approach for sure. =)


#220

I have a WH16NS40 SVC Code NS50 with 1.03 firmware. I bought it last week and received it 3 days ago.


#221

I’ve ran it on a Dell, HP, and Asus mobo and I get the same “Unknown flash chip!” error. Is it possible that I have a newer more locked down version.


#222

Chris_Smith I used a Dell when I did this.
I don’t know if there are newer locked down versions.

Does your drive play regular blu rays OK ?
Also can it copy a regular blu ray ?
In other words is it a working drive?

I can’t easily test my WH16NS40 SVC Code NS50 as I have it in a USB enclosure.
The BH16NS55 I flashed was for a friend that lives in another city.
Both went without a problem.

I did test my DosFlash drive on the Dell again & it detected the WH14NS40 that is internal in it.
To go further than that with this older blu ray drive I would have had to open the Dell case & unplug all the SATA cables .
Then put the WH14NS40 cable in the Primary Master slot.
That is the way I flashed the other drives.
I would only read the WH14NS40 as it has the latest firmware for it already.
These drives can’t be flashed for UHD capability.
Some people tried & bricked them.
A few were able to reverse that but not all.

Another thing you might check is your SATA cable try a different one.