DosFlash V2.0 patched to support BH16NS40/BH16NS55 drives


#182

Only the modified version of DosFlash runs on 32 bit systems.


#183

Ok, I can install windows 7 next question My custom computer is new and seems my motherboard doesn’t allow IDE only ACHI and Raid is there anyway to get this to work without using IDE


#185

I am trying to flash a WH16NS40 using TheBelcherMan’s DOS method. I get to step through step 9, it detects my optical drive and assigns it port 0 as primary. However there is no prompt “What do you want to do?”, it simply is a flashing cursor and regardless of what key I hit on the keyboard it does nothing but continue to show a flashing cursor.


#186

i downgrade my WH16NS60 from 1.01 to 1.00. in windows xp, everything runs smoothly, but now the drive can’t read any disc !!
HELP ME PLEASE


#187

I hope you made a backup using dosflash before the downgrade (and store it in a safe place). That’s not only common sense, but in this case a must, as the flash contains data unique to the drive (such as serial number, but most importantly calibration data of at least the OPU).
Since you have a new drive (NS60) I’m not sure the data mover (to copy the unique data from your backup to the file to be flashed) still works as it should, although it is likely.
Did you copy the unique data from your backup to the 1.00 firmware before flashing?


#188

It does run on my 64-bits Windows 7 without any issues (as does the unmodified DosFlash64). It still uses the 64-bits portio driver, of course (64-bit OS cannot use 32-bit drivers), but it still works fine. I backed up and flashed my 1.03 BH16NS55 just fine with it.


#189

no i did not do backup, i tried to update with firmware 1.01 from LG website without positive result …
my drive is dead? Or is it possible to fix it?


#190

Which is the method you followed to downgrade your unit ?

I think you can throw your drive into the toilet.


#191

I based myself with the method found here
https://club.myce.com/t/dosflash-v2-0-patched-to-support-bh16ns40-bh16ns55-drives/399911/152?u=anthony_dumais


#192

And thus did you flash a clean 1.00 firmware ? That’s the only reason why you can’t read any discs anymore.


#193

yes whit clean 1.00 firmware !


#194

You’ve done the worst thing for your drive, which is useless and can be thrown into the toilet.

In other words, you should consider two main aspects:

  1. Read guides carefully

  2. Buy another drive.

Best regards.


#195

Please help!!
I use gagbyte Z270-HD3 motherboard .But it can not change SATA mode to IDE MODE


#196

As it turned out a drive can sometimes be revived with calibration data from another drive.

@Anthony_Dumais
Attached are three dosflash dumps of NS60 drives.
And here are many NS50 dumps which you can try as well: https://forum.redfox.bz/threads/dumping-downgrading-firmware-on-uhd-friendly-devices.74479/page-19#post-489726

WH16NS60.7z (1.2 MB)


#197

@bigbigbig
In my experience, if your mother board doesn’t support this, then you have to find one that does. I could never get it to work until I found one that did and then it worked the first time.


#198

Yes, I was indeed able to unbrick my drive (after flashing the wrong firmware and losing my dump, don’t ask me how I’m still traumatized). Found on the thread you linked a WH16NS40 an untouched 1.03 dump from a drive manufactured a month before mine and it can now read and write fine. Now I’m a little concerned that there might still be some slight miscalibration (no optical block is the same, I guess :confused:) but I can burn relatively fast. One thing I’ve noticed is that the max I can do with my media is 4.1x even if it’s 6x compatible but it might always have been that way. Also didn’t remember the spin was so noisy/scratchy. Erh, it works, it works.


#199

All is not lost, if you can find somebody else’s untouched dump of a similar drive. With luck the calibration data will be good enough for your drive. I managed to find one for my WH16NS40 on the thread @Terramex linked.
Good luck.


#200

Tanks you so much !
i will try this… to follow


#201

yeah it works !! mydrive has resurrected


#202

Just for my pure curiosity which specific firmware did you flash ?

Thanks. :slight_smile: