DosFlash V2.0 patched to support BH16NS40/BH16NS55 drives


#164

Wow that was painful but it worked! I have an ASUS motherboard running Windows 10 64 bit.

I could not get portia.sys to work no matter how much signatures I disabled. Only your method worked.

I had to change my SATA fro ACHI to IDE, as well as move the LG SATA cable into position 2 from position 4, and then use Rufus to boot into DOS just as you said, worked perfectly but painful. Thank you so much!


#165

@Anish_Chari

Ya but it was fun, wasn’t it :slightly_smiling_face:


#166

Oh man I left out the more painful parts. I first tried the above methods - disabling all kinds of drive signaturing, even downloading 64 bit versions of Dosflashing without any luck. I probably rebooted my computer more that day than in the last 6 months.

But then when I tried your method, I have a huge graphics card GTX770 that covers up my 1 and 2 SATA ports. I could not for the life of me fish the SATA cable into the motherboard, because the spring clip on the SATA cable and sheered off and was stuck inside the port! So I had to take that the GPU, remove the broken clip, then get the Blueray drive in the right position, and to be safe disconnected all other SATA drives. Even then I had to run dosflash a few times to recognize the drive. And then when I reconnected the other hard drive to boot into windows I got a terrifying ‘unable to boot into windows’ blue screen error, but thankfully that was because I hadn’t gone back into ACHI configuration and from there it worked.

AND ALL BECAUSE OF A STUPID FIRMWARE UPGRADE THAT NEUTERS THE DRIVE!!!


#167

Does the EEPROM Data Mover write the original laser calibration data to the new firmware?

I remember reading about downgrading methods last year and I think a lot of people lost their calibration data because they flashed firmware files that contained different calibration data, etc.

Also, what is the best downgrade firmware for my LG WH16NS40 v1.03 (NS50) drive? I think it’s [flash_HL-DT-ST-BD-RE_WH16NS40_1.02_NS50.bin], right?


#168

‘clean’ file is correct. & thats’s the point of the ‘Data Mover’… take calibration from your dump & transfer it to the ‘clean’ firmware.


#169

I downgraded my BH16NS40 with the clean firmware and ended up losing the calibration data. How do I restore this data to recover the drive, as it does not read disk and only opens the tray?


#170

IF you followed the instructions & dumped the original FW, you have 2 choices:

  • Flash the drive with the dump (leaves you where you started)

  • Use the ‘EEPROM Data Mover’ to transfer your calibration data from your dump to the ‘clean’ image.

Otherwise, dunno… you MAY be stuck with a brick.


#171

Attention flashers:

I still have 9 LG-WH16NS40s, svc code NS50, rom ver. 1.02 manufactured between Sept 2016 and August 2017, original factory firmware loaded no flashing required plug and play and backup your 4K discs, for sale, at cost.

I also have 7 LG-BH16NS40s, same specs as above. These are the retail packaged version of the WH16NS40 meaning these drives have spent their lives in protective styro foam end caps rather than stacked 10 high with zero protection.

Arriving soon 4 original factory firmware loaded ASUS BW-16D1HT, manufactured March 2017, firmware 3.00d (macOS will report the d, windows no). Due to all the overblown hype because of the extra 2x you gain in speed, which is negligible in the long run, these will still be for sale at cost but not cheap, due to multiple ships, and a cash tip to the manager who made it happen (long story, best told offline).

So if you value an authentic UHD friendly drive that’s not had it’s firmware inbred using a dos utility in the year 2018 by all means drop me a line at alexcoluzzi32@gmail.com and you’ll have your drive two days later*

*if you live in the SF Bay Area you’ll have your drive the same day, and possibly a beer.

Plenty of references on makemkv and avs forums from happy users. Each drive tested by me with a virgin 4K UHD and guaranteed to work (warranty still intact, because, ya know, it hasn’t had it’s firmware polluted).

thank you for reading,

Alex


#172

Successfully downgraded WH16NS60 from 1.01 back to 1.00. Thanks for the clean firmware and guide. It now works again with DeUHD.


#173

I have been unable to downgrade my WH16NS60 from 1.01 to 1.00. Everything runs smoothly, but when I get to the last step of writing of the firmware I keep getting the error “Firmware file is not present!”

I can’t upload the backup that I did, nor the bin file created from the mover stage, since I am a newbie.


#174

I ended up being able to downgrade my WH16NS60. Thank you so very much for posting these instructions and for all the work that you have put into it. I’m not sure what was going wrong with my previous attempts, but what I did this time that worked was to install a fresh copy of 32 bit Windows 7 Home onto a spare hard drive, and didn’t do any updates (in fact I never even connected it to the internet). Then when I went through the steps at the start of this thread I was able to downgrade my BIOS from 1.01 to 1.00 in about 5 minutes. I wish I would have just done this before rather than messing around with Windows 10, then a Windows 8 computer I have running Windows Media Center, and then the Rufus USB boot drive - none of those worked for me. Total time including installing Windows 7 was about 30 minutes - Versus the 4 hours I wasted on it previously trying it the other ways, heh. Thanks again, czary2mary.


#176

I get an BH16NS55 V.1.03. I try to downgrade the Firmware with the Windows method. I get the following Error:


Any ideas?


#177

Is this a modernized version by us DosFlash V2.0?
If so, then there should not be such a message.? !

The message indicates lack of access to the device.
There may be many reasons.
Which system, hard drive in IDE mode, what SATA controller, SATA drivers?


#178

I’m getting a weird issue when I open DOSFlash x64 my cd drive disables itself.

When I re-enable drive still does not show up by program and if I close DosFlash V2 and re open the drive is disabled again.


#179

how did you do this I have same drive but program keeps disabling my cd drive


#180

Yes, it is a Version from here.
System is Windows 7, 32Bit, Sata controllers in IDE-Mode, standarddriver from Windows 7 Image.
I also tried the DOS Method with the same problem.
Also I have another Drive here (ASUS BC12D2HT) with Firmware 1.00. Here I get the same error.


#181

Check exactly what SATA controller you have on the motherboard to which the drives are connected. Check afterwards whether there are SATA drivers from the SATA controller manufacturer for Windows 7 32bit!
There is no program to access the device.


#182

Only the modified version of DosFlash runs on 32 bit systems.


#183

Ok, I can install windows 7 next question My custom computer is new and seems my motherboard doesn’t allow IDE only ACHI and Raid is there anyway to get this to work without using IDE


#185

I am trying to flash a WH16NS40 using TheBelcherMan’s DOS method. I get to step through step 9, it detects my optical drive and assigns it port 0 as primary. However there is no prompt “What do you want to do?”, it simply is a flashing cursor and regardless of what key I hit on the keyboard it does nothing but continue to show a flashing cursor.