DOS GUI Problem

Hi, everyone!
I have this problem: whenever I enter a Dos Gui (for BIOS settings, or other low level entry progs like BootitNG or CheckitPro, whatever), after a while the mouse cursor jumps to the edge of the screen and stays there, not responding, and I can navigate only by keyboard shortcuts. Any ideas what I should do? Thank you, Peter.
P.S. : I run on XP PRO SP1

Though I can’t say exactly what’s causing your problems - I can say this;

XP contains both COMMAND.COM and CMD.EXE (Both are CLI = Command Line Interface)

COMMAND.COM (16bit, from DOS era) …and CMD.EXE (32bit, NTFS only).

some related files are (google on these) ntvdm, wowexec, autoexec.nt, config.nt, and the Environment Variables also play a role)

XP (and all NTFS) is all 32bit - doesn’t contain any MS-DOS (although billy would have you believe this, describing the command console does ‘appear’ as an old style DOS terminal window) - and XP does allow running of 16bit applications (ntvdm (the subsystem), and wowexec.exe are part of this “emulation”)

Note also; The “Recovery Console” (Booted from XP CD) uses a yet even a different “Command Interpreter” still…As far as I can remember.


I think you likely have either a Mouse driver issue, or some funky config setting that doesn’t allow enough RAM while in a console…for ex; I know when running an older 16bit Game and using “Compatibility Mode” in XP to achieve this, one may need to “allocate” enough RAM to that VirtualDOS session. (look into that).

Plus - IIRC, once WOW and NTVDM are started, used, and then no longer needed - ending those processes manually (using TaskManager "may have “oddball” side effects).

Configuring a Boot Manager such as BootitNG most certainly is not using 32bit mode - yet conversly: the BIOS does not use a Mouse at all…unless, I guess you mean some sort of Mobo utility that enables this such as a GUI for Flashing, etc.

You’re right, no mouse in bios settings; but other low level entry progs invariably produce the mouse freeze. Any ideas how to fix this? Thanx.