DOS filenames w/o TILDE

vbimport

#1

Hi,
I have a setup CD I burnt with Nero 5.5 that has a bunch of W98
directories (folders) with long names.
When I boot from a DOS diskette, I see the folder names in short
format, like this:
CHATTO~1 <DIR> 02-06-03 8:38a
FILETO~1 <DIR> 02-06-03 8:38a
GENERA~1 <DIR> 02-06-03 8:38a
HWTOOLS <DIR> 02-06-03 8:38a
INTERN~1 <DIR> 02-06-03 8:38a
KIDSTUFF <DIR> 02-06-03 8:38a
MEDIAT~1 <DIR> 02-06-03 8:38a
NETWOR~1 <DIR> 02-06-03 8:38a
PEFORM~1 <DIR> 02-06-03 8:38a
PICTUR~1 <DIR> 02-06-03 8:38a
SECURI~1 <DIR> 02-06-03 8:38a

Now I tried to make a new one, and something has changed!
In Windows I still see the long names, but in DOS boot I get
folder names like this:
CHATTOOL <DIR> 07-30-04 12:48a
FILETOOL <DIR> 07-30-04 12:48a
GENERALT <DIR> 07-30-04 12:48a
HWTOOLS <DIR> 07-30-04 12:48a
INTERNET <DIR> 07-30-04 12:48a
KIDSTUFF <DIR> 07-30-04 12:48a
MEDIATOO <DIR> 07-30-04 12:48a
NETWORKI <DIR> 07-30-04 12:48a
PEFORMAN <DIR> 07-30-04 12:48a
PICTURET <DIR> 07-30-04 12:48a
SECURITY <DIR> 07-30-04 12:48a

What is worse is that in DOS, I cannot get into those
directories. If I try to do CD GENERALT, it says that there is
no such directory! :frowning:

I don’t know what caused this, so I have tried to change
settings hoping to correct it… I have tried ALL combinations
in Nero of ISO Level 1 or 2, and Track Mode 1 or 2, but in
none of them do I get the tilde format DOS file names.

When I used Track Mode 2 at least I was able to CD, apparently
the names were REALLY those short forms, but How do I get back
what I used to have?

Thank you for your help!
Shimon


#2

Your DOS boot disk does not support joliet " long file names " try downloading UBD “universal boot disk” for this function.

It’s not your burnt cd, the first one looks perfect booting from a DOS disk.


#3

Both directory listings that I posted were made with the same
DOS, from the same boot diskette. The “DOS” on it was made
with Win98-SE, which I thought did recognize long file names.

In any case, this DOS shows the tilde format for one CD, but not
the other, so it looks like Nero is making the folder names differently
now.

Please explain what I misunderstood here. I appreciate your help!

Thank you,
Shimon


#4

I absolutely agree that Nero changed something…ISO mode I’d guess. I tinker alot in dos to this day, and your first directory listing looked native.

Win98se recognizes joliet (long file names) but not in dos mode, for that you need ubd, or a similar utility.


#5

Weird. Totally Weird. :frowning:

I got an email from Nero techsupport which said:
> Set the following:
> File Name… -> Iso Level 2
> Format -> Mode 1
> Character Set -> ISO 9660

I did that (and also set on the ISO page: Joliet secondary volume descriptor
and directories).

I downloaded and built the UBD (found at http://www.startdisk.com/Web1/ubd/ubd.htm )

When I booted that disk, and looked at the CD I just burnt,
it showed this astonishing output:

Volume in drive X is TESTINF
Directory of X:\

CHATTOOL S <DIR> 01-29-04 9:33p
FILETOOL S <DIR> 01-29-04 9:54p
GENERALT OOL <DIR> 07-29-04 9:44p
HWTOOLS <DIR> 07-28-04 11:33p
INTERNET APP <DIR> 05-18-04 12:06a
KIDSTUFF <DIR> 05-19-04 10:13p
MEDIATOO LS <DIR> 05-18-04 7:52a
NETWORKI NG <DIR> 05-18-04 10:44p
PEFORMAN CE <DIR> 06-07-04 9:35p
PICTURET OOL <DIR> 06-08-04 9:18a
SECURITY TOO <DIR> 06-12-04 11:53p

Really! Including those blanks in the middle of folder names!
And of course, there was no way I could CD into any of those
directories.
BTW, when I used a standard W98 DOS boot disk, the dir
output looked more normal, like this:

Volume in drive U is TESTINF
Directory of U:\

CHATTOOL <DIR> 01-29-04 9:33p
FILETOOL <DIR> 01-29-04 9:54p
GENERALT <DIR> 07-29-04 9:44p
HWTOOLS <DIR> 07-28-04 11:33p
INTERNET <DIR> 05-18-04 12:06a
KIDSTUFF <DIR> 05-19-04 10:13p
MEDIATOO <DIR> 05-18-04 7:52a
NETWORKI <DIR> 05-18-04 10:44p
PEFORMAN <DIR> 06-07-04 9:35p
PICTURET <DIR> 06-08-04 9:18a
SECURITY <DIR> 06-12-04 11:53p

But CD still failed when I tried CD CHATTOOL.

Any ideas anyone?

Thanks!
Shimon