DOS drivers for cdrom?

vbimport

#1

Whenever i restart in MSDOS mode (Win 98 SE) , i can’t seem to have access to any of my drives (Toshiba 1712 & Yamaha 2100e).

Do i need any dos drivers for these devices to work under DOS ?


#2

Yes you do , you can find them on the Windows 98 startup disk.
I believe it has the OAKCDROM.SYS or something.

You will need MSCDEX.EXE to mount a driveletter for your cdrom drive(s).


#3

So , you’re saying i’ll need to define some parameters
(for example loading Oakcdrom.sys Device=C\WINDOWS\Command\EBDHimem.Sys)
at the properties of command prompt ?


#4

Originally posted by The_Judas
So , you’re saying i’ll need to define some parameters
(for example loading Oakcdrom.sys Device=C\WINDOWS\Command\EBDHimem.Sys)
at the properties of command prompt ?

let’s see if i remember my old dos l33t skillz :bigsmile:

CONFIG.SYS

switches=/f
device=a:\himem.sys /verbose
dos=high,umb,auto
device=a:\oakcdrom.sys /D:OAKCD001

AUTOEXEC.BAT

@echo off
mscdex /d:OAKCD001

Could be wrong with the /D option though ; Check out the config.sys of your Windows 98 disk.


#5

Originally posted by Mr. Belvedere
[B]

let’s see if i remember my old dos l33t skillz :bigsmile:

CONFIG.SYS

switches=/f
device=a:\himem.sys /verbose
dos=high,umb,auto
device=a:\oakcdrom.sys /D:OAKCD001

AUTOEXEC.BAT

@echo off
mscdex /d:OAKCD001

Could be wrong with the /D option though ; Check out the config.sys of your Windows 98 disk. [/B]

Well the /D option is correct, but I remember some dos versions having problems with the “dos=high,umb” statement; replacing it by:
dos = high
dos = umb
helps


#6

umm, ok really dumb but…

Whats l33t ???


#7

in h4x0r talk, l33t = elite.

h4x0r = hacker.


#8

Originally posted by xtacydima
[B]umm, ok really dumb but…

Whats l33t ??? [/B]

A little offtopic here… visit this thread and know everything there is to know about the l33t!


#9

I altered some options and it worked …
This is what i used :


config.sys :

switches=/f
device=C:\WINDOWS\Command\EBD\oakcdrom.sys /D:mscd001
device=C:\WINDOWS\Command\EBD\aspicd.sys /D:mscd001

autoexec.bat :

@echo off
mscdex /D:mscd001

Thanks Mr. Belvedere :wink:


#10

Originally posted by The_Judas
[B]I altered some options and it worked …
This is what i used :


config.sys :

switches=/f
device=C:\WINDOWS\Command\EBD\oakcdrom.sys /D:mscd001
device=C:\WINDOWS\Command\EBD\aspicd.sys /D:mscd001

autoexec.bat :

@echo off
mscdex /D:mscd001

Thanks Mr. Belvedere :wink: [/B]

You’re most welcome.

Remember , you do not need the ASPI drivers if it’s an ATAPI/IDE interface the cdrom device is using. Saves some more bytes we all knew and loved back in the MS-DOS days. :slight_smile:

640kb ought to be enough for everybody :bigsmile: