Does twinpeak still work with NEW CloneCD 4.3.1.7?

Just wondering b/c I haven’t seen anything saying either way (and I don’t know if Slysoft changed the CloneCD format)

Yes. :slight_smile:

Like a charm !!! :bigsmile:

It doesn’t work with SecuROM 4.85 though,

Or am I mistaken???