Does the 1620 have issue with AMD/VIA?

vbimport

#1

I had an issue with my BenQ (originally Philips 8631 from Dell) not recognizing DVD-Rs.

Well I put the drive back into the Dell machine and it works fine, I put it in my machine (AMD T-Bird 1400 w/ VIA chipset) and then it won’t recognize the DVD-Rs.

Is this a known issue and is there a fix for it?

Thanks again for all your help.


#2

It is not just an issue with the 1620. It is an issue with just about every burner out there (CD or DVD). If you have the VIA IDE drivers installed you are asking for trouble. You should use the the standard M$ drivers instead.


#3

Uninstall your IDE drivers and reboot. You should be good to go.


#4

You do this via the “Add Remove Programs” section in control panel, and select Nvidia drivers. You’ll get a dialog asking you which Nvidia drivers to remove - pick the IDE driver to remove it.

It shouldn’t just pick on -R though. I think there’s something else going on there.


#5

Spartane- What does Nvidia have to do with AMD/VIA drivers?


#6

Are you talking about VIA or NVIDIA IDE drivers?

I have M$ for Primary and Secondary IDE and VIA BUS MASTER IDE Controller.

I have never had a problem with can CD or CD burner.

I am confused here?


#7

:bigsmile: Whoops! :eek:


#8

The “P9” firmwares for retail and generic do not conflict with VIA.

However S9 can be some trouble with older VIA chipsets. It’s not that it won’t work with them, but the flasher doesn’t do a great job going through the older VIAs to write flash information to the drive (tried it about 6 times–finally worked right).

Philips (by requesting through Email tech support) can provide some newer Philips firmware for your drive that will update the media list and help it get along with your other computer.

One should consider removing (or installing) unnecessary 3rd party IDE drivers when troubleshooting IDE problems. With VIA, this can be done from the setup portion of their install program at: http://www.viaarena.com


#9

Thanks to all.

My system is rather old, technologically speaking.

I think I will simply upgrade my machine with newer hardware, I’ve been looking for an excuse anyways.

Should I flash back to Philips or stay with BenQ f/w?
Should I be shying away from AMD and toward Intel?
Or is the newer hardware OK with this issues?

Thanks again and Merry Christmas!


#10

I use a 32-bit AMD Nvidia solution and it works fine - very stable and fast. I’ve heard rumblings about possible stability issues with some of the newer 0.9 micron AMD 64-bit CPU chips that have come out over the last 6 weeks or so, but I suspect this will be / is limited to an early generation bleeding-edge teething issue that is most likely corrected by now.

The latest Intel solutions tend to run very hot, but other than this they should work fine.

Merry Christmas to you!


#11

I have AMD/Via - no problem here


#12

… so I would bet you do not have a VIA Apollo KT133 chipset :slight_smile:


#13

as u see from my specs
:slight_smile: , BTW thank u for working on that media list


#14

I uninstalled my IDE drivers and rebooted, but the drive still won’t recognized -Rs.

Do I need to be doing something else?


#15

I have the same problems too. I have a Gigabyte GA-7DXR (AMD 761 + VIA 686B). I am running drivers for the AMD 761 and VIA 686B straight from WinXP. The drive works on my brother’s nForce2 board. Tried installing VIA IDE miniport v3.0.14 as v3.0.20b had problems (from what I read) but that didn’t fix my problems.

I would also like to find a solution to this problem before I go out and buy a new mobo.


#16

I have nforce2 chipset and I am unable to write neiter + nor - with the Nvidia drivers (1620 DVD Writer), switching to MS IDE drivers enable me to write + but not - … Since both media are plentiful I dont care anymore


#17

It wouldn’t be a big deal for me either, I prefer +R because my standalone won’t read -R.

But, I have a quantity of -Rs that I’d like to utilize for backing up large data files.

So if anyone has any ideas, that would be great.

One should consider removing (or installing) unnecessary 3rd party IDE drivers when troubleshooting IDE problems. With VIA, this can be done from the setup portion of their install program at: http://www.viaarena.com

I looked here but didn’t seem to be able to find anything useful, my just be my ignorance in knowing what to look for.


#18

There are some notable small difficulties concerning optical drives in general with the VIA chipsets–with all combinations of software and drivers. However, the newer VIAs featuring SATA have also solved the chronic IDE problems as a bonus. Hooray!

So, if you’re going for a VIA board, make sure it has SATA (even if you don’t use the SATA).


#19

I know this isn’t the answer your looking for but if the off chance you have a motherboard with a VIA 686B southbridge then that could well be the cause of the trouble, the 686B was one of the buggiest southbridges VIA made IMO and its where VIA acquired its image as an unreliable chipset developer even though they have gone to great lengths to shake off that image in recent times.

Do you have the latest bios for your motherboard ? I recall at least some vendors releasing bios updates with some workarounds to offset the flaws in the southbridge.


#20

I believe my MB is a MSI KT7 266Pro-R. (or some name very similiar to that)
I’m not on that machine right now.

Well might I find the newer drivers, I can’t seem to find anything on this board at the MSI site.

I really appreciate all the help everyone has to offer.