DO NOT BIOS UPDATE PX-716SA (Plextor 16x SATA)

vbimport

#1

DO NOT BIOS UPDATE YOUR PX-716SA

This is serious! Don’t update your Plextor SATA DVDRW drive.
On April 27,05, I comfirmed with Plextor tech support that their BIOS update link for PX-716SA is bad.

The link actually leads to a BIOS for PX-716A, it actually makes you think it is one BIOS for all 716XX drive, including USB-external and SATA versions. This is wrong!!
http://www.plextor.com/english/support/support_downloads.html

If you flash it with your 716SA, it will change the BIOS to 716A (PATA ver.), and the drive cannot read DVD anymore. Reading CD seems still working but buggy.

Poor me flashed it, and called tech support and they comfirmed it is a mistake. I actually went to Plextor.co.jp (Plextor Japan, where the Plextor was originally engineered) to look for a correct BIOS, and the Jap site has the same error linking problem.

The mistake is there since the 1.04 version of BIOS. There is no internet link where I can find the old version for the SATA DVDRW drive.

My first call to Plextor, tech-sup told me that they will replace it for free, since they don’t have any correct version of BIOS for 716SA. They will pay for the shipping by arranging UPS pick up as well. I accpeted it, and then I regreted about it right after I hung up the phone. Becaus I could end up getting an RAM drive (Refurb). Hell, NO!

So I called the Plextor tech-sup again, and after all the troublesome, the supervisor promised me a brand new drive will be specially requested to ship it to me. No advance replacement tho!

I don’t get this: almost after one (1) month of releasing the new driver, on one have found out about this??

Bottom line: The plextor tech sup said they will work with Plextor’s webmaster ASAP to remove the links for all PX-716SA update (I hope so). How sad there is never a working BIOS for 716SA on internet.

Please let me know if anyone out there have similar problem. This is the first and only post I will make, so please pass on the message, because I don’t know when Plextor will update their error web link.

My system config:
P4 660
ASUS P5AD2-E-P
2GB Corsair Twin2x-5400
Nvidia Quadro FX 4400
4x WD Raptor 74
PX-716SA
OCZ ModStream520


#2

JosephDoc, welcome to the forums. Since you posted this message in another thread as well I’m just going to quote myself. I will try to contact Plextor Europe and ask them if they are aware of this serious problem.


#3

Yeah, I questioned 2 tech-sup for more than 10 times why no one complained… Justin were the one comfirmed about the wrong Bios lead, and John followed up to compensate me the brand new drive replacement with approved from their supervisor.

Very funny :iagree: … they said there wasn’t any complain. So I assum who ever has a 716SA with V1.06 is BSing, or I am telling funny story here.

I am new here to warm 716SA owners. I googled my way here and wish this is the right place to have the message pass around. I noticed my drive failed a few weeks ago right after I flashed with 1.06, then I never used it again and did most of DVDR jobs with my other machine. I found the problem because I tried a few DVDs from Blockbuster and none of the DVDs could be played.

BTW, there are something that is out of scope but I think I should mention at here as well. I found out the tech-sup department of Plextor USA is not really the dedicated tech-sup for Plextor; they also doing tech-sup for some Pc systems and some other Pc components. Evenmore, it seems like they use the DOT-COM as their library just like us. I am a 10+ yrs Plextor fan, and I feel “not too good” about what I have found out, but I will still be a Plextor fan as long as the industrial is still building array burnners with Plextor drives.

I just run the V1.06 downloaded from Europe site without my 716SA drive(packed and ready to go). The flash window has the same message… “for Model PX-716A” even the link is listed as “Firmware upgrades for PX-716A/SA/UF”. You can also try it and it will not hurt becaus there is a confirm-to-flash buttom. So, so far I have tried links in sites of Usa, Jp, China, and Eur now and I bet Aus will be the same.

I think some one will actually flash it to make their 716SA change into a buggy CDRom drive, and take the free ride to get a new drive.

Good luck. :rolleyes:


#4

We of course appreciate the warning JosephDoc. I will try to contact my contact over at Plextor Europe and pass him your information. If he lets me know anything I’ll post it here.

I just run the V1.06 downloaded from Europe site without my 716SA drive(packed and ready to go). The flash window has the same message… “for Model PX-716A” even the link is listed as “Firmware upgrades for PX-716A/SA/UF”.
This is normal and as far as I know, this has always been the case. I can flash my PX-716UF just fine with the PX-716A firmware, even though the firmware flash program doesn’t mention the PX-716UF drive.


#5

Strange. I have a PX-716SA that I upgraded to firmware 1.06 from the same link in message #1 at it reads DVD discs perfectly.


#6

Same here I updated to 1.06 from that link and have had no problems.


#7

No problems here also.


#8

I update to 1.06 My PX-716SA is just perfect read and write any cd try i,no problem here


#9

I am sorry and I want to take my words back now.

Hmm…
Can you guys (Rjih, Drew, Pelli) check under DeviceManager/DvdCdRomDrives, to ID your drives. My 716SA was listed as 716A after I flashed, and the drive is alive that it still takes all ver. of BIOS and stays as 716A, but only acts as a buggy CDRom drive.

Actually there is another dude is experiencing the drive listed as 716A, although I don’t know if he is seening his drive functioning normally.
Check member feedback from Zone83X
http://club.cdfreaks.com/showthread.php?t=135406

Now there could be anohter possible factor that I did not think of. I think 716SA could have different models and I have the one just don’t eat the right tag.

Ok, I just ripped open the RMA package. The label prints:

Made In China…127-3513-00
December 2004
S/No. 507xxxxxx864
…TLA#0304
507xxxxxx8645…BCC

Ring any bell? Don’t bother to take it out from your chassis… lol.
I bought it from BestBuy in Jan this yr. It is almost May now and I think I only crated 2 DVDs so far and that was before April.
I dont think hardware configuration matters but here it is…

P4 660
Asus P5AD2E Pre
2GB Corsair Twin2x5400
Nvdia Quadro FX 4400
4x WD Raptor 74
Funny 716SA
2x 2405FPW (lol)
Ocz ModStream520

Grr… Lucky me huh!


#10

Everything lists the 716/712SA as the A (PATA) model, everything except Plextools, it is the only thing that actually reads them as SATA version’s Nero, Clone, Blindwrite, Windows, Roxio, Alcohol none of these see’s them as SATA drives.


#11

The SATA is the 716A with a SATA bridge chip. I think your problem may have been corrupted firmware or a marginal drive to begin with. Feedback looks like you just were the victim of a bad upgrade. S–t happens…


#12

Really? I never look at any software that comes with my Plextors in last 10 yrs… lol. But I think the dude I mention above, he said he is seening his 716SA as 716A in PlextorTool(<------Do you guys really use this?)


#13

:iagree: :iagree: :iagree:

Yes. :bigsmile: (btw, it is called PlexTools Professional)

Regards,

ET


#14

Below is how my PX-716SA is displayed in PlexTools Professional, Device Manager and Nero.





#15

A Plextor drive and no PlexTools… shame on you! :stuck_out_tongue:


#16

The drives are all the same - only the interfaces have been changed to protect the innocent…

.bh.


#17

plextor :cop:



#18

benq :iagree:



#19

http://www.plextor.com/english/support/downloads/firm_716.htm

I really doubt that their is a difference between Firmware versions since the US site has the same link for all three 716s.


#20

So Plex XL works with all drives, not just Plextor???