DMA under Windows 2000 on SiS 730s

vbimport

#1

Big problem. My hard drive can't access DMA, although my CD-writer can. Hard drive is currently in PIO mode 4 (stinks). My hard drive can barely supply enough data to write at 4x!. It's a 10GB IBM drive, UDMA/66. On a (I think) matshita board with the SiS 730s chipset. Help me! I believe it may be an incompatibility with Windows 2000 (it's not MS's fault this time, the OS came out before the chipset). Sis FAQ actually has something about it, though it is a bit cryptic.

  1. In SiS desktop products ( SiS 5598, 5591, 5600, 530, 620, 540, 630...), how to enable DMA mode under NT 4.0 ? And how to enable DMA mode in Windows 2000 professional?
    A: (1).First, please install NT 4.0 Service Pack 6, then execute the following steps to enable DMA:
    Execute the DMACHECK.EXE program on the Windows NT 4.0 Service Pack 6 (SP6) CD from the \support\utils\i386\ directory. DMACHECK.EXE will indicate if DMA is enabled on the primary or secondary IDE channel. Click the Enabled option to enable DMA for the UDMA-capable hard drive.
    Reboot the system. Execute the DMACHECK.EXE program again to verify that DMA was successfully enabled.
    (2)In order to enable the DMA mode in Windows 2000, please make sure that the ASL code has been implemented in system Bios or not. You may contact the board maker to get the details.

I did a little research and the ASL code is ACPI System Language or something related to ACPI. ACPI is enabled, installed, but nothing. And no, Installing Windows 98 is not an option, this is a shared computer and I need it stable.

If anyone has a solution, PLEASE respond.


#2

I can only help you enable DMA under Windows 2000, pls do the following:

Go to “Control Panel” then “Administrative Tools” then “Computer Management” on your left side click on “Device Manager” then on your right go to “IDE/ATA/ATAPI Controllers” now double click on either “Primary IDE Channel” or Secondary IDE Channel" from here you will find how to enable or disable DMA and/or PIO.

Hope this helps.


#3

no, it’s not that I don’t know how to enable dma. the problem is that I CAN’T enable DMA. With “DMA if available” selected it chooses PIO. This drive can use DMA and has used DMA in other systems. Under the secondary channel, the CD-ROM is using Ultra DMA mode and the CD writer is using DMA mode. It just won’t enable for the hard drive, which means the cd drives are crap past 4x. it took me an hour to install office 2000! the cd slows down and waits for the hard drive!


#4

Have you downloaded any utilities from ibm for yuor hard drive? They have a “Feature Tool” program that can switch on the UDMA, go to:
http://www.storage.ibm.com/hdd/support/download.htm