DMA unavailable?

vbimport

#1

Hi,

I have a LiteOn DVD-ROM and an LG CDRW Burner, both connected to the secondary IDE channel.

I read the thread about enabling DMA, so in the “Transfer Mode” box I chose “DMA If Available” for both drives and restarted. It worked for the LG, but in the LiteOn the "current transfer mode " is always “PIO Only”, eventhough “DMA If Available” is selected. Does anyone know why?

Thanks in advance.


#2

I assume you have rebooted. If so, then go back to the device manager and uninstall the IDE Controllers. Then restart and let the computer find them and install again and that should solve your problem.


#3

Thanks, but it didn’t work. The strange thing is that I switched the master/slave thing on the drives, and the slave is always the one that doesn’t use DMA.


#4

here is something I wrote up about DMA back in 2002 that might help it tells you how to change it in the registry. I checked and the same registry key still controls the DMA so this should work.

Had not made a cd in months and when I did at high speed got errors and a defag seem to fix that problem next time I will test and record instead of record only.

I did also check my DMA settings and found that my main hardrive DMA settings were set to PIO only and Had to follow the procedure below to correct. I hate that xp will change these settings without any help from you.

To enable DMA mode using the Device Manager:

start then control panel then system hardware to

Open Device Manager.

Double-click IDE ATA/ATAPI Controllers to display the list of controllers and channels.

Right-click the icon for the channel to which the device is connected, select Properties, and then click the Advanced Settings tab.

In the Current Transfer Mode drop-down box, select “DMA if Available” if the current setting is “PIO Only”.

If the drop-down box already shows “DMA if Available” but the current transfer mode is “PIO Only”, then the user must toggle the settings.

That is:

Change the selection from “DMA if available” to “PIO only”, and click OK. Then repeat the steps above to change the selection to “DMA if Available”.

I found this did not work on one of my hardrives and had to use the following steps. I found that the hardrive did not have the 0xffffffff. When you right click and modify to change it to the above you only input the ffffffff not the 0x. I changed it then I could change from PIO Only.

Go to

“HKEY_LOCAL_MACHINE\SYSTEMS\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}”

The Default Value should be “IDE ATA/ATAPI controllers”

Go to “0001” key if your device is on Primary IDE Chanel or “0002” if your device is on Secondary IDE channel

and change the MasterDeviceTimingModeAllowed or SlaveDeviceTimingModeAllowed to 0xffffffff depending if your device is master or slave

close registry editor.

Go to device manager select “IDE ATA/ATAPI controllers” and the corresponding IDE chanel go to “Advanced Settings” Tab and Set Transfer Mode to PIO and then to DMA if available again


#5

http://www.michna.com/kb/WxDMA.htm

http://support.microsoft.com/?kbid=817472

Two more sources for override.


#6

Have you checked the BIOS to make sure the drives are set to AUTO detect? Save BIOS setting and reboot to windows.


#7

setting to auto does not always work on all computers you have to set it to cdrwin bios.