DMA setting not holding

I currently have a Lite-on 1693S burner. One issue I am having is keeping the Ultra DMA4 setting under the primary IDE. For some reason, it occasionally jumps back to the PIO setting. My first question is why this is happening? The second is how to remedy this. In the BIOS the primary IDE channel is set to auto. Would it be better to actually set it to UDMA4? I am hesitant to force that if it could create more problems.
I did notice on the Microsoft knowledge base that is there are errors during date transfer, Windows will turn off the DMA mode. Maybe the culprit??
Any assistance would be appreciated.

Some users solved this issue uninstalling and reinstalling IDE drivers.

I don’t know the exact procedure, but they claim that it work

Take a look also here

You could try slowing things down a bit as well. Also do a search in here on the topic of occasional verses sustained data transfer errors and the registry fixes that can help. Even Microsoft has pointed out this flaw.

ps: play nice in your registry, it can be your undoing :iagree:

Yea, I should have been that I have(more than once) removed the Primary IDE and reinstalled it. And that did work for awhile. Then it has jumped back to PIO transfer.

If you have a damaged IDE cable, maybe this can cause ripetitive slowing of data flux, so windows revert automatically in PIO mode.

Check cables, and try also to use 80 wire cables to see if this solve the problem

Are you using nVidia IDE drivers or STD MS IDE drivers?

Standard drivers

What about cables?

80

As geno888 points out XP will downgrade the DMA setting if it experiences errors. It might be worthwhile trying a new cable as this has been known to fix this type of problem.

No doubt…getting a new cable is first thing I should do. This is a new burner, so I don’t think I am starting to get hardware failure. My research has let me down the path of registry adjustments and other temporary fixes. But getting to the source of the errors in reading/writing is obviously the only way to permanently fix the problem. The good thing from the responses I recieved, it that is doesn’t appear to be a burner problem. And that is what I needed to know.

Keep us updated if you’ll solve the problem :slight_smile: