DMA reverts to PIO all the time

vbimport

#1

On a VAIO RB57GY [Costco special] no longer available
[http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=8810889150&ssPageName=MERC_VIC_RSCC_Pr4_PcY_BID_Stores_IT](Sony Vaio RB57GY example)

I replaced the Sony Reader and "Sony"Writer which was a Sony firmwared Pio110, with TWO Benq1650s. I set the PrimaryIDE interface to DMA if available and it stays at or reverts back to PIO all the time.

I have tried all the great suggestions on the following two pages, I am not a noob.

http://users.bigpond.net.au/ninjaduck/itserviceduck/udma_fix/

http://www.cdrlabs.com/phpBB/viewtopic.php?t=6645

Any thoughts on why the Benq are just not being read right, whether the VAIO is just so locked down that they are not recognizing the Benq. The bios on the VAIO is also no help, again very minimal settings.

Is there a setting I am missing to force it all the time to DMA?

Thanks in advance for your help


#2

Make sure you are working with correct IDE channel. Your mobo also has SATA connectors that show can up as “IDE channel” in your device manager.

Use Nero InfoTool to confirm your configuration.


#3

System specs? OS, current on all updates and service packs, etc?

Although this may be jumping the gun, I know AnyDVD will make sure your drive runs with DMA on…just one of the perks.


#4

System is virtually new, Auto updates performed.

I will try AnyDVD as soon as I get a chance.

Those two links were very helpful to get it to DMA temporarily, but it does not hold through a reboot. I understand the whole thing of mode step down because of errors.

Is there some Benq specific driver I should look into?

TIA
m.


#5

OK tried AnyDVD and see all the great features but cannot see anything to force the mode to DMA. Any help appreciated.


#6

It is not an option in the program, AnyDVD just does this. It was discussed by James as an “added bonus” if you will. Basically it’s a Windows bugfix. Try a transfer rate or burst rate test in Nero CD/DVD Speed to test it out with AnyDVD running.


#7

I did as you suggested and ended up with a burn rate that maxed @ 1.68, mind you that in Primary IDE, all I have on this machine, but were set for DMA if avail, but showed PIO.
So, I did the usual recovery, in registry, delete the Master and SlaveCheckSum values, delete both hard drives, Turn computer OFF not reboot, Restart and in primaryIDE both drives now show as UDMA2 and CDSpeed shows starting at 6.69 and running out to an expected 16 on a FUJI 16x. But if I reboot, it is all back to PIO.


#8

Wow…this is a tough one. Can you post everything you have starting up with your computer? Msconfig would probably be the easiest way to do this, screenshot maybe…

Also, do you have any IDE Busmaster drivers running? Common ones would be Intel Application Accelerator or NVIDIA’s IDE drivers.


#9

Get in to your system bios and see if all your drives UDMA are set at “Auto” if not try to set them at Auto.


#10

Hi,

at first try only one 1650 and see, if that works. Wintendo sometimes has problems if there are two identical ODD installed. It might help in that case, if the drives have different firmware versions.

Michael


#11

it seems like the system in some respect did not like seeing two of the same drives. I now have a Pio110 and BenQ1650, and the Pio shows as UDMA4 and the BenQ as UDMA2. Any idea why the difference and why the two same drives caused the problems? thanks for the help.


#12

Pioneer 110 has an UDMA4 Host Interface and should run in that mode, always.
The 1650 (AFAIK) ‘only’ supports up to UDMA2, so all seems to be fine.


#13

This program can do all of the registry digging stuff described on these pages.