DMA problems! nd-3520a Stuck in PIO! Please help

vbimport

#1

Hello,
Having just completed my current build, I was excited to get it up and running, and although it does, I still have this one problem plaguing me.
My NEC ND-3520a, working fine for about 7 months or so now, is giving my a lot of problems in this current config. My slave drive on the secondary channel works fine in UDMA, but my DVD burner only seems to read DVD’s in PIO mode.
First off, my setup:

AMD Athlon 3500+
Asus A8N-SLI Premium
Gigabyte 7800GTX
2gb Corsair pc3200
500w Antec PSU
ND-3520a [Master]
Some DVD/CD-RW Combo drive [Slave]
1 80gig Maxtor hdd [Master], 1 30gig WD hdd [Slave]
All drives are connected via IDE

Things I have tried:
-Formatting, Reinstalling Windows XP Pro
-Uninstalling the secondary IDE channel in Device Manager
-Playing with the NF4 drivers, using Nvidia’s own IDE drivers, and also using Microsoft’s

-Flashing my ND-3520a to an ND-3520aw [Newest Firmware]

The drive works fine, both before and after firmware upgrade, but only in PIO mode. I can force it into UDMA, but only after I uninstalled the secondary channel, and then it wouldn’t read DVD’s - just CD’s. The motherboard has the newest BIOS version.
If someone could possibly help get me rolling, I would greatly appreciate it.


#2

Remove the combo, try again.


#3

You can try to disconnect the Combo drive (for test purposes) and just leave the Nec as the only drive on that IDE channel then see if the Nec in fact works in UDMA2. I had a similar problem with my Nec 3520A and a Lite On Combo drive. If the combo drive was installed as slave the Nec would not even show up. Turns out the Combo is UDMA3 so putting the Combo as Master on the secondary and the Nec as slave worked fine (VIA chipset though). Some drives that are PIO mode only will drag the others on that channel to PIO as well. Let us know.:slight_smile:

EDIT: chef beat me to it.:stuck_out_tongue:


#4

No worries. :wink: